封面

三汇SMG系列光口网关

SMG3064

光口网关

用户手册

Version 1.7.0

杭 州 三 汇 信 息 工 程 有 限 公 司

www.synway.cn


目 录

目 录... i

版权申明 iv

版本修订记录... v

第1章 产品介绍... 1

1.1 应用场景图.. 1

1.2 功能列表.. 1

1.3 硬件描述.. 2

1.4 告警信息说明.. 4

第2章 基本使用... 5

第3章 WEB配置... 9

3.1 登录系统.. 9

3.2 运行信息.. 10

3.2.1 系统信息.. 11

3.2.2 PSTN线路状态.. 13

3.2.3 SS7服务器信息.. 15

3.2.4 呼叫监控.. 18

3.2.5 呼叫统计.. 19

3.2.6 筛号统计.. 20

3.2.7 光口告警.. 21

3.2.8 告警信息.. 21

3.3 SIP设置.. 22

3.3.1 SIP设置.. 23

3.3.2 SIP中继.. 26

3.3.3 SIP注册.. 28

3.3.4 SIP账户.. 30

3.3.5 SIP中继组.. 32

3.3.6 媒体设置.. 35

3.4 PCM设置.. 37

3.4.1 PSTN线路设置.. 39

3.4.2 电路维护.. 41

3.4.3 通道闭塞.. 42

3.4.4 PCM设置.. 42

3.4.5 PCM中继组.. 44

3.4.6 收号规则.. 46

3.4.7 收号超时.. 49

3.4.8 号码归属地.. 50

3.4.9 PSTN呼转号码表.. 52

3.5 ISDN设置.. 53

3.5.1 ISDN设置.. 54

3.5.2 号码参数设置.. 56

3.5.3 改发号码池（默认隐藏）.. 56

3.6 SS7设置.. 57

3.6.1 TUP设置.. 57

3.6.2 TUP号码参数.. 59

3.6.3 ISUP设置.. 61

3.6.4 ISUP号码参数.. 63

3.6.5 原被叫号码池.. 66

3.6.6 改发的号码池（默认隐藏）.. 67

3.6.7 SS7服务器设置.. 69

3.7 传真设置.. 74

3.7.1 传真参数.. 75

3.8 路由设置.. 76

3.8.1 IP to PSTN路由.. 76

3.8.2 PSTN to IP路由.. 78

3.9 号码过滤.. 80

3.9.1 白名单.. 80

3.9.2 黑名单.. 83

3.9.3 号码池.. 84

3.9.4 过滤规则.. 85

3.10 号码变换.. 87

3.10.1 IP to PSTN主叫变换.. 88

3.10.2 IP to PSTN被叫变换.. 91

3.10.3 IP to PSTN原被叫变换.. 91

3.10.4 PSTN to IP主叫变换.. 91

3.10.5 PSTN to IP被叫变换.. 94

3.10.6 PSTN to IP原被叫变换.. 94

3.10.7 主叫变换号码池.. 94

3.10.8 主叫号码变换保留池.. 96

3.11 系统工具.. 97

3.11.1 网络设置.. 98

3.11.2 授权管理.. 100

3.11.3 管理参数.. 101

3.11.4 IP路由表.. 102

3.11.5 访问控制.. 104

3.11.6 证书管理.. 105

3.11.7 集中管理.. 106

3.11.8 筛号管理.. 108

3.11.9 SIP账号生成工具.. 109

3.11.10 录音管理.. 109

3.11.11 配置文件.. 111

3.11.12 信令抓包.. 112

3.11.13 呼叫测试.. 113

3.11.14 呼叫跟踪.. 114

3.11.15 网络测速.. 115

3.11.16 PING测试.. 116

3.11.17 TRACERT测试.. 117

3.11.18 修改记录.. 118

3.11.19 备份载入.. 118

3.11.20 恢复出厂.. 119

3.11.21 软件升级.. 119

3.11.22 更改口令.. 120

3.11.23 设备锁定.. 120

3.11.24 重启网关.. 121

第4章 典型应用配置案例... 122

4.1 典型应用一.. 122

4.1.1.1 总部网关配置.. 123

4.1.2 分支机构A网关配置.. 126

4.1.3 分支机构B网关配置.. 129

4.2 典型应用二.. 133

4.2.1 总部网关配置.. 133

4.2.2 分支机构网关配置.. 136

附录A 主要技术/性能参数... 137

附录B 常见问题... 138

附录C ISUP (ISDN)挂起原因到SIP状态码对应表... 139

附录D TUP挂起原因到SIP状态码对应表... 141

附录E CDR使用说明... 142

附录F 技术/销售支持... 143


版权申明

本文档版权属杭州三汇信息工程有限公司所有。

杭州三汇信息工程有限公司保留对此文件进行修改而不另行通知之权利。

杭州三汇信息工程有限公司承诺所提供的信息为正确且可靠，但并不保证本文件绝无错误。

请在使用本产品前，自行确定所使用的相关技术文件及规格为最新有效之版本。若因贵公司使用本公司之文件或产品，而需要第三方之产品、专利或者著作等与其配合时，则应由贵公司负责取得第三方同意及授权。关于上述同意及授权，非属本公司应为保证之责任。


版本修订记录

版本号 | 发布日期 | 修订内容
Version 1.6.3 | 2016.04 | 新创建此文档。
Version 1.6.4 | 2016.09 | 修订此文档。
Version 1.6.5 | 2017.06 | 修订此文档。
Version 1.7.0 | 2018.06 | 修订此文档。

请访问我们的网站（www.synway.cn）以获取该文档的最新版本。


第1章 产品介绍

欢迎使用三汇SMG系列光口网关产品（以下简称SMG光口网关）。SMG光口网关用于连接PSTN和企业交换机到基于IP的电话网络或IP PBX。SMG光口网关为大容量IP呼叫中心和多分支机构提供功能强大、稳定可靠和高性价比的VoIP解决方案。目前SMG系列光口网关产品主要包括SMG3064。


1.1 应用场景图

图 1‑1 SMG光口网关应用场景图


1.2 功能列表

基本功能

说明

PSTN呼叫

PSTN线路呼入，经过路由和号码变换，连接指定的SIP中继进行语音通信

IP呼叫

IP线路呼入，经过路由和号码变换，连接指定的PCM中继进行语音通信

号码变换

删减号码头部或尾部的数字，或者对号码添加前缀或后缀

PSTN/ VoIP路由

用户可以设置路由路径，从IP到PSTN或从PSTN到IP

传真

用户可以设置传真模式、最大传真速率、训练方式、纠错模式等传真参数

回波抵消

在通话过程中提供回波抵消功能

信令和协议

说明

7号信令

7号信令TUP协议、7号信令ISUP协议

ISDN协议

ISDN用户侧、ISDN网络侧

SIP信令

兼容的协议：SIP V1.0/2.0、RFC3261

语音

音频编解码 式 | G.711A、G.711U、G.729、G722、G723、iLBC、AMR-NB、SILK(16K)、OPUS(16K)、SILK(8K)、OPUS(8K)
DTMF模式 | RFC2833、SIP INFO、INBAND、RFC2833+信令、带内+信令

传真

传 模式 | T.38、Pass-Through
波特率 | 14400bps、9600bps、4800bps

网络特性

说明

网络协议

TCP/UDP、HTTP、ARP/RARP、DNS、NTP、TFTP、TELNET、STUN

静态IP

IP地址修改

DNS

域名解析

安全性

说明

管理认证

支持管理员认证确保资源和数据的安全性

维护升级

说明

WEB配置

通过WEB界面修改配置

支持语言

中文，英文

软件升级

基于WEB的用户界面、网关服务、内核及固件升级

跟踪测试

基于WEB的Ping测试和Tracert测试

SysLog类型

ERROR、WARNING、INFO


1.3 硬件描述

SMG光口网关采用1U高度标准机架式设计，并在ARM+DSP的硬件架构中提供LINUX嵌入式系统。网关机箱支持1个光纤接口和2个千兆以太网口。产品外观示意图如下：

图 1‑2前面板示意图

图 1‑3 后面板示意图

图 1‑4 左侧示意图

上图中各接口、按键及指示灯的详细介绍如下：

接口 | 说明
网络接口 | 数量：2个
 | 类型：RJ-45
 | 带宽：10/100/1000 Mbps
 | 自适应带宽：支持
 | 自动翻转：支持
光纤接口 | 数量：1
 | 类型：STM-1
串口 | 数量：8
 | 类型：RS-232
 | 波特率：115200 bps
 | 接口类型：USB
 | 数据位：8 bits
 | 停止位：1 bit
 | 校验：无
 | 流控：无
按键 | 说明
电源开关 | 开启/关闭SMG光口网关，两个电源开关同时打开，实现电源主从热备份功能
恢复出厂设置按键 | 将SMG光口网关恢复到出厂设置状态
指示灯 | 说明
电源指示灯 | 指示电源状态，开机通电后点亮
运行状态灯 | 指示设备运行状态，具体说明见1.4告警信息说明
告警指示灯 | 指示设备异常，告警，具体说明见1.4告警信息说明
Link指示灯 | 网络指示灯中的绿色LED指示灯，用于指示网络连接状态
ACT指示灯 | 网络指示灯中的黄色LED指示灯，该指示灯闪烁表示数据正在传输
LOS指示灯 | 光纤模块同步成功，LOS指示灯（黄绿色LED）常灭

注意：串口用于SMG光口网关的调试，本设备串口通过双公头USB线连接，每个USB口转4个串口，共8个串口。其它硬件参数请参考附录A 主要技术/性能参数。


1.4 告警信息说明

SMG光口网关提供两个指示设备运行状态的LED指示灯：运行灯与告警灯。运行灯为绿色，告警灯为红色。指示灯的状态及含义说明如下：

指示灯 | 状态 | 含义
运行灯 | 熄灭 | 系统未启动
 | 点亮 | 系统正在启动
 | 闪烁 | 设备正常运行
告警灯 | 熄灭 | 设备无异常
 | 点亮 | 启动时：设备正常 运行中：设备异常
 | 闪烁 | 设备异常

说明：

l 开机过程包括系统启动和网关服务启动两个阶段。系统启动过程大约持续1分钟，系统启动成功后，运行灯与告警灯均点亮。网关服务启动成功，设备正常运行后，运行灯闪烁，告警灯熄灭。

l 运行过程中，告警灯点亮或者闪烁表示设备异常，用户如果无法自行排除故障，请联系我公司的技术人员处理故障，技术支持联系方式见附录F技术/销售支持。


第2章 基本使用

本章节旨在帮助用户于最短的时间内掌握SMG光口网关产品的基本使用方法。

第一步：确认产品包装盒内包含以下物品。

l SMG光口网关机箱1台

l 脚垫6个、挂耳螺丝8颗、前角板2个、后角板2个、接地线1根、直通屏蔽网线2根

l 220V电源线2根

l 保修卡1份

l 安装手册1份

第二步：固定SMG光口网关机箱。

如果不需要安放到机架上，先安装6个脚垫；如果需要安放到机架上，先将前角板安装到机箱上，再配合后角板将机箱安装到机架上。

第三步：连接机箱电源。

在连接机箱电源之前，务必确认可靠接地。先查看电源插座是否有接地线；如果没有，可以通过机箱后侧的接地螺柱（如 图 1‑3 所示）接地。

注：每个SMG光口网关有两个电源接口，满足电源主从热备份功能需求。正确连接并开启两个电源后，当一个电源出现故障时，另外一个电源也能保证网关的正常工作。

第四步：接入网线。

第五步：连接光纤。本设备采用双LC接口。

第六步：登录网关。

通过浏览器输入SMG光口网关的初始IP地址（LAN1初始IP地址：192.168.1.101；LAN2初始IP地址：192.168.0.101），进入SMG光口网关。具体登录方法见3.1登录系统，SMG光口网关的初始用户名为admin，初始密码为admin。用户在初次登录后，应尽快通过“系统工具 à 更改口令”界面修改初始用户名及密码。用户名、密码修改方法见3.11.22更改口令。用户名及密码修改后，需要重新登录。

第七步：修改网关的IP地址。

通过“系统工具 à 网络设置”界面修改IP，使之融入公司的局域网中。IP地址的修改方法见 3.11.1网络设置 。IP地址修改后，需要使用新设置的IP地址重新登录。

第八步：设置PCM信令类型。

初次使用光口网关时，必须准确配置PCM的信令方式及连接类型。信令方式、连线类型需要与物理连线类型一致；其余配置项可暂时采用默认值。PCM设置具体说明见3.4.4 PCM设置。

注意：完成此步骤后，需要重启网关服务使配置生效，操作方法见3.11.24重启网关。

第九步：设置信令协议参数。

当网关配置不同的信令协议时，需要在不同的界面进行设置，具体操作说明如下：

l 7号信令-ISUP：

说明：为方便用户理解及操作，此步骤不涉及ISUP准直联。准直联的具体说明见3.6 SS7设置。

此时需要设置的界面包括ISUP设置，以及SS7服务器设置两个部分。

初次使用光口网关时，ISUP设置界面各配置项均可采用默认值。SS7服务器设置界面必须准确配置，否则可能导致通道故障。SS7服务器配置可按以下步骤进行：

1. 设置OPC、服务器IP地址和信令点码编码标准。OPC一般由电信局分配；服务器IP地址可采用默认值；信令点码编码标准中国用户使用默认值24。修改完成后，点击配置项右侧的“修改”按钮保存配置。

2. 修改信令链路，或在信令链路列表右下方点击“添加链路”按钮添加信令链路。物理地址选择实际传递信令的PCM（E1接口）。随后点击“保存”即可。当网关上只连接一条信令PCM时，只需要设置一条信令链路。

3. 修改信令链路组，或在信令链路组列表右下方点击“添加链路组”按钮添加信令链路组。勾选第2步中添加的信令链路；其余配置项均可使用默认值。随后点击“保存”即可。

4. 修改DPC，或在DPC设置界面下方点击“添加DPC”按钮添加DPC。信令点码需要填写对端（即信令目的点）的信令点码。对应链路组选择第3步中添加的链路组；其余配置项均可使用默认值。随后点击“保存”即可。

5. 修改CIC路由，或在ISUP_CIC路由设置列表右下方点击“添加ISUP_CIC路由”按钮添加CIC路由。对应DPC选择第4步中添加的DPC；对应PCM的CIC_PCM编号需要按照交换机的分配情况进行设置，其余配置项均可使用默认值。随后点击“保存”即可。当网关上使用多条语音PCM时，需要设置多条ISUP_CIC路由。

注意：完成7号信令-ISUP相关界面的配置后，需要重启网关服务使配置生效，操作方法见3.11.24重启网关。

l 7号信令-TUP：

说明：为方便用户理解及操作，此步骤不涉及TUP准直联。准直联的具体说明见3.6 SS7设置。

此时需要设置的界面包括TUP设置，以及SS7服务器设置两个部分。

初次使用光口网关时， TUP设置界面各配置项均可采用默认值。SS7服务器设置界面必须准确配置，否则可能导致通道故障。SS7服务器配置可按以下步骤进行：

1. 设置OPC、服务器IP地址和信令点码编码标准。OPC一般由电信局分配；服务器IP地址可采用默认值；信令点码编码标准中国用户使用默认值24。修改完成后，点击配置项右侧的 “修改”按钮保存配置。

2. 修改信令链路，或在信令链路列表右下方点击“添加链路”按钮添加信令链路。物理地址选择实际传递信令的PCM（E1接口）。随后点击“保存”即可。当网关上只连接一条信令PCM时，只需要设置一条信令链路。

3. 修改信令链路组，或在信令链路组列表右下方点击“添加链路组”按钮添加信令链路组。勾选第2步中添加的信令链路并设置对应的OPC地址；其余配置项均可使用默认值。随后点击“保存”即可。

4. 修改DPC，或在DPC设置界面下方点击“添加DPC”按钮添加DPC。信令点码需要填写对端（即信令目的点）的信令点码。对应链路组选择第3步中添加的链路组；其余配置项均可使用默认值。随后点击“保存”即可。

5. 修改CIC路由，或在TUP_CIC路由设置列表右下方点击“添加TUP_CIC路由”按钮添加CIC路由。对应DPC选择第4步中添加的DPC；对应PCM的CIC_PCM编号需要按照交换机的分配情况进行设置，其余配置项均可使用默认值。随后点击“保存”即可。当网关上使用多条语音PCM时，需要设置多条TUP_CIC路由。

注意：完成7号信令-TUP相关界面的配置后，需要重启网关服务使配置生效，操作方法见3.11.24重启网关。

l ISDN用户侧/网络侧：

此时需要设置的界面为ISDN设置。初次使用光口网关时，ISDN设置界面各配置项均可采用默认值。

注意：完成ISDN设置界面的配置后，需要重启网关服务使配置生效，操作方法见3.11.24重启网关

第十步：检查通道状态。

完成信令配置后，用户可以通过“运行信息 à PSTN线路状态”界面检查通道状态，通道各状态的具体说明见3.2.2 PSTN线路状态。如果端口的0时隙状态为帧同步，信令时隙状态为信道，其它通道状态均为空闲，表明该端口配置正确。如果通道状态为故障（0时隙、信令时隙）或不可用（其它通道），可能是信令协议配置错误，建议返回第九步，检查信令协议的配置。

第十一步：设置呼叫路由。

说明：为方便用户理解及操作，此步骤的所有示例均不涉及注册操作。

第一种：IPàPSTN

1. 在配置中添加与网关进行通信的SIP终端IP地址，此IP范围以外的终端呼入网关，网关不会响应。操作方法见“SIP设置 à SIP中继”。设置界面中的“远端地址”和“远端端口”分别填写呼入的SIP终端的IP地址和端口，其余选项均可采用默认值。
举例：假设呼入的SIP终端的IP地址为192.168.0.111，端口为5060。新增 SIP中继0，填写远端地址为 192.168.0.111，远端端口为 5060。

2. 将第1步中添加的SIP终端的IP地址加入到对应的SIP中继组。操作方法见“SIP设置 à SIP中继组”。设置界面中的“选择SIP中继”需要选择第1步中设置的SIP中继，其余选项可以采用默认值。
举例：新增 SIP中继组0，选择 SIP中继勾选 0，其余配置项不修改，采用默认值。

3. 将不同的PCM加入对应的PCM中继组。操作方法见“PCM设置 à PCM中继组”。设置界面中的“PCM”选择需要进行语音通信的PCM，其余选项可以采用默认值。
举例：假设需要进行语音通信的PCM中继为PCM[1]。新增 PCM中继组0，勾选 PCM[1]，其余配置项不修改，采用默认值。

4. 添加呼叫路由。使用第2步中设置的SIP中继组做为呼叫来源，第3步中设置的PCM中继组做为呼叫目的。操作方法见“路由设置 à IPàPSTN路由”。设置界面中的“呼叫来源”和“呼叫目的”需要进行相应选择，其余选项可以采用默认值。
举例：呼叫来源选择 SIP中继组[0]，呼叫目的选择 PCM中继组[0]，其余配置项不修改，采用默认值。

5. 使用第1步中配置的SIP终端呼叫SMG光口网关的IP地址和端口，就可以通过PCM[1]外呼，与PSTN终端进行语音通信了。（注意：SIP中继呼叫IP地址的方式为：username@IP地址，其中，username为PCM[1]口外呼时使用的被叫号码，该号码需要符合对端设备的收号规则）
举例：假设光口网关的IP地址为192.168.0.101，端口为5060；123是一个符合对端设备收号规则的号码。通过SIP终端0呼叫IP地址192.168.0.101（呼叫方式为123@192.168.0.101），就可以通过PCM[1]外呼到123，和对方进行语音通信了。

第二种：PSTNàIP

1. 设置网关会进行处理的PSTN呼入的被叫号码范围。操作方法见“高级设置 à 收号规则”。设置界面中的“收号规则”需要输入一个具体的号码，或输入n个“x”表示n个任意号码（比如xxx表示3个任意号码），索引可以采用默认值。
举例：选择索引为 99，设置收号规则为 123。

2. 设置网关需要呼叫的SIP终端的IP地址。操作方法见“SIP设置 à SIP中继”。设置界面中的“远端地址”和“远端端口”分别填写需要呼叫的SIP中继的IP地址和端口，其余选项均可采用默认值。
举例：假设需要呼叫的SIP中继的IP地址为192.168.0.111，端口为5060。新增 SIP中继0，填写远端地址为 192.168.0.111，远端端口为 5060。

3. 将不同终端的IP地址加入到对应的SIP中继组。操作方法见“SIP设置 à SIP中继组”。设置界面中的“选择SIP中继”需要选择第2步中设置的SIP中继，其余选项可以采用默认值。
举例：新增 SIP中继组0，选择 SIP中继勾选 0，其余配置项不修改，采用默认值。

4. 将不同的PCM加入对应的PCM中继组。操作方法见“PCM设置 à PCM中继组”。设置界面中的“PCM”选择需要进行语音通信的PCM，其余选项可以采用默认值。
举例：假设需要进行语音通信的PCM中继为PCM[1]。新增 PCM中继组0，勾选 PCM[1]，其余配置项不修改，采用默认值。

5. 添加呼叫路由。使用第4步中设置的PCM中继组做为呼叫来源，第3步中设置的SIP中继组做为呼叫目的。操作方法见“路由设置 à PSTNàIP路由”。设置界面中的“呼叫来源”和“呼叫目的”需要进行相应选择，其余选项可以采用默认值。
举例：呼叫来源选择 PCM中继组[0]，呼叫目的选择 SIP中继组[0]，其余配置项不修改，采用默认值。

6. 当PSTN呼入到PCM[1]，且呼入的号码符合第1步中设定的收号规则时，就可以通过网关呼叫对应的SIP终端进行语音通信了。
举例：PCM[1]收到来自PSTN端的呼叫，且被叫号码为123时，就可以连接光口网关的SIP中继0进行语音通信了。

特别注意：

l 按照电信设备使用的常规要求，SMG光口网关必须可靠接地（通过电源的第三只脚连接地线，或者使用机箱上的接地螺柱接地），否则可能出现工作不稳定且抗雷击能力降低等情况。

l SMG光口网关工作时会产生热量，切勿阻挡机箱两侧的散热孔（如 图 1‑4 所示），以免发生意外。

l 发现SMG光口网关运行时告警灯亮或者闪烁，用户如果无法自行排除故障，应及时联系我公司的技术人员分析告警类型，并进行相应处理，否则可能会出现性能下降或发生意外错误的情况。


第3章 WEB配置


3.1 登录系统

在浏览器地址栏输入网关的IP地址，进入登录界面，如 图 3‑1 所示：

图 3‑1登录界面

网关只有一个用户，初始用户名为admin，初始密码为admin。登录后，用户名和密码都可以修改，具体修改方法见 3.11.22 更改口令 。

用户登录后，界面显示如下：

图 3‑2登陆后的主界面


3.2 运行信息

运行信息显示了网关当前的工作状态，包括系统信息、PSTN线路状态、SS7服务器信息、呼叫监控、呼叫统计、筛号统计、光口告警和告警信息八个部分，如 图 3‑3 所示，详细介绍如下：

图 3‑3 运行信息功能列表


3.2.1 系统信息

图 3‑4系统信息界面

系统信息界面如 图 3‑4 所示，点击刷新 可以获取最新的系统信息，点击版本详细信息 可以获取各个slaver的详细信息。以上各信息项的说明如下：

信息项

说明

MAC地址

业务网口1或业务网口2的MAC地址。

IP地址

从左到右依次为业务网口1或业务网口2的IP地址、子网掩码、默认网关。

IPV6地址

IPV6地址。

DNS服务器

业务网口1或业务网口2的DNS服务器地址。

接收数据包

网关启用后的接收数据包数量，包括总包数、错包数和丢包数。

发送数据包

网关启用后的发送数据包数量，包括总包数、错包数和丢包数。

当前速率

显示网络当前发送和接收的速率。

工作模式

显示网络的工作模式，包括10 Mbps半双工、10 Mbps全双工、100 Mbps半双工、100 Mbps全双工、1000 Mbps全双工和断线六种。

网络类型

网络类型，包括静态、DHCP和PPPoE。

运行时间

网关服务启动后，设备正常工作的时长。运行时间每2s更新一次。

工作类型

网关的工作类型，包括：

工作类型 | 说明
主服务器 | 当前网关使用7号信令，既用于传输信令，也用于传输语音。
ISDN（用户侧） | 当前网关配置成ISDN用户侧。
ISDN（网络侧） | 当前网关配置成ISDN网络侧。

CPU温度

显示当前CPU的实时温度，第一个为Master的温度，后面4个为Slaver的温度。

CPU占用率

显示当前CPU的占用率。

当前RTP报文数据

显示当前RTP报文数据的发送和接收信息。

设备云工作状态

显示网关与集中管理服务端的连接状态。

录音工作状态

显示网关对接的录音服务器的工作状态。

序列号

每台SMG光口网关唯一的序列号。

WEB

当前使用的WEB界面版本。

网关服务

当前使用的网关服务版本。

Uboot

当前使用的Uboot版本。

内核

网关上运行的系统内核版本号。

固件

网关上运行的固件版本信息。

SDH

当前光口板的版本信息。


3.2.2 PSTN线路状态

图 3‑5 PSTN线路状态界面

PSTN线路状态界面如 图 3‑5 所示，该界面显示了网关上每个PCM中继的状态，包括各通道的通道状态、同步状态和链路状态。以上各信息项的说明如下：

信息项

说明

端口

E1端口在物理设备上的对应序号。

时隙编号

PCM线路时隙在端口内的编号。

话路状态

显示通道的实时状态。将鼠标移至通道状态图标上方可以查看具体的通道状态说明和呼叫相关信息，如：呼叫方向，主、被叫号码信息。

l 对于0时隙，通道状态指示该E1的同步状态，具体说明如下：

通道状态 | 颜色 | 说
帧同步 |  | 帧同步正常， 同步 态为0x0。
故障 |  | 通道配置有误或硬件故障。将鼠标移至故障图标上方可以查看16进制的同步状态。同步状态共16个比特，bit0为最低有效位，比特值为0表示工作正常，为1时： bit0=1： 基本帧同步丢失 bit1=1： 基本帧同步丢失时间大于100ms bit2=1： CAS重新同步 bit3=1： CRC重新同步 bit4=1： 远端告警指示 bit5=1： 信号状态告警指示 bit6=1： 16时隙全1告警信息 bit7=1： 信号丢失 bit9=1： 远端MF告警 bit10=1：断路 bit11=1：短路 其余比特：保留，全部为0

l 对于信令时隙，通道状态包括：

通道状态 | 颜色 | 说明
信道 |  | 对于SS7信令，此状态指示SS7业务开通； 对于ISDN信令，此状态指示建立多帧或定时器恢复。
故障 |  | 通道配置有误或硬件故障。 对于SS7信令，此状态指示业务中断、初始定位、定位/准备好、定位/未准备好或处理机故障； 对于ISDN信令，此状态指示TEI未指定、分配等待TEI、建立等待TEI、TEI已指定、等待建立或等待恢复。
未启用 |  | 该 1没有使用信令时隙。

l 对于其它通道，通道状态包括：

通道状态 | 图标 | 说明
不可用 |  | 通道不可用。
电路复原 |  | 电路复位。
空闲 |  | 通道可用。
本端闭塞 |  | 相关通道因本方应用程序的指令而阻断本方指定通道的来话业务。
对端闭塞 |  | 对端交换机通过向本方发送特定的电路/电路群闭塞消息以阻断本方的去话业务（即阻断对端交换机的来话业务）。
两端闭塞 |  | 本方阻断指定通道来话业务，同时对端也阻断了本方的去话业务。
回铃 |  | 等待对方应答，收到来自对端的回铃音。
振 |  | 通道处于振铃状态。
通话 |  | 通道处于通话状态。
挂起 |  | 通 处于挂起状态。
拨号中 |  | 通道正在拨号。
等待消息 |  | 等待对端消息。

统计

相应状态对应的通道个数。

注：该界面提供了模糊查找通话的功能，用户只需鼠标点击 图 3‑5 界面上的任意文字部分，然后按“F”键，即可出现查找框，输入关键字后，网关可定位到正在通话的符合模糊查询条件的电话发生在哪个通道上。

举例说明：如下 图 3‑6 所示，查找栏输入111，网关根据此关键字，模糊查找并定位到被叫号码包含111的通话发生在PCM 0的时隙编号7、8上。

图 3‑6 查找通话

注：点击开始录音，对匹配到的通道进行录音，若同时匹配到多个通道，则只对最后一个通道（通道号最大）进行录音。


3.2.3 SS7服务器信息

用户只有在 PCM设置界面的信令方式 配置项设置为 7号信令-TUP 或 7号信令-ISUP 时才能看到SS7服务器信息。

图 3‑7 SS7服务器信息界面

SS7服务器信息界面如 图 3‑7 所示，该界面包含7个状态栏（图中状态栏1~7）和一个配置区域（图中区域8）。具体介绍如下：

l 状态栏1、状态栏2：接收/发送消息列表

显示光口网关从对端接收的消息和发送到对端的消息，方便网关程序的调试。接收/发送消息列表的属性可以通过配置区域8设置。

l 配置区域8：配置接收/发送消息列表的属性

配置区域中各配置项说明如下：

配置项 | 说明
工作模式 | 显示SS7信令服务器的工作模式，目前只有主服务器。
显示发到对端消息 | 勾选此配置项时，发送消息列表中会显示发送到对端的消息。
显示接收对端消息 | 勾选此配置项时，接收消息列表中会显示从对端接收的消息。
显示DPC和OPC | 勾选此配置项时，接收/发送消息列表中会显示DPC和OPC。
显示SNT消息 | 勾选此配置项时，接收/发送消息列表中会显示SNT消息。
显示SNM消息 | 勾选此配置项时，接收/发送消息列表中会显示SNM消息。
自动翻译消息 | 勾选此配置项时，此页面会自动翻译接收/发送消息内容，每一条接收/发送消息的格式如下： 日期 时间 总条数 信令链路编号# SIO 消息内容 对于TUP消息，SIO为“TUP”（0x84），后面是消息内容，通常为下列形式： 标题码 CIC=PCM:TS 消息体 不勾选此配置项时，此页面以十六进制方式显示接收/发送的原始数据。

用户可以通过配置项前的复选框设置接收/发送消息列表的显示内容，修改配置后需要点击保存应用配置信息。修改后的配置信息，将实时地应用在接收/发送消息列表中。点击下载 可对SS7服务器日志信息进行下载。

l 状态栏3：链路组/信令链路信息

显示光口网关配置的信令链路的信息，具体说明如下：

信息项 | 说明
链路组 | 链路组的编号。
链路组状态 | 链路组的业务状态，包括In service和 Out of service。只要链路组中有1条信令链路处于 In service 状态时该链路组就会处于 In service 状态。
链路@物理地址 | 信令链路编号及其物理位置，如“0 @ PCM组[0]:LINK[0]”表示本网关上第0条信令链路的物理位置为第0个PCM组上本地LINK编号为0的E1。
网络 | 本信令链路是否已经注册到网关，包括 Connected 和 Disconnected（或无显示）。信令链路进入正常使用时必须处于 Connected 状态。
同步 | 本信令链路的基本帧同步状态（0时隙），包括 Sync 和 Async 2种状态。信令链路只有在 Sync 状态下才可以投入使用。
链路状态 | 本信令链路的业务状态，包括 In service 和 Initial alignment。链路状态的详细信息可以参考本页面中的状态栏6：链路信息。
保持时间 | 本信令链路最后一次进入业务开通（In service）后所持续的时间。
定位 | 本信令链路从程序启动后发生定位的次数。
发送MSU | 自从程序启动后本信令链路上发送消息的总数。
接收MSU | 自从程序启动后本信令链路上收到消息的总数。
倒换MSU | 自从程序启动后本信令链路上倒换消息的总数。

l 状态栏4：PCM组信息

显示光口网关配置的PCM组及连接状态的信息，具体说明如下：

信息项 | 说明
编号 | PCM组编号。
PCM组 | 对应的PCM组。
状态 | 显示PCM组是否已经成功连接到了本网关。

l 状态栏5：DPC信息

显示光口网关配置的DPC信息，具体说明如下：

信息项 | 说明
DPC# | DPC的编号，编号从0开始。
DPC编码 | DPC的信令点编码，通常由电信局分配。
DPC状态 | 指示到达该DPC的路由是否可用。包括 Available 和 Unavailable。只有到达DPC的路由处于 Available 状态时才能向该DPC发送消息。只要到达DPC的所有链路组中有1条链路组处于业务开通（In service）状态，该DPC即进入 Available 状态。
DPC路由（链路组）表 | 到达该DPC的路由，即链路组编号。

l 状态栏6：链路信息

显示所有信令链路状态的详细信息，通常用于查找信令链路业务中断的原因，具体说明如下：

lnk# | STA | L2 | POC | LSC | FSN | ERR | CHO
链路号 | 链路状态0-6 | 链路故障原因（中断） | 处理机故障0-3 | 业务未开通0-1 | 本端正在发送的消息前面的序号 | 未使用 | 未使用
 | 0.上载但未启动 | 0.正常 | 0.未出现异常 | 0.业务未开通 |  |  |
 | 1.业务中断 | 1.BSNR非法 | 1.本端处理机故障 | 1.业务开通 |  |  |
 | 2.初始定位 | 2.FIBR非法 | 2.对端处理机故障 |  |  |  |
 | 3.已定位/准备好 | 3.T2超时 | 3.两端处理机故障 |  |  |  |
 | 4.已定位/未准备好 | 4.T6超时，对端忙 |  |  |  |  |
 | 5.业务开通 | 5.L3发送停止命令 |  |  |  |  |
 | 6.处理机故障 | 6.信号差错率过高 |  |  |  |  |
 |  | 7.初始定位过程中，未能进入正常定位 |  |  |  |  |
 |  | 8.定时器1超时 |  |  |  |  |
 |  | 9.已定位准备好，收到对端中断信号 |  |  |  |  |
 |  | 10.未准备好状态，收到对端中断信号 |  |  |  |  |
 |  | 11.开通状态时收到对端中断信号 |  |  |  |  |
 |  | 12.处理机故障状态收到对端中断信号 |  |  |  |  |

l 状态栏7：运行日志

运行日志随时记录MTP3发送的命令及运行过程中的各种错误信息。此状态栏显示光口网关启动后的所有日志记录。


3.2.4 呼叫监控

图 3‑8 呼叫监控界面

呼叫监控界面如 图 3‑8 所示，在监控条件栏设置监控条件，可对满足条件的呼叫进行监控。如上图所示，设置监控主叫号码为15967143013，所有主叫号码为15967143013的呼叫信息都显示在当前呼叫信息栏。以上各信息项的说明如下：

信息项 | 说明
监控主叫号码、监控被叫号码 | 设置通话监控条件，可以根据主叫号码、被叫号码对通话进行监控。
监听网口选择 | 设置对通话进行监听的网口。
PCM编号 | PCM的编号，编号从0开始。
时隙编号 | PCM线路时隙在端口内的编号。
呼叫方向 | 显示被监控呼叫的呼叫方向，包含IPà PSTN和PSTNàIP两种。
通道状态 | 显示被监控呼叫所在通道的状态。
主叫号码 | 显示被监控呼叫的主叫号码。
被叫号码 | 显示被监控呼叫的被叫号码。
开始时间 | 显示被监控呼叫的开始时间。
持续时间 | 显示被监控呼叫的持续时间。

点击通道状态栏的图标，可以对该通道进行即时监听。若用户没有安装RemoteListener，点击进行监听后会出现安全级别设置提示。请根据提示进入浏览器的工具-Internet选项-安全，进入自定义级别，将“没有标记为安全的ActiveX控件进行初始化和脚本运行”选为“启用”。被监听通道图标底层显示出阴影，如“ [image] ”，表示监听成功，再次点击监听图标即可取消监听。

注：当某个通道一开始就处于监听状态下，且未被取消。当通道被移出监控列表时，监听也会自动取消。


3.2.5 呼叫统计

图 3‑9 呼叫统计界面

呼叫统计界面如 图 3‑9 所示，该界面记录了从网关开机到最近一次打开或刷新此界面这个时间段内所有呼叫的具体信息，包括SIP呼叫统计、IPà PSTN呼叫释放原因值统计和PSTN à IP呼叫释放原因值统计。点击重置统计 可以重新统计呼叫信息。点击下载日志 可以下载所有呼叫日志以及ISDN日志。以上各信息项的说明如下：

信息项 | 说明
SIP中继 | SIP中继的地址，即与网关通信的对方SIP设备的IP地址或域名。
描述 | 标识每个SIP中继组的信息，方便查看。
当前IPà PSTN数 | 当前从IPà PSTN的呼叫数量。
接通IPà PSTN数 | 从IPà PSTN的呼叫接通的数量。
总IPà PSTN数 | 从IPà PSTN的总呼叫数量。
IPà PSTN接通率 | 从IPà PSTN发起的且双方成功进入通话的呼叫数量占各自发起的总呼叫数量的百分比。
当前PSTNàIP数 | 当前从PSTNàIP的呼叫数量。
接通PSTNàIP数 | 从PSTNàIP的呼叫接通的数量。
总PSTNàIP数 | 从PSTNàIP的总呼叫数量。
PSTNàIP接通率 | 从PSTNàIP发起的且双方成功进入通话的呼叫数量占各自发起的总呼叫数量的百分比。
平均通话时长 | 所有接通呼叫的平均通话时间。
CPS | 每秒新呼叫的数量。
释放原因 | 呼叫的释放原因。
正常拆线 | 正常的呼叫清除的呼叫。
主叫取消 | 呼叫的主叫方取消呼叫。
用户忙 | 被叫端被占用、直接回复忙消息的呼叫。
无应答 | 由于被叫长时间不摘机或主叫在被叫没有摘机的情况下挂机导致失败的呼叫。
路由失败 | 由于呼叫找不到匹配的路由规则导致失败的呼叫。
无空闲资源 | 由于找不到空闲的语音资源导致失败的呼叫。
空号 | 被叫为未分配的（未确定的）号码的呼叫。
呼叫拒绝 | 被叫直接回复拒绝消息的呼叫。
正常未指定 | 被叫为正常、未规定的呼叫。
呼叫失败 | 由于被叫号码不符合收号规则等原因导致网关外呼失败的数量。
其他 | 由于出现其他不可预知的原因导致失败的呼叫数量。
百分比 | 不同释放原因的呼叫数量占总呼叫数量的百分比。


3.2.6 筛号统计

图 3‑10 筛号统计界面

筛号统计界面如 图 3‑10 所示，该界面记录了所有筛号呼叫的具体信息，点击重置统计 可以重新统计筛号统计信息。点击下载日志 可以下载所有筛号统计日志。


3.2.7 光口告警

图 3‑11 光口告警界面

光口告警界面如 图 3‑11 所示，包括线路告警、高阶通道告警和低阶通道告警。 表示线路或通道有告警， [image] 表示线路或通道正常。


3.2.8 告警信息

图 3‑12 告警日志界面

告警信息界面如 图 3‑12 所示，网关上出现的所有告警信息都会输出并在该界面显示。


3.3 SIP设置

SIP设置包括 SIP设置、SIP中继、SIP注册、SIP账户、SIP中继组和媒体设置六个部分，如 图 3‑13 所示。SIP设置用于设置SIP通用信息；SIP中继用于设置SIP中继的基本信息和注册信息；SIP注册用于设置SIP的注册情况；SIP账户用于将SIP账户注册到对应的SIP服务器；SIP中继组用于分组管理SIP中继；媒体设置用于设置RTP端口和负载类型。

图 3‑13 SIP设置功能列表


3.3.1 SIP设置

图 3‑14 SIP通用设置界面

SIP设置界面如 图 3‑14 所示，用户可以通过该界面设置SIP通用信息。配置完成后，点击保存 将以上设置存入网关，如果保存后弹出页面提示“重启服务后生效”，需要重启网关服务，操作方法见3.11.24重启网关。点击重置 可恢复当前配置。界面中的各配置项说明如下：

配置项 | 说明
WAN口选择 | SIP信令的IP地址，默认使用网口1。
SIP信令端口 | SIP信令用于监听的端口，取值范围为2000~65535，默认值为 5060。 注：不能与媒体设置里RTP端口范围有重叠。
SIP TLS信令端口 | TLS信令端口，端口范围2000~65535，默认5061。
发送183 | 网关SIP端用作被叫时，是否用183代替180回复振铃消息，默认为启用。
指定被叫前缀回复180 | 启用发送183功能后，符合指定被叫号码前缀的回复180消息，其余回复183消息。默认为空，即所有呼叫都回复183消息。最多可填写5个指定前缀，各个前缀间用“:”隔开。
发送100rel | 设置180/183消息是否带100rel字段，默认为关闭。
对接软交换 | 设置和网关对接的软电话设备，包含其他软交换和VOS软交换两种，默认值为其他软交换。
发送183延时时间 | 设置发送183消息的延时时间，取值范围为0~10000，默认值为 0。 注：仅当对接软交换设置为VOS软交换时，该配置有效。
发送183延时模式 | 设置发送183消息的延时模式，包括模式1和模式2两种，默认值为模式 1。模式1指收到vos的invite消息之后，在PSTN侧发送IAM消息，然后等待ACM消息，如果在设定时间内没有收到ACM消息，则在sip侧回复183消息，如果之后收到了PSTN侧的ACM消息，则在sip侧再发送一次183消息；如果在设定时间内收到ACM消息，则回复183消息，之后也不再发送183消息。模式2指只在超时时发送一个183，在超时时间内收到acm不发送183。 注：仅当对接软交换设置为VOS软交换时，该配置有效。
主叫隐藏 | 设置是否隐藏主叫号码，默认值为不隐藏。
获取主叫ID方式 | 获取主叫号码的方式，From字段的username、From字段的displayname、P-Preferred-Identity字段、P-Asserted-Identity字段 四个选项，默认值为 From字段的username。
获取/发送被叫ID方式 | 获取、发送被叫号码的方式，包括从 To字段 和从 Request字段 两个选项，默认值为从 Request字段 获取。
Asserted Identity模式 | 设置是否在invite消息里将带上某些头信息，目前包含P-Asserted-Identity和P-Preferred-Identity两个字段，默认值为关闭。
Prack发送模式 | 收到的180/183带了100rel字段后是否回复prack消息，可以选择Supported和Require方式，默认不发送。
From字段号码不变换 | 该功能启用后，From字段里的主叫将不进行变换，默认值为关闭。 注：仅当配置项P-Asserted-Identity启用时，该配置有效。
从diversion字段发送/获取改 发号码/原被叫号码 | 设置是否需要开启从diversion字段发送、获取改发号码/原被叫号码的功能，默认值为不开启。
NAT穿透、穿透类型 | 设置是否开启NAT穿透，默认值为不开启。穿透类型仅包括端口映射。默认为不启用。
网口1 映射地址、网口2映射 地址 | NAT穿透启用后，网口1和网口2分别对应的SIP映射地址。实现端口映射同时还需要路由器的配合。此处填写路由器设置的映射地址。默认只填写地址，不填写端口，端口为sip信令端口。
网口1 映射地址(RTP)、网口2映射地址(RTP) | NAT穿透启用后，网口1和网口2分别对应的RTP映射地址。
始终使用映射地址 | 该功能启用后，将强制使用上面的映射地址进行呼叫，默认为不启用。
收到Refer消息时设置E1侧REL消息的呼转参数 | SIP侧收到Refer消息时，向E1侧发送REL消息，带上呼转参数。
SIP加密 | 启用SIP加密功能可以对SIP信令进行加密，默认为关闭。加密时需要选择加密规范和密钥。
加密规范 | 对SIP信令进行加密的加密规范，目前只支持VOS1.1。
密钥 | 对SIP信令进行加密的密钥。
RTP加密 | 该功能启用后，可以对RTP进行加密，默认为关闭。
RTP自适应 | 该功能启用后，当远端发送的信令消息中携带的RTP接收地址或端口与实际情况不符时，自动更新其为实际的RTP接收地址或端口，提高网关RTP发送的自适应能力。默认为不启用。
开启UDP头校验 | 该功能启用后，网关在发送RTP时会自动计算UDP头校验和。
开启Rport | 该功能开启后，将在SIP信令的Via字段中增加对应的Rport字段。默认为不启用。
开启过滤相同主被叫 | 对于PSTN外呼的呼叫，该功能启用后，如果主叫号码和被叫号码相同时，将不能进行外呼，默认为不启用。
开启来源地址回复 | 该功能启用个后，网关将使用invite消息里面的源地址回复，默认为不启用。
多audio选择 | SDP消息中带了多个audio，选择RTP或者SRTP的端口作为语音端口。
主叫并发限制 | 限制相同主叫号码的呼叫次数，超过次数后回复503。
SIP账号注册间隔(MS) | 多个SIP账号注册的间隔，范围0~10000，默认0
启用DSCP | 启用DSCP差异化服务编码点功能。默认值为不启用。
语音媒体 | 设置DSCP中语音媒体的优先级。取值范围为0～63，默认值为 46。取值越大，优先级越高。
信令控制 | 设置DSCP中信令控制的优先级。取值范围为0～63，默认值为 26。取值越大，优先级越高。
仅允许SIP中继地址呼入 | 此功能开启后，网关仅接收SIP设置àSIP中继里配置的IP地址过来的呼叫。默认为不启用。
通话超时挂机设置 | 设置是否开启通话超时时挂机的功能。默认为不启用。
最大超时时间 | 设置通话的最大超时时间，单位为分钟。
工作时间段、时间段 | 设置整个网关的工作时间段，可以设置在指定时间段内才能进行呼叫。默认为 24小时 都可以呼叫。
会话定时器 | 设置是否开启会话刷新功能，默认值为不启用。该功能启用后，需输入定时器最小时间和定时器超时时间。
定时器最小时间 | 设置会话刷新的最小时间。取值范围为90～65535，默认值为 150。
定时器超时时间 | 设置会话刷新的超时时间。取值不能小于定时器最小时间，默认值为 600。
启用中继心跳 | 设置是否定期向SIP中继发送option消息，未收到MGCF中继的回复超过一定次数则路由至该中继的呼叫直接拒绝。
中继心跳周期 | 设置向SIP中继发送option消息的周期。
允许未响应次数 | 设置允许SIP中继未回复option消息的次数。
启用早期媒体 | 该功能启用后，Inivite消息会加上P-Early-Media字段，默认值为不启用。
启用早期会话 | 该功能启用后，Inivite消息会加上early-session字段，默认值为不启用。
发送200OK后不等待ACK | 该功能启用后，网关发送200OK消息以后不需要等待ACK消息，默认值为不启用。
注册消息发送周期占有效期 百分比 | 设置实际发送SIP注册消息的周期时间占SIP注册消息有效期的百分比，，取值范围为1~200，默认值为 70。
等待对方应答时间 | SIP通道外呼时等待被叫应答的时间。如果对方在指定时间内没有应答，则通道自动取消此次呼叫。默认值为 60，单位为秒。
RTP超时挂机时长 | 通道等待RTP包的时间。如果在指定的时间内没有收到RTP包，则通道会自动进入挂起状态，终止本次呼叫。默认值为 0，单位为秒。
INVITE消息To字段添加内容 | 该功能启用后，INVITE消息的TO字段中将添加user=phone。默认为不启用。
添加内容 | 自定义设置TO字段添加的内容。
自定义UserAgent字段 | 自定义设置UserAgent字段内容，目前只支持英文的大小写字母。


3.3.2 SIP中继

图 3‑15 SIP中继配置界面

SIP中继配置界面如 图 3‑15 所示。SIP中继可以通过点击列表右下角的添加 SIP中继 添加，见 图 3‑16 。

图 3‑16 SIP中继添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
索引 | SIP中继的索引，具有唯一性。
描述 | 标识每个SIP中继组的信息，方便查看。
远端地址 | SIP中继的地址，即与网关通信的对方SIP设备的IP地址或域名。
远端端口 | SIP中继的信令端口。
本端网口 | SIP中继所在的网口。
呼出语音资源 | SIP中继分配给网关的最大呼出资源数。
呼入语音资源 | SIP中继分配给网关的最大呼入资源数。
工作时间段、时间段 | 设置该SIP中继的工作时间段，可以设置在指定时间段内才能进行呼叫。默认为 24小时 都可以呼叫。
启用外部代理 | 是否启用代理，启用后SIP消息往代理地址发送。
外部代理地址 | 代理地址。
外部代理端口 | 代理端口。
中继心跳模式 | 发OPTION消息给中继配置的地址。需要在SIP设置中启用中继心跳后才显示，默认为不启用。有不启用、MGCF和GWC三种模式，其中GWC表示OPTION发送到的目的地址是中继地址；MGCF表示OPTION发送到的目的地址是可配置的。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。

点击 图 3‑15 中的修改 可以对已经配置的SIP中继进行修改，修改界面如 图 3‑17 所示。修改界面各配置项的意义与 SIP中继添加 界面的对应配置项相同。

图 3‑17 SIP中继修改界面

如果需要删除SIP中继，可以在 图 3‑15 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空 SIP中继 用于一键清除所有SIP中继。


3.3.3 SIP注册

图 3‑18 SIP注册配置界面

网关默认没有SIP注册信息，如 图 3‑18 所示。点击添加 进行添加，如 图 3‑19 所示。用户可以通过该界面添加SIP注册相关信息。

图 3‑19 SIP注册添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
索引 | SIP注册的索引，具有唯一性。
SIP中继编号 | 设置哪个SIP中继注册到SIP服务器。
用户名 | 通过网关向SIP线路发起呼叫时，该号码对应于SIP的username；通过网关向PSTN外呼时，该号码对应于显示的主叫号码。
密码 | 网关注册到SIP服务器上时所使用的密码，发起注册时必须同时填写用户名 与密码 。
注册地址 | SIP中继对外注册的SIP服务器地址。
注册端口 | SIP中继的信令端口。
注册域名 | 网关用于对外注册的注册服务器域名。
注册有效期 | SIP注册的注册周期，每间隔该时间段重新发起注册。取值范围为10~3600，单位为秒，默认值为3600。
认证用户名 | 注册时的认证用户名。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。

图 3‑20 SIP注册信息列表

点击 图 3‑20 中的修改 可以对已经配置的SIP注册信息进行修改，修改界面如 图 3‑21 所示。修改界面各配置项的意义与SIP注册添加 界面的对应配置项相同。

图 3‑21 SIP注册修改界面

如果需要删除SIP注册，可以在 图 3‑20 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空SIP注册信息 用于一键清除所有SIP注册信息。


3.3.4 SIP账户

图 3‑22 SIP账户配置界面

SIP账户配置界面如 图 3‑22 所示，用于将不同的SIP账户注册到对应的SIP中继服务器。SIP账户可以通过点击列表右下角的添加 SIP账户 添加，见 图 3‑23 。

图 3‑23 SIP账户添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
索引 | SIP账户的索引，具有唯一性。
SIP中继编号 | 设置SIP账户注册到哪个SIP中继。
用户名 | SIP账户注册到SIP中继的用户名。SIP账户注册成功后，服务器可以通过用户名 呼叫网关。
密码 | SIP账户注册到SIP中继上时所使用的密码，发起注册时必须同时填写用户名 与密码 。
注册有效期 | SIP账户注册的周期，每间隔该时间段重新发起注册。取值范围为10~3600，单位为秒，默认值为3600。
注册状态 | 显示SIP账户注册的情况，包括已注册 或注册失败。
认证用户名 | 启用IMS网络时，该端口注册到SIP服务器上时所使用的认证用户名。 注：此配置只有在该SIP账户所对应的SIP中继启用了IMS网络的情况下才会出现。
描述 | 标识每个SIP账户的信息，方便查看。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。

点击 图 3‑22 中的修改 可以对已经配置的SIP账户进行修改，修改界面如 图 3‑24 所示。修改界面各配置项的意义与 SIP账户添加 界面的对应配置项相同。

图 3‑24 SIP账户修改界面

如果需要删除SIP账户，可以在 图 3‑22 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空 SIP账户 用于一键清除所有SIP账户。


3.3.5 SIP中继组

图 3‑25 SIP中继组配置界面

SIP中继组配置界面如 图 3‑25 所示。SIP中继组可以通过点击列表右下角的添加 SIP中继组 添加，见 图 3‑26 。

图 3‑26 SIP中继组添加界面

以上界面中各配置项的说明如下：

配置项

说明

索引

每个SIP中继组的唯一标识，用于在配置路由规则和号码变换规则时对应需要配置的SIP中继组。

描述

标识每个SIP中继组的信息，方便查看。

中继选择方式

当SIP中继组收到呼叫时，会以指定的中继选择方式，选择合适的SIP中继进入振铃。包括递增 、递减 、循环递增 、循环递减 四个可选项，具体说明如下：

可选项 | 说明
递增 | 每次从序号最小的SIP中继开始，按升序查找有空闲资源的SIP中继。
递减 | 每次从序号最大的SIP中继开始，按降序查找有空闲资源的SIP中继。
循 递增 | 记录之前查找到的SIP中继，从序号为记录SIP中继+1的SIP中继开始，按升序 找 空闲资源的SIP中继。
循环递减 | 记录之前查找到的SIP中继，从序号为记录SIP中继-1的SIP中继开始，按降序查找有空闲资源的SIP中继。

呼出资源限制、呼入资

源限制

设置是否限制呼出/呼入的通道资源，默认值为否，若选择是，需要输入限制的通道数量。

IPàPSTN禁止呼出

设置是否禁止从IP到PSTN的呼叫，默认值为否，若选择是，需要输入被叫禁呼规则或主叫禁呼规则。具体禁呼规则请查看页面下方的批注。

选择SIP中继

SIP中继组中包含的SIP中继，SIP中继前的复选框呈灰色表示该SIP中继已被占用，不能选择。选中的SIP中继在 图 3‑25 的列表中显示为包含中继。

配置完成后，点击保存 将以上设置存入网关；点击取消 可直接取消设置。

点击 图 3‑25 中的修改 可以对已经配置的SIP中继组进行修改，修改界面如 图 3‑27 所示。修改界面各配置项的意义与 SIP中继组添加 界面的对应配置项相同。

图 3‑27 SIP中继组修改界面

如果需要删除SIP中继组，可以在 图 3‑25 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空 SIP中继组 用于一键清除所有SIP中继组。


3.3.6 媒体设置

图 3‑28 媒体设置界面

媒体设置界面如 图 3‑28 所示，用户可以根据实际需求对RTP端口和负载类型进行配置。配置完成后，点击保存 将以上设置存入网关，如果保存后弹出页面提示“重启服务后生效”，需要重启网关服务，操作方法见 3.11.24重启网关 。点击重置 可恢复当前配置。界面中各配置项的说明如下：

配置项

说明

发送DTMF方式

IP端发送DTMF的方式，取值范围包括 RFC2833、信令、带内、RFC2833+信令、带内+信令五种方式，默认采用 RFC2833。

RFC2833负载值

RFC2833形式的DTMF在IP线路上采用的负载值，取值范围为90~127，默认值为101。

RTP端口范围

IP端建立语音通话时网关端RTP适用的端口范围，取值范围的为5000-60000，默认值下限为6000，上限为20000，且端口范围差值不能小于8192。

静音抑制

设置当IP通话过程中没有语音时，是否用柔和静音包代替RTP包或者不发送RTP包，以减少带宽的占用。默认值为禁用。

注：当编解码选择G723时，该配置会自动修改为启用。

自动降噪

启用噪音抑制功能，可以自动降低线路上的噪音音量。默认值为开启。

JitterMode

设置JitterMode的工作模式，包括静态模式 和自适应模式 两种模式，默认采用静态模式。

JitterBuffer

对IP线路上语音包的缓冲处理能力。缓冲越大，对网络上语音包抖动的适应能力越强，但同时语音延迟也会适当变大；反之则对语音包的抖动处理能力变弱，但语音延迟变小。取值范围为0~280，单位为毫秒，表示能够接受网络上多少时间范围内的数据包抖动，默认值为 100。

JitterUnderrunLead

设置当接收的语音包晚于JitterBuffer设定值时，已接收语音包的初始延迟。取值范围为0~280，单位为毫秒，默认值为 100。

注：只有当JitterMode配置为静态模式 时，用户才可以看到该配置项。

JitterOverrunLead

设置当接收的语音包早于300-JitterBuffer设定值时，插入的提前时间。取值范围为0~280，单位为毫秒，默认值为 50。

注：只有当JitterMode配置为静态模式 时，用户才可以看到该配置项。

JitterMin

设置自适应jitter功能可以设定的最小延时，必须小于JitterBuffer设定值。取值范围为0~280，单位为毫秒，默认值为 80。

注：只有当JitterMode配置为自适应模式 时，用户才可以看到该配置项。

JitterDecreaseRatio

设置自适应模式下，减小延时的速率，定义了减少延时可以删除的静音的最大百分比。取值范围为0~100，默认值为 50。

注：只有当JitterMode配置为自适应模式 时，用户才可以看到该配置项。

JitterIncreaseMax

设置一个静音周期内增大的最大延时。取值范围为0~280，单位为毫秒，默认值为 30。

注：只有当JitterMode配置为自适应模式 时，用户才可以看到该配置项。

IP侧输出增益

网关IP侧向对端发送的语音增益大小，取值大小必须为3的倍数，取值范围为-24～24，单位为分贝，默认值为 0。

编解码设置

IP端建立语音通话时适用的编解码设置。各子配置项具体说明如下：

子 置项 | 说明
网关协商编码顺序 | 设置编解码优先级顺序，包括默认优先级 和自定义优先级 两种，缺省值是默认优先级。
优先级 | 在SIP通信中选用编解码格 的先后顺序，数值越小优先级越高。
编解码 | 编解码格式类型，取值范围包括G711A、G711U、G729、G722、G723、iLBC、AMR-NB、SILK(16K)、OPUS(16K)、SILK(8K)、OPUS(8K)。
打包时长 | RTP包的打包间隔，单位为毫秒。
比特率 | 该编解码格式在净荷情况下每秒钟需要传输多少个千比特。

默认十一种编解码格式同时适用，且优先级从高到低分别为G711A、G711U、G729、G722、G723、iLBC、AMR-NB、SILK(16K)、OPUS(16K)、SILK(8K)、OPUS(8K)，此处设置编解码为新增SIP中继的默认编解码格式。

不同编解码格式支持的打包时长和比特率如下表所示，图中字体加粗的取值为该编解码的默认值。

编解码 | 打包时长（ms） | 比特率（kbps）
G711A | 10 / 20 / 30 / 40 / 50 / 60 | 64
G711U | 10 / 20 / 30 / 40 / 50 / 0 | 64
G729 | 10 / 20 / 30 / 40 / 50 / 60 | 8
G722 | 10 / 20 / 30 / 0 | 64
G723 | 30 / 60 | 5.3 / 6.3
iLBC | 20 / 0 | 15.2
 | 30 | 1 .3
 | 60 | 13.3 / 15.2
AMR | 20 / 40 / 60 | 4.75 / 5.15 / 5.90 / 6.70 7.40 / 7.95 / 10.20 / 12.20
SILK(16K) | 20 /40 / 60 / 80 / 100 | 20
OPUS(16K) | 10 / 20 / 40 / 60 | 20
SILK(8K) | 20 /40 / 60 / 80 / 100 | 20
OPUS(8K) | 10 / 20 / 40 / 60 | 20


3.4 PCM设置

PCM设置包括PSTN线路设置、电路维护、PCM设置、PCM中继组、收号规则、收号超时、号码归属地和PSTN呼转号码表八个部分，如 图 3‑29 所示。

图 3‑29 PCM设置功能列表


3.4.1 PSTN线路设置

图 3‑30 PSTN线路设置界面

PSTN线路设置界面如 图 3‑30 所示，各配置项说明如下：

配置项 | 说明
接口类型 | 网关上E1接口的实际接线类型。
线路语音编码格式 | 设置数字中继线上语音信道的语音编码格式。可选的取值包括A-Law 和μ-law ，默认值为A-Law。
回波抵消 | 该功能启用时，数字中继线路在通话过程中将提供回波抵消功能，抵消效果能够达到128ms。默认值为启用。
忙音检测 | 该功能启用后，E1侧检测到忙音时，IP侧回复486消息，默认是不启用。
频率1、频率2 | 设置忙音信号第1个中心频率和第2个中心频率值，单位为Hz。频率1默认值为450，频率2默认值为0。
周期 | 设置忙音周期，单位为ms，可以同时添加4个不同的忙音检测周期，按从小到大的顺序排列，以“,"隔开，如：700,1400,2000,3200。取值范围为25-5000，默认值为700。
通话中忽略忙音 | 该功能启用后，在通话过程中检测到忙音时，不会主动挂断，默认值是启用。
回铃音设置 | 设置E1侧和IP侧是否开启提供回铃音功能，默认不提供。
频率1、频率2 | 设置回铃音信号第1个中心频率和第2个中心频率值，单位为Hz。频率1默认值为450，频率2默认值为0。
高电平持续时间、低电平持续时间 | 设置回铃音高低电平的持续时间，单位毫秒
PSTN->IP呼叫回铃音自适应 | 收到的180/183消息没带P-Early-Media 或者参数值为inactive才由网关E1侧提供回铃音。
启用单PCM模式 | 该功能启用后，PCM中继组支持单独设置各个PCM，默认是不启用。
PSTN外呼限制 | 该功能启用后，用户可以自主设置外呼同一个被叫号码的呼叫次数。默认是不启用。
被叫号码允许接入阀值 | 设置外呼同一个被叫号码的最大呼叫次数。
周期 | 设置限制外呼的周期。
回复SIP值 | 自定义设置外呼次数超过规定阀值后，PSTN向SIP侧回复的SIP码。
ISDN 01消息含进展表示语 | 设置ISDN 01消息后面带的进展表示语的值，取值范围为0x80 ~ 0xff，默认值为0x82。若配置为0x0，则表示不带进展表示语。
回铃音音量 | 设置回铃音音量大小，单位为分贝，默认值为-25，取值范围为-35~-2。
PSTN侧输出增益 | 网关PSTN侧向对端发送的语音增益大小，取值大小必须为3的倍数，取值范围：-24～24，单位为分贝，默认值为0。
UUI协议标识 | 有来话时获取消息中的user to user字段，并且在外呼时，赋值到Usr2UsrInfo字段中。
协议标识 | ISUP/ISDN表示Usr2UsrInfo的协议标识码，默认为4
E1热备份 | 设置是否开启E1热备份功能。默认是不启用。
热备份网关IP | 设置实现E1设备热备份功能的网关的IP地址。
E1外呼限制号码长度 | 限制PSTN侧外呼的被叫号码长度，当长度超过该配置设置值时，被叫号码将会被分成两段。取值范围为0～50，默认值为0，表示不限制。
PSTN呼入呼转功能 | 设置PSTN呼入的呼叫失败时，自动呼转该呼叫至PSTN侧。包含禁用、SIP中继不可用启用呼转和立即启用呼转三种。默认是禁用。
心跳包检测远端SIP中继 | 设置是否开启向SIP中继发送option消息。
最大无应答次数 | 设置PSTN呼入呼叫不通的最大次数，超过该次数的呼叫才会被呼转。
时钟来源 | 设置光口的时钟模式，包括远端时钟和本地时钟两种模式，默认为远端时钟。
E1编号模式 | 设置网关E1的编号模式，包括线路模式（朗讯模式）和时隙模式（华为模式）两种，默认为线路模式。
E1交叉自环 | 该功能启用后，0号E1和32号E1将自环，1号E1和33号E1将自环，······，依次类推。默认是不启用。
C2 | SDH帧结构中的高阶通道开销字节，是信号标记字节，指示VC帧的复用结构和信息净负荷的性质。
S1 | 同步状态标志字节，用来传送同步状态信息，即在定时传递链路上直接反映同步定时信号的质量级别。
J0发送、J0应收 | 发送/应收的J0；J0是再生段追踪字节，用于再生段追踪。
J1发送、J1应收 | 发送/应收的J1；J1是高阶通道VC-3/VC-4追踪字节，供重复地发送高阶通道接入点标识，以便通道接收端能证实本通道的连接。
PCM |
J2（n）发送、J2（n）应收 | PCM(n)发送/应收的J2；J2是发送的低阶通道VC-12追踪字节，以便使通道接收端能确认与发送机处于连接状态。
VT PSL（n）应收 | PCM(n)应收的VT PSL；VTPSL是低阶通道状态和信号标记字节，用于误码校测，信号标记和VC12通道状态表示等功能。
C2 |
J0实收 | 实际接收的J0。
J1实收 | 实际接收的J1。
J2（n）实收 | PCM(n)实际接收的J2。

配置完成后，点击保存 将以上设置存入网关，如果保存后弹出页面提示“重启服务后生效”，需要重启网关服务，操作方法见 3.11.24重启网关 。点击重置 可恢复当前配置。


3.4.2 电路维护

图 3‑31 电路维护界面

PCM电路维护界面如 图 3‑31 所示，用户可通过该界面选择相应的PCM编号，对其进行闭塞、解闭塞的操作。全选 指选中当前端口可以选定的全部项目；全不选 指取消选中当前端口已经选定的全部项目；反选 指取消选中当前端口已选中的项目，并选中原先未选中的项目。本地环回 指LIU发送器环回到LIU接收器，远端环回 指LIU接收器解码后环回到LIU发送器。解环回 用于关闭已经配置的本地环回或者远端环回。


3.4.3 通道闭塞

图 3‑32 通道闭塞界面

可选择单个通道进行闭塞和解闭塞操作。


3.4.4 PCM设置

图 3‑33 PCM设置界面

PCM设置界面如 图 3‑33 所示，以上列表显示了网关上所有PCM的信息和配置。以上界面中各配置项的说明如下：

配置项 | 说明
PCM编号 | PCM的编号，编号从0开始，不可修改。
信令方式 | 数字中继线上使用的信令方式，E1下可选的参数包括ISDN用户侧、ISDN网络侧、7号信令-TUP、7号信令-ISUP； 注：SMG3064网关最多只能配置1种信令方式。
时钟模式 | 数字中继线的时钟模式，包括线路同步主 、自振荡主 和从时钟 。
主控模式 | 7号信令数字侧外呼时选择时隙的方式，默认"无"，按照点码大小搜索空闲通道，点码大的一方控偶时隙，搜索通道函数根据偶时隙从0，2，4，......，30，31，29，27，......，1依次选择； 选择"控偶时隙"， 搜索通道函数根据偶时隙从0，2，4，......，30，31，29，27，......，1依次选择； 选择"控奇时隙"， 搜索通道函数根据奇时隙从1，3，5，......，31，30，28，26，......，0依次选择。（除0，1和16 ts）。
信令时隙 | 配置数字中继线上传输信令的时隙。当信令方式 设置为ISDN，E1下的信令时隙为16时隙，不可更改。SS7信令最多可以设置4个信令时隙。
链路类型 | 表示该链路用作信令链路还是语音链路。没有用于传输信令的时隙的链路即为语音链路。
接口类型 | PCM配置的物理连线的类型。该配置项在PCM信息修改界面显示为连接类型。
CRC-4 | 设置是否开启数字中继线上的CRC-4校验功能，默认值为开启。
SIP中继号 | PCM中继绑定SIP中继编号，在PCM中继状态发生变化时或通道闭塞时，通过该SIP中继发出option通知消息。

点击 图 3‑33 中的修改 可以修改PCM信息，见 图 3‑34 。各配置项的意义与PCM设置 界面的对应配置项相同。

图 3‑34 PCM信息修改界面

PCM信息修改界面其它配置项说明如下：

配置项 | 说明
使用所选时隙走信令 | 勾选此配置项表示使用信令时隙 中配置的时隙来传输信令。用户只有在信令方式 设置为7号信令-TUP 或7号信令-ISUP 时才能看到此配置项。
应用到所有PCM | 勾选此配置项表示将此PCM上配置的信息（不包括时钟模式）应用到所有PCM。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。


3.4.5 PCM中继组

图 3‑35 PCM中继组配置界面

PCM中继组配置界面如 图 3‑35 所示。PCM中继组可以通过点击列表右下角的添加PCM中继组 添加，见 图 3‑36 。

图 3‑36 PCM中继组添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
索引 | PCM中继组的索引，具有唯一性，用于在配置路由规则和号码变换规则时对应需要配置的PCM中继组。
描述 | 标识每个PCM中继组的信息，方便查看。
中继选择方式 | 设置选择PCM中继的方式，包括递增、递减、循环递增、循环递减四种。
PCM中继 | PCM中继组中包含的PCM中继，PCM中继前的复选框呈灰色表示该PCM中继已占用，不能选择。选中的PCM中继在 图 3‑35 的列表中显示为包含PCM。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。

点击 图 3‑35 中的修改 可以对已经配置的PCM中继组进行修改，修改界面如 图 3‑37 所示。修改界面各配置项的意义与PCM中继组添加 界面的对应配置项相同。

图 3‑37 PCM中继组修改界面

如果需要删除PCM中继组，可以在 图 3‑35 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空PCM中继组 用于一键清除所有PCM中继组。

注： PSTN线路设置 中启用单PCM模式开启后，PCM中继组中的PCM中继不再是成组设置，可以分别单独设置。


3.4.6 收号规则

收号方案用于过滤网关PSTN端的呼入号码，只有符合收号方案的号码才会被呼叫。收号方案由多条收号规则组成，为防止规则匹配冲突，各规则之间有优先顺序的限制。

图 3‑38 收号规则配置界面

收号规则配置界面如 图 3‑38 所示，以上列表显示了各收号规则及其优先级和说明。显示在列表中的收号规则及对应信息可以通过点击列表右下角的添加收号规则 添加，见 图 3‑39 。

图 3‑39添加收号规则界面

以上界面中各配置项的说明如下：

配置项

说明

索引

收号规则的索引。每条收号规则都需要一个唯一的索引，用于规定收号规则的优先级，该数值越小则优先级越高。进行收号规则匹配时，优先匹配优先级高的规则。

收号规则

收号规则 可以包含的字符及具体含义如下表所示，每条规则的字符串长度上限为64个字符，网关最多可以配置200条规则。在收号过程中，网关会对所收号码进行收号规则的即时匹配，直至收到#号或收号超时，此次收号结束。

字符 | 含义
“0”~ 9” | 数字0～9。
“x” | 代表一个任意数字；多个x表示多个任意数字，如：xxx表示3个任 数字。
“ ” | 表示其后可以出现任意多个字 ，包括零个。
“[ ]” | 表示一个数字，该数字是前后用一对”[”、”]”括起来的范围内的任意值，“[ ]”内的值只支持数字“0”~”9”、“-”和“,”。 举例：[1-3,6,8]表示集合1、2、3、6、8内的任意一个数字。
“-” | 两个数字之间 “-”相隔，表示该区间之 的 何数字。“-”只能出现在“[ ]”中。
“,” | 两个数字或数字区间之间用“,”相隔，表示两者之间为选择关系。“,”只能出现在“ ]”中。

网关默认只配置一条收号规则“.”，为了方便用户理解和使用，下表中共列举了20条收号规则，具体说明如下：

优先级 | 拨号规则 | 说明
99 | . | 表示任意号码，任意长度。
98 | 01[3,5,8]xxxxxxxxx | 以013、015或018开头的任意12位号码。
97 | 010xxxxxxxx | 以010开头的任意11位号码。
96 | 2xxx xxxx | 以02开头的任意11位号码。

收号规则

95 | 0[3-9]xxxxxxxxxx | 以03、04、05、06、07 08或09开头的12位号码。
94 | 20 | 号码120。
93 | 11[0,2-9] | 号码110、112、113、114、115、116、117、118或119。
92 | 111xx | 以111开头的任意5位号码。
91 | 123xx | 以123开头的任意5位号码。
90 | 95xxx | 以95开头的任意5位号码。
89 | 100xx | 以100开头的任意5位号码。
88 | 1[3- 8]xxxxxxxxx | 以13、14、15或18开头的任意11位号 。
87 | [2-3,5-7]xxxxxx | 以2、3、5、6或7开头的任意8位号码。
86 | 8[1- ]xxxxxx | 以81、82、83、84、85、86、87、88或89开头的任意8位号码。
85 | 80[1-9]xx xx | 以801、802、803、804、805、806、807、808或809开头的任意8位 码。
84 | 800xxxxxxx | 以800开头的任意10位号码。
83 | 4[1-9]xxxxxx | 以41、42 43、44、45、46、 7 48或49开头的任意8位号码。
82 | 40[1-9]xxxxx | 以401、402、403、404、405、40 、407、408或409开头的任意8位号码。
81 | 400xxxxxxx | 以400开头的任意10位号码。
80 | 8xxx | 以8开 的任意4位号码。

描述

收号规则的备注，可以填写任意信息，但不能为空。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑38 中的修改 可以对收号规则进行修改。修改界面如 图 3‑40 所示，各配置项的意义与添加收号规则 界面的对应配置项相同。

图 3‑40修改收号规则界面

如果需要删除收号规则，可以在 图 3‑38 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空规则 用于一键清除所有收号规则。


3.4.7 收号超时

图 3‑41 收号超时信息配置界面

收号超时信息配置界面如 图 3‑41 所示。各配置项的说明如下：

配置项 | 说明
最大收号间隔时间 | 设置每两个收号按键之间的最大时间间隔，单位为秒，默认值为1，取值范围为0~10。如果收号规则中没有设置“.”，那么，在该时间间隔内没有按键或者没有匹配到任何收号规则，则呼叫失败。如果收号规则中设置了“.”，那么，在该时间间隔内没有按键或者没有匹配到除“.”以外的任何收号规则，则网关将在该时间间隔后自动匹配到“.”这个收号规则。
描述 | 对配置信息的补充说明，方便下次查看配置项的取值原因。

点击 图 3‑41 中的修改 可以对收号超时信息进行修改，收号超时信息修改界面如 图 3‑42 所示。界面中各配置项的意义与收号超时信息配置 界面的配置项相同。

图 3‑42 修改收号超时信息

修改完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。


3.4.8 号码归属地

图 3‑43 号码归属地设置界面

号码归属地配置界面如 图 3‑43 所示。可以设置IPàPSTN呼出的呼叫中是否去掉本地号码的被叫号码前的0或者区号，以及禁止呼叫某个或者某几个地区，还可以设置呼叫各地手机号时自动添加对应区号。以上界面中各配置项的说明如下：

配置项 | 说明
号码归属地优先级规则 | 设置号码归属地的优先级，包含号码变换前（号码归属地优先）和号码变换后（号码变换优先）两种。默认为号码变换后。
IP->PSTN被叫号码为 本地号码时去掉号码前 的0或区号 | 设置呼出时被叫号码为本地号码时是否去掉号码前的0或者区号。默认为否。
本地区号 | 设置本地区号。
IP->PSTN呼叫指定区 域号码不带原被叫或改 发号码 | 该功能启用后，根据下面的主被叫号码选择和限制规则，将取消呼叫中的原被叫号码（ISUP）或改发号码（ISDN）默认为否。
主被叫号码选择 | 选择主、被叫号码。
限制规则 | 用于设置外呼号码不带原被叫或改发号码的限制呼叫区域。
IP->PSTN禁止呼出、 禁呼区号 | 是指是否禁止外呼呼叫、禁止外呼呼叫的区号。默认为否。
IP->PSTN呼叫本地号 码时被叫号码前添加本 地区号 | 设置外呼呼叫本地号码时是否在被叫号码前添加本地区号。
IP->PSTN被叫号码自 动添加各地区号 | 设置外呼时自动在各个呼叫的被叫号码前添加相应地区的区号。
PSTN->IP号码主叫自 动添加各地区号 | 设置是否自动在呼入呼叫的主叫号码前添加相应地区的区号。
PSTN->IP号码主叫去 掉区号前的0 | 设置是否去掉呼入呼叫的主叫号码区号前的号码0。
PSTN->IP号码被叫自 动添加各地区号 | 设置是否对呼入呼叫的被叫号码自动添加相应地区的区号。

点击保存 保存设置信息，点击重置 可恢复当前配置。用户也可以点击导出，导出并查看本地和禁呼号码归属地信息。通过浏览 加载需要导入的本地和禁呼号码归属地信息，然后点击导入，导入需要的归属地信息文件。

注：目前导入只支持如下号段的号码：13x、14x、15x、17x、18x。


3.4.9 PSTN呼转号码表

图 3‑44 PSTN呼转号码表界面

PSTN呼转号码表配置界面如 图 3‑44 所示。当 PSTN线路设置 中PSTN呼入呼转功能开启时，该界面才会出现，通过该界面可以设置PSTNàIP的呼叫不成功时，再从IP呼转至PSTN的号码对应关系。可以通过点击列表右下角的添加 进行添加，见 图 3‑45 。

图 3‑45 PSTN呼转号码表添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
编号 | 该条呼转对应关系在号码表中的编号。
主叫号码 | PSTNàIP呼入呼叫中的主叫号码。
被叫号码 | IPà PSTN呼出呼叫中的被叫号码。
原被叫号码 | 原来PSTNàIP呼入呼叫中的被叫号码。
改发信息 | 设置IAM消息中的改发信息字段。需要配置ISUP才会显示。改发信息字段的参数类型为0x13，共包含2个字节。默认值为0x0331，即用户无应答前转。各字节具体含义参见ISUP协议书规定。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。保存配置后的界面如 图 3‑46 所示。

图 3‑46 PSTN呼转号码表列表

点击 图 3‑46 中的修改 可以对已经配置的号码表进行修改，修改界面如 图 3‑47 所示。修改界面各配置项的意义与PSTN呼转号码表添加 界面的对应配置项相同。修改界面不允许修改编号。

图 3‑47 PSTN呼转号码表修改界面

PSTN呼转号码表列表下方的删除所选 用于删除选中的号码表；清空 用于一键清除所有号码表。


3.5 ISDN设置

用户只有在PCM设置界面的信令方式 配置项设置为ISDN用户侧 或ISDN网络侧 时才能看到ISDN设置菜单，如 图 3‑48 所示。

图 3‑48 ISDN设置功能列表


3.5.1 ISDN设置

图 3‑49 ISDN设置界面

ISDN设置界面如 图 3‑49 所示，用户可以通过该界面设置ISDN通用信息。配置完成后，点击保存 将以上设置存入网关，如果保存后弹出页面提示“重启服务后生效”，需要重启网关服务，操作方法见 3.11.24重启网关 。点击重置 可恢复当前配置。界面中的各配置项说明如下：

配置项 | 说明
TEI值 | 终端设备标识符，用于标识连接在服务接入点内点到点数据链路连接中的终端。取值范围0~63，默认值为0。注意：对应网络侧与用户侧的TEI值必须相同。
通路识别类型 | 设置数字中继线上的通路识别的表示方法。可选的参数包括：号码表示和时隙图表示，默认值为号码表示。
默认被叫号码类型 | 去话呼叫时，设置setup消息中被叫号码的号码类型及编号方案。可选的参数包括国内号码、国际号码、网络号码、用户号码和未知号码，默认值为国内号码。
默认主叫号码类型 | 去话呼叫时，设置setup消息中主叫号码的号码类型及编号方案。可选的参数包括国内号码、国际号码、网络号码、用户号码和未知号码，默认值为国内号码。
语音编解码格式 | 设置数字中继线上语音信道的语音编解码格式，可选的参数包括A率和μ率，默认值为A率。
发送建链消息 | 设置ISDN用户侧或网络侧是否发送建链消息。默认值为开启。
信令校验 | 设置是否开启ISDN用户侧或网络侧数字中继线上的CRC校验功能。默认值为开启。
有改发号码时另设主被叫号码型 | 此功能启用时，在IP到PSTN的呼叫中，如果IP端带有改发号码，setup消息中主叫号码和被叫号码的号码类型及编号方案需要使用特别设定的参数，即被叫号码类型和主叫号码类型。默认值为不启用。
被叫号码类型 | 有改发号码时另设主被叫号码类型 设置为启用 时，此配置项有效；用于设置在IP到PSTN的呼叫中，IP端带有改发号码时，setup消息中被叫号码的号码类型及编号方案。可选的参数包括国内号码 、国际号码 、网络号码 、用户号码 和未知号码，默认值为国内号码。
主叫号码类型 | 有改发号码时另设主被叫号码类型 设置为启用 时，此配置项有效；用于设置在IP到PSTN的呼叫中，IP端带有改发号码时，setup消息中主叫号码的号码类型及编号方案。可选的参数包括国内号码 、国际号码 、网络号码 、用户号码 和未知号码，默认值为国内号码。
负载能力 | 设置信令消息中负载能力字段的内容。可选的参数包括Voice 和3.1k Audio，默认值为Voice。
收到CALL PROCEEDING消息自动进入提醒状态 | 勾选此配置项表示收到02（CALL PROCEEDING）消息，进展指示为8或1时，自动进入提醒状态。默认不勾选此配置项。
收到PROGRESS消息自动进入提醒状态 | 勾选此配置项表示收到03（PROGRESS）消息，进展指示为8或1时，自动进入提醒状态。默认不勾选此配置项。
输出ISDN调试消息前先将ISDN消息进行解码 | 输出ISDN调试消息前先将ISDN消息进行解码。
最大等待被叫摘机时间 | 在去话呼叫过程中，当通道状态迁移到"WaitAnswer"后，等待被叫用户摘机的最大等待时间。单位为秒，默认值为60。
来话呼叫的被叫号码最小长度 | 设置使用指定长度的收号规则时，被叫号码的最小长度，长度范围为1£n£40。若此处设置为n，即在来话呼叫时，如果本端收齐了n个被叫号码，就认为收号过程结束。
主叫属性呈现表示语 | 设置主叫属性呈现表示语，包含允许显示、限制显示、因互通而无法提供号码和保留四种方式，默认值为允许显示。
主叫属性屏蔽指示语 | 设置主叫属性屏蔽指示语，包含用户提供，未加检查；用户提供，检验并传送；网络提供三种方式，默认值为用户提供，检验并传送。
默认改发号码类型 | 去话呼叫时，设置setup消息中改发号码类型及编号方案。可选的参数包括国内号码 、国际号码 、网络号码 、用户号码 和未知号码，默认值为国内号码。
被叫付费电话 | setup消息中如果带了reverse charging indication，则网关可选择1：接受呼叫 2：拒接 3：invite消息中带上x-BRCollectCall: 1 告之服务器
发送“被叫号码全”参数 | 去话呼叫时，是否在SETUP消息中包含“被叫号码全”参数。
等待确认时间（T310） | 在去话呼叫过程中，设置本端等待对端发送确认消息的最大等待时间。如果没有在此配置项设置的时间内收到对端的确认消息，本端将主动拆线。对于ISDN用户侧，此配置项默认值为15，对于ISDN网络侧，此配置项默认值为20，单位为秒。
发送通路识别信息 | 来话呼叫时，设置当本端收到对端交换机的SETUP消息后，在相应的应答信号中（如CALL PROCEEDING、ALERT等）是否包含通路识别信息。默认勾选此配置项。
设置原因值长度2字节 | 该功能启用后，status(0x7d), release(0x4d), disconnect(0x45消息中的原因值字段采用2字节格式，默认为不开启，3字节。


3.5.2 号码参数设置

图 3‑50 号码参数设置界面

ISDN号码参数设置的设置方式和SS7号码参数设置一样，只是主、被叫号码由SS7变成了ISDN，存在原被叫号码时才设置此参数变为存在改发号码时才设置此参数。ISDN号码参数设置界面如 图 3‑50 所示，界面中各配置项的意义及配置方法与SS7号码参数设置 界面的对应配置项一样。


3.5.3 改发号码池（默认隐藏）

图 3‑51 改发号码池设置界面

当用户需要设置改发号码池时，在浏览器地址栏输入 http://所使用网关的IP地址/gfhmc.php 后，会显示ISDN改发号码池。其设置方式和SS7原被叫号码池一样，只是主、被叫号码由SS7变成了ISDN。ISDN改发号码池界面如 图 3‑51 所示，界面中各配置项的意义及配置方法与SS7原被叫号码池 界面的对应配置项一样。


3.6 SS7设置

用户只有在PCM设置界面的信令方式 配置项设置为7号信令-TUP 或7号信令-ISUP 时才能看到SS7设置菜单。SS7设置包括TUP设置、TUP号码参数、ISUP设置、ISUP号码参数、原被叫号码池、改发的号码池（默认隐藏）和SS7服务器设置七个部分。如 图 3‑52 所示。

图 3‑52 SS7设置功能列表


3.6.1 TUP设置

图 3‑53 TUP设置界面

TUP设置界面如 图 3‑53 所示。用户只有在PCM设置界面的信令方式 配置项设置了7号信令-TUP时才能看到该配置界面并修改TUP通用信息。配置完成后，点击保存 将以上设置存入网关，如果保存后弹出页面提示“重启服务后生效”，需要重启网关服务，操作方法见 3.11.24重启网关 。点击重置 可恢复当前配置。界面中的各配置项说明如下：

配置项 | 说明
采用“全0范围字段”发送GRM群消息 | 此配置项启用时，当本端驱动程序向对端交换机发送电路群消息时，该电路群消息覆盖的时隙范围为时隙1~31。默认值为启用。
去话接续时发送主叫的脉冲终了信号 | 此配置项启用时，网关发送的主叫号码字符串中包含ST信号（脉冲终了信号）。默认值为不启用。
去话接续时发送被叫的脉冲终了信号 | 此配置项启用时，网关发送的被叫号码字符串中包含ST信号（脉冲终了信号）。默认值为不启用。
设置地址信号中备用值的对应字符 | 用于设置地址信号中备用值的对应字符，实现将地址信号中的备用值映射到特定的字符。, 注：映射的字符不能为‘0’～‘9’中的任何一个字符；如果映射的字符超过一个字符，则备用值对应的编码字符为映射字符的第一个字符。
默认主叫号码参数 | 设置IAI消息中主叫用户线标识字段的地址表示语，可选的参数包括市内用户号码、国内备用、国内有效号码和国际号码，默认值为国内有效号码。
有原被叫号码时另设主叫号码参数 | 此功能启用时，在IP到PSTN的呼叫中，如果IP端带有原被叫号码，IAI消息中主叫用户线标识字段的地址表示语需要使用特别设定的参数，即有原被叫时的主叫号码参数。默认值为不启用。
有原被叫时的主叫号码参数 | 有原被叫号码时另设主叫号码参数 设置为启用 时，此配置项有效；用于设置在IP到PSTN的呼叫中，IP端带有原被叫号码时，IAI消息中主叫用户线标识字段的地址表示语。可选的参数包括市内用户号码 、国内备用 、国内有效号码 和国际号码，默认值为国内有效号码。
默认原被叫号码参数 | 用于设置IAI消息中原被叫地址字段的地址表示语。可选的参数包括市内用户号码 、国内备用 、国内有效号码 和国际号码，默认值为国内有效号码。
最大等待被叫摘机时间(秒) | 去话呼叫过程中等待被叫应答的时间。如果对方在指定时间内没有应答，则通道自动取消此次呼叫。默认值为60，单位为秒。
来话呼叫的被叫号码最小长度 | 设置使用指定长度的收号规则时，被叫号码的最小长度，长度范围为1£n£40，默认值为40。若此处设置为n，即在来话呼叫时，如果本端收齐了n个被叫号码，就认为收号过程结束。


3.6.2 TUP号码参数

图 3‑54 TUP号码参数设置界面

TUP号码参数设置界面如 图 3‑54 所示，用于设置TUP号码的主叫号码相关参数。通过点击列表右下角的添加 添加主叫号码参数，见 图 3‑55 。

图 3‑55 主叫号码参数添加界面

以上各配置项说明如下：

配置项 | 说明
判断号码变换前的主被叫前缀 | 设置是否使用号码变换前的主被叫前缀作为判断条件，默认为不启用，即仅判断变换后号码的主被叫前缀。
编号 | 主叫号码参数设置对应的编号。编号从0开始。
主叫号码前缀、被叫号码前缀 | 设置主叫号码/被叫号码开头的字符串。
主叫号码参数 | 设置主叫号码对应的参数类型。
存在原被叫号码时才设置此参数 | 设置是否启用存在原被叫号码时才设置此参数功能。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。点击修改 可修改对应主叫号码参数，如 图 3‑56 所示。修改界面各配置项的意义与添加界面相同。

图 3‑56 主叫号码参数修改界面

主叫号码参数列表下方的删除所选 用于删除选中的主叫号码参数；清空 用于一键清除所有主叫号码参数。

注：TUP号码参数设置时若出现主叫号码前缀重复的两条或多条设置，则主叫号码参数以编号最小的设置有效，其他设置自动失效。


3.6.3 ISUP设置

图 3‑57 ISUP设置界面

ISUP设置界面如 图 3‑57 所示。用户只有在PCM设置界面的信令方式 配置项设置了7号信令-ISUP时才能看到该配置界面并修改ISUP通用信息。配置完成后，点击保存 将以上设置存入网关，如果保存后弹出页面提示“重启服务后生效”，需要重启网关服务，操作方法见 3.11.24重启网关 。点击重置 可恢复当前配置。界面中的各配置项说明如下：

配置项 | 说明
主叫用户类别 | 设置IAM消息中的主叫用户类别，可选的参数包括国内话务员 、普通用户、优先主叫用户、数据呼叫、测试呼叫、付费电话/其他和普通主叫用户，默认值为普通用户。
默认主叫号码参数 | 设置IAM消息中主叫用户号码字段的主叫参数，可选的参数包括用户号码、国内号码和国际号码。默认值为用户号码。
默认被叫号码参数 | 设置IAM消息中被叫用户号码字段的被叫参数，可选的参数包括用户号码、国内号码和国际号码。默认值为国内号码。
有原被叫号码时另设主被叫号 码参数 | 此功能启用时，在IP到PSTN的呼叫中，如果IP端带有原被叫号码，IAM消息中主叫用户号码字段的主叫参数和被叫用户号码字段的被叫参数需要使用特别设定的参数，即有原被叫时的主叫号码参数和有原被叫时的被叫号码参数。默认值为不启用。
有原被叫时的主叫号码参数 | 有原被叫号码时另设主被叫号码参数 设置为启用 时，此配置项有效；用于设置在IP到PSTN的呼叫中，IP端带有原被叫号码时， IAM消息中主叫用户号码字段的主叫参数。可选的参数包括用户号码、国内号码 和国际号码。默认值为用户号码。
有原被叫时的被叫号码参数 | 有原被叫号码时另设主被叫号码参数 设置为启用 时，此配置项有效；用于设置在IP到PSTN的呼叫中， IP端带有原被叫号码时，IAM消息中被叫用户号码字段的被叫参数。可选的参数包括用户号码、国内号码 国际号码。默认值为国内号码。
默认原被叫号码参数 | 设置IAM消息中原被叫的头两字节信息，包括地址性质表示语、编号计划、限制提供。默认值为0x1001。
发送通用号码 | 设置IAM消息是否发送通用号码，默认值为不启用。
通用号码属性 | 设置IAM消息中通用号码属性，仅当启用发送通用号码功能时，该配置有效。
传输媒介要求 | 设置IAM消息中的传输媒介要求。可选的参数包括语音、64kb/s不受限、3.1khz音频、语音与不受限交替（备用）、不受限与语音交替（备用） 、64kb/s优选、2*64kb/s不受限、384kb/s不受限、1920kb/s不受限和备用。默认值为语音。
原被叫号码来源选择 | 设置原被叫号码的来源，可选的参数包括原被叫号码和原被叫号码或改发的号码。默认值为原被叫号码或改发的号码。
业务开通后首先进入复原，否 则空闲 | 此功能启用时，ISUP业务开通后电路进入复原状态，否则电路进入空闲状态。默认值为启用。
收到CPG消息回复多个 180/183 | 该功能启用后，收到acm消息，触发183，收到第一个cpg消息，触发180，收到第二个cpg消息，触发183，后面收到的的cpg消息将不触发消息。默认值是不启用。
去话接续时发送主叫的脉冲终 了信号 | 此配置项启用时，网关发送的主叫号码字符串中包含ST信号（脉冲终了信号）。默认值为不启用。
去话接续时发送被叫的脉冲终 了信号 | 此配置项启用时，网关发送的被叫号码字符串中包含ST信号（脉冲终了信号）。默认值为不启用。
设置地址信号中备用值的对应 字符 | 用于设置地址信号中备用值的对应字符，实现将地址信号中的备用值映射到特定的字符。, 注：映射的字符不能为‘0’～‘9’中的任何一个字符；如果映射的字符超过一个字符，则备用值对应的编码字符为映射字符的第一个字符。
发送改发的号码 | 是否发送ISUP改发号码的开关，默认为开。
改发的号码的头两字节信息 | 设置IAM消息中改发的号码的头两字节信息，包括地址性质表示语、编号计划、限制提供。默认值为0x1001。
改发信息 | 设置在IAM消息中添加改发信息字段。改发信息字段的参数类型为0x13，共包含2个字节，默认值为0x0331。 注：该配置只在进行呼叫测试时有效，正常呼叫时无效，且 改发的号码池 中改发信息的配置值会自动覆盖本配置项值。
最大等待被叫摘机时间 | 去话呼叫过程中等待被叫应答的时间，如果对方在指定时间内没有应答，则通道自动取消此次呼叫。默认值为180，单位为秒。
来话呼叫的被叫号码最小长度 | 设置使用指定长度的收号规则时，被叫号码的最小长度，长度范围为1£n£40。若此处设置为n，即在来话呼叫时，如果本端收齐了n个被叫号码，就认为收号过程结束。
前向呼叫指示语 | 设置IAM消息中的前向呼叫指示语。默认值为0x0040。
连接性质表示码 | 设置IAM消息中的连接性质表示语。默认值为0x00。
用户业务信息 | 设置IAM消息中是否包含用户业务信息内容，默认值为不启用。启用此配置项时，具体取值由对端交换机的配置决定，默认值为0x80,0x90,0xa3，适用于华为交换机。
任选前向呼叫表示语 | 设置IAM消息中是否包含任选前向呼叫表示语，默认值为不启用。启用此配置项时，具体取值由对端交换机的配置决定，默认值为0x00。


3.6.4 ISUP号码参数

图 3‑58 ISUP号码参数设置界面

ISUP号码参数设置包括主叫号码参数和被叫号码参数两部分，如 图 3‑58 所示。

点击右下方的添加 可以添加主/被叫号码参数，如下 图 3‑59 、 图 3‑60 。

图 3‑59 主叫号码参数添加界面

图 3‑60 被叫号码参数添加界面

以上各配置项说明如下：

配置项 | 说明
判断号码变换前的主被叫前缀 | 设置是否使用号码变换前的主被叫前缀作为判断条件，默认为不启用，即仅判断变换后号码的主被叫前缀。
编号 | 主/被叫号码参数设置对应的编号。编号从0开始。
主叫号码前缀 | 设置主叫号码开头的字符串。
主叫号码参数 | 设置主叫号码对应的参数类型。
被叫号码前缀 | 设置被叫号码开头的字符串。
被叫号码参数 | 设置被叫号码对应的参数类型。
存在原被叫号码时才设置此参数 | 设置是否启用存在原被叫号码时才设置此参数功能。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。

点击修改 可修改对应主/被叫号码参数，如 图 3‑61 、 图 3‑62 所示。修改界面各配置项的意义与添加界面相同。

图 3‑61 主叫号码参数修改界面

图 3‑62 被叫号码参数修改界面

主/被叫号码参数列表下方的删除所选 用于删除选中的主/被叫号码参数；清空 用于一键清除所有主/被叫号码参数。

注：ISUP号码参数设置时若出现主/被叫号码前缀重复的两条或多条设置，则主/被叫号码参数以编号最小的设置有效，其他设置自动失效。


3.6.5 原被叫号码池

图 3‑63 原被叫号码池设置界面

原被叫号码池设置界面如 图 3‑63 所示，用于给网关所有PSTN出局的呼叫或者指定的包含主/被叫号码前缀的呼叫增加原被叫号码。通过点击列表右下角的添加 添加原被叫号码，见 图 3‑64 。

图 3‑64 原被叫号码池添加界面

以上各配置项说明如下：

配置项 | 说明
编号 | 添加的原被叫号码在号码池中所对应的编号。编号范围：0～99。
主叫号码前缀 | 设置主叫号码开头的字符串，可以是数字或者“*”（ *代表任意字符串）。
被叫号码前缀 | 设置被叫号码开头的字符串，可以是数字或者“*”（ *代表任意字符串）。
原被叫号码范围 | 原被叫号码池中开始和结束的原被叫号码范围，不能为空。只能填入数字。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。

点击 图 3‑63 中修改 可修改对应的原被叫号码池信息，如 图 3‑65 所示。修改界面各配置项的意义与添加界面相同。修改界面不允许修改编号。

图 3‑65 原被叫号码池修改界面

注：设置两条或多条主/被叫号码前缀重复的原被叫号码池时，则起始原被叫号码从编号最小的设置开始以递增/循环递增的机制，合理利用所设置的原被叫号码池。


3.6.6 改发的号码池（默认隐藏）

图 3‑66 改发的号码池设置界面

当用户需要设置改发的号码池时，在浏览器地址栏输入 http://所使用网关的IP地址/gfdhmc.php 后，会显示SS7改发的号码池设置界面，如 图 3‑66 所示，用于设置网关所有PSTN出局或者指定的包含主/被叫号码前缀的呼叫建立消息中的改发的号码，只适用于ISUP呼叫。通过点击列表右下角的添加 添加改发的号码，见 图 3‑67 。

图 3‑67 改发的号码添加界面

以上各配置项说明如下：

配置项 | 说明
编号 | 添加的改发的号码在号码池中所对应的编号。编号范围：0～99。
主叫号码前缀 | 设置主叫号码开头的字符串，可以是数字或者“*”（*代表任意字符串）。
被叫号码前缀 | 设置被叫号码开头的字符串，可以是数字或者“*”（*代表任意字符串）。
改发信息 | 设置IAM消息中的改发信息字段。改发信息字段的参数类型为0x13，共包含2个字节。默认值为0x0331，即用户无应答前转。各字节具体含义参见ISUP协议书规定。
改发的号码范围 | 改发的号码池中开始和结束的改发的号码范围，不能为空。只能填入数字。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。

点击 图 3‑66 中修改 可修改对应的改发的号码池信息，如 图 3‑68 所示。修改界面各配置项的意义与添加界面相同。修改界面不允许修改编号。

图 3‑68 改发的号码修改界面

改发的号码池列表下方的删除所选 用于删除选中的改发的号码；清空 用于一键清除所有改发的号码。

注：设置两条或多条主/被叫号码前缀重复的改发的号码池时，则起始改发的号码以编号最小的设置开始以递增/循环递增的机制，合理利用所设置的改发的号码池。


3.6.7 SS7服务器设置

图 3‑69 SS7服务器设置界面

网关使用7号信令时，必须首先运行SS7服务器。SS7服务器设置界面如 图 3‑69 所示，用于设置7号信令服务器程序的配置文件（Ss7server.ini） 。配置可按以下步骤进行：

第一步，配置服务器IP地址和信令点码编码标准，见 图 3‑69 区域1。各配置项具体说明如下：

配置项 | 说明
信令点码编码标准 | 此配置项的值根据交换机的选择确定，可选的取值为14和24。中国国内7 号信令公共信道网统一采用24位编码方式。默认值为24。
子业务编码 | 设置SS7子业务编码，可选的参数包括：国际网络、国际备用、国内网络、国内备用，默认值为国内网络。
发送测试消息 | 设置是否向对端交换机发送信令链路测试消息。默认为不启用。
级联功能 | 该功能启用后，支持两台光口网关共用一个信令点码。
本机IP、级联网关IP | 设置网关/级联网关的IP地址。
0号对端CIC_PCM范围、1号对端CIC_PCM范围 | 设置级联网关的CIC_PCM范围。

配置完成后，点击保存 可将以上配置存入网关。

第二步，配置信令链路和链路组，见 图 3‑69 区域3。

在两个信令点之间传送信令消息的链路称为信令链路。信令链路与其物理地址存在一一对应关系。点击信令链路列表右下方的添加 可以添加信令链路，见 图 3‑70 。

图 3‑70 添加信令链路界面

各配置项具体说明如下：

配置项 | 说明
信令链路编号 | 信令链路的唯一标识，用于在配置链路组时对应需要配置的信令链路。编号从0开始。
PCM组 | PCM组编号。此配置项与PCM 共同配置信令链路对应的E1口的物理地址。物理地址与信令链路存在一一对应关系。
LINK | 信令时隙的编号，从0开始。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。点击信令链路列表中的修改 可修改对应信令链路，信令链路修改界面各配置项的意义与信令链路添加界面相同。

信令链路列表下方的删除所选 用于删除选中的信令链路；清空 用于一键清除所有信令链路。注意：删除或清空时，无法直接删除被链路组占用的信令链路，必须首先删除占用该信令链路的链路组。删除时，必须从列表末端的信令链路开始向前删除。

直接连接两个信令点的所有信令链路构成链路组。点击信令链路组列表右下方的添加 可以添加信令链路组，见 图 3‑71 。

图 3‑71 添加链路组界面

各配置项具体说明如下：

配置项

说明

链路组编号

信令链路组的唯一标识，用于在配置DPC时对应需要配置的信令链路组。编号从0开始。

信令链路

链路组中包含的信令链路。信令链路前的复选框呈灰色表示该信令链路已被占用，不能选择。

对应OPC

信令消息的起源点（Originating Point Code），用于设置信令服务器的信令点编码，通常由电信局分配。

格式及取值范围如下表所示：

 | 14位点码 | 24位点码
十进制（a.b.c） | a、c为0～7，b为0～255 | a、b、c均为0～255
十六进制（abc） | a、c为3位十六进制数值，b为8位十六进制数字 | a、b、c均为00～ff之间十六进制数值

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。点击链路组列表中的修改 可修改对应链路组，链路组修改界面各配置项的意义与链路组添加界面相同。

链路组列表下方的删除所选 用于删除选中的链路组；清空 用于一键清除所有链路组。注意：删除或清空时，无法直接删除被DPC占用的链路组，必须首先删除占用该链路组的DPC。删除时，必须从列表末端的链路组开始向前删除。

第三步，配置DPC，见 图 3‑69 区域4。

信令消息的目的点为DPC（Destination Point Code）。点击DPC设置列表右下方的添加 可以添加DPC，见 图 3‑72 。

图 3‑72 添加DPC界面

各配置项说明如下：

配置项 | 说明
DPC编号 | DPC的唯一标识，用于在配置TUP_CIC路由或ISUP_CIC路由时对应需要配置的DPC。编号从0开始。
直联/准直联 | 两个信令点之间传递信令消息的方式，包括直联 和准直联。两个信令点之间的信令消息，通过直接连接两个信令点的信令链路组进行传递，称为直联工作方式。两个信令点之间的信令消息，通过两个或多个串接的信令链路组成的固定通路进行传递，称为准直联工作方式。如下图所示：
信令点码、局端SP | DPC的信令点码，通常由电信局分配。
信令转接点 | 设置准直联工作方式下信令消息传递过程中经过的第一个信令转接点（STP）。只有在准直联工作方式下，用户才可以看到并需要设置此配置项。
对应链路组 | 用于传递信令消息的链路组。对于直联工作方式，此配置项设置OPC与DPC之间的链路组；对于准直联工作方式，此配置项设置从OPC到第一个STP（信令转接点）之间的链路组。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。点击DPC设置列表中的修改 可修改对应DPC，DPC修改界面各配置项的意义与DPC添加界面相同。

DPC设置列表下方的删除所选 用于删除选中的DPC；清空 用于一键清除所有DPC。注意：删除或清空时，无法直接删除被TUP_CIC路由或ISUP_CIC路由占用的链路组，必须首先删除占用该DPC的路由。

第四步，配置TUP_CIC路由或ISUP_CIC路由，见 图 3‑69 区域5。

点击TUP_CIC路由列表右下方的添加TUP_CIC路由 可以添加TUP_CIC路由，见 图 3‑73 。

图 3‑73 添加TUP_CIC路由界面

各配置项说明如下：

配置项 | 说明
编号 | CIC路由的唯一标识。编号从0开始。
对应DPC | 配置CIC路由使用的DPC。
CIC_PCM | CIC字段中的PCM编号，由电信局分配的电路CIC起始编号除以32后得到的值。
CIC范围 | CIC对应的PCM时隙的范围。
PCM组 | PCM组的编号。此配置项与PCM 共同配置该CIC路由对应的本地PCM。
PCM | PCM本地编号。
为此DPC连续添加_条CIC_PCM消息路由 | 可以为一个DPC连续添加多条CIC_PCM消息路由。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。点击TUP_CIC路由设置列表中的修改 可修改对应TUP_CIC路由，TUP_CIC路由修改界面各配置项的意义与TUP_CIC路由添加界面相同。

TUP_CIC路由设置列表下方的删除所选 用于删除选中的信令链路；清空TUP_CIC路由 用于一键清除所有TUP_CIC路由。

点击 图 3‑69 区域5中的ISUP_CIC路由设置选项卡可以切换到ISUP_CIC路由设置界面，如 图 3‑74 所示，ISUP_CIC路由设置各配置项的意义及配置方法与TUP_CIC路由设置界面的对应配置项完全相同，需要注意ISUP_CIC路由设置中的CIC范围，除默认配置外，用户还可自定义。

图 3‑74 ISUP_CIC路由设置界面

完成SS7服务器设置界面的配置后，需要重启网关服务才能使配置生效，操作方法见 3.11.24重启网关 。


3.7 传真设置

传真设置界面如 图 3‑75 所示。传真参数用于修改传真功能的专用配置。

图 3‑75 传真设置功能列表


3.7.1传真参数

图 3‑76 传真参数界面（T.38模式）

采用默认配置的传真参数界面（传真模式为T.38）如 图 3‑76 所示，用户可以通过该界面设置传真通用信息。配置完成后，点击保存 将以上设置存入网关，如果保存后弹出页面提示“重启服务后生效”，需要重启网关服务，操作方法见3.11.24重启网关。点击重置 可恢复当前配置。界面中的各配置项说明如下：

配置项 | 说明
传真模式 | 实时IP传真模式，可选的参数包括 T.38 、Pass-Through 和 Disable。默认为 T.38，此配置项设置为 Disable 表示关闭传真的T.38模式和Pass-Through模式。
T38版本 | ITU-T定义T.38建议书的版本号，取值范围为0~3，默认值为0。
T38属性协商 | 设置T38属性协商方式，包括不支持、做发送方时发起协商和做接收方时发起协商， 默认为做接收方时发起协商。
最大传真速率 | 设置接收或发送传真时使用的最大速率。取值范围包括14400、9600和4800，单位为bps，默认值为9600。
训练方式 | T.38传真的训练方式。可选的参数包括 transferredTCF 和 localTCF，默认值为 transferredTCF。
纠错模式 | T.38传真的纠错方式。可选的参数包括 t38UDPRedundancy（冗余错误纠正机制）和 t38UDPFEC（前向错误纠正机制），默认值为 t38UDPRedundancy。
T.30 Ecm | 设置是否启用T.30纠错模式（ECM: Error Correction Mode），默认值为启用。
CNG信号最短持续时长 | 根据标准传真CNG信号规定，CNG最短持续时长为500ms ± 15%，单位为ms，默认值为425。 注：正常情况下无须更改该值，如须修改，请联系我方技术支持。
CED信号最短持续时长 | 根据标准传真CED信号规定，CED最短持续时长为2600~4000ms，单位为ms，默认值为2600。 注：正常情况下无须更改该值，如须修改，请联系我方技术支持。

如果传真模式设置为Pass-Through，传真参数界面如 图 3‑77 所示。

图 3‑77传真参数界面（Pass-Through模式）

界面中的配置项说明如下：

配置项 | 说明
透传负载值 | Pass-Through传真模式下的RTP负载值，取值范围为96~127，默认值为102。


3.8 路由设置

路由设置用于规定IP àPSTN和PSTNàIP两个方向呼叫的路由选择方式，如 图 3‑78 所示。

图 3‑78 路由设置功能列表


3.8.1 IP to PSTN路由

图 3‑79 IPàPSTN路由规则配置界面

IPàPSTN路由规则配置界面如 图 3‑79 所示。路由规则可以通过点击列表右下角的添加路由规则 添加，见 图 3‑80 。

图 3‑80 IPàPSTN路由规则添加界面

以上界面中各配置项的说明如下：

配置项

说明

索引

路由规则的索引，具有唯一性，并且规定了路由规则的优先级，该配置项的值越小优先级越高。用于当一通呼叫同时匹配多条路由规则时，选用优先级最高的路由规则来处理。

呼叫来源

表示呼叫来自于哪个SIP中继组。此配置项可以选择具体的SIP中继组，也可以选择SIP中继组[ANY]来表示任意SIP中继组。

主叫前缀、被叫前缀

主被叫号码开头的字符串，可以用“*”来代表任意字符串。此配置项与呼叫来源 一起规定了适用这条规则的呼叫。

规则说明：

字符 | 含义
“0”~”9” | 数字0～9。
“[ ]” | 表示一个数字，该数字是前后用一对”[”、”]”括起来的范围内的任意值，“[ ]”内的值只支持数字“0”~”9”、“-”和“,”。 举例：[1-3,6,8]表示集合1、2、3、6、8内的任意一个数字。
“-” | 两个数字之间用“-”相隔，表示该区间之内的任何数字。“-”只能出现在“[ ]”中。
“,” | 两个数字或数字区间之间用“,”相隔，表示两者之间为选择关系。“,”只能出现在“[ ]”中。

举例：规则“0[0-3,7][6-9]”表示前缀为006、016、026、036、007、017、027、037、008、018、028、038、009、019、029、039、076、077、078、079。

注：主、被叫号码前缀支持多个规则，不同规则间用“:”分开。

呼叫目的

指定这条路由规则最终路由的目的PCM中继组。

号码过滤

指定这条路由适用的号码过滤规则。具体过滤规则在号码过滤 里设置，见3.9.4过滤规则。

描述

用于标识路由规则，方便查看。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑79 中的修改 可以对已经配置的路由规则进行修改，修改界面如 图 3‑81 所示。修改界面各配置项的意义与路由规则添加 界面的对应配置项相同。修改界面不允许修改索引。

图 3‑81 IPàPSTN路由规则修改界面

如果需要删除路由规则，可以在 图 3‑79 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空路由 可以一键清除所有路由规则。


3.8.2 PSTN to IP路由

图 3‑82 PSTNàIP路由规则配置界面

PSTNàIP路由规则配置界面如 图 3‑82 所示。路由规则可以通过点击列表右下角的添加路由规则 添加，见 图 3‑83 。

图 3‑83 PSTNàIP路由规则添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
索引 | 路由规则的索引，具有唯一性，并且规定了路由规则的优先级，该配置项的值越小优先级越高。用于当一通呼叫同时匹配多条路由规则时，选用优先级最高的路由规则来处理。
呼叫来源 | 表示呼叫来自于哪个PCM中继组。
主叫前缀、被叫前缀 | 主被叫号码开头的字符串，可以用“*”来代表任意字符串。此配置项与呼叫来源 一起规定了适用这条规则的呼叫。 具体规则说明见IP to PSTN路由主叫前缀、被叫前缀处规则说明。 注：主、被叫号码前缀支持多个规则，不同规则间用“:”分开。
呼叫目的 | 指定这条路由规则最终路由的目的SIP中继组。
号码过滤 | 指定这条路由适用的号码过滤规则。具体过滤规则在号码过滤 里设置，见3.9.4过滤规则。
描述 | 用于标识路由规则，方便查看。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑82 中的修改 可以对已经配置的路由规则进行修改，修改界面如 图 3‑84 所示。修改界面各配置项的意义与路由规则添加 界面的对应配置项相同。修改界面不允许修改索引。

图 3‑84 PSTNàIP路由规则修改界面

如果需要删除路由规则，可以在 图 3‑82 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空路由 可以一键清除所有路由规则。


3.9 号码过滤

号码过滤界面如 图 3‑85 所示，包括白名单、黑名单、号码池、过滤规则四个部分。

图 3‑85 号码过滤界面


3.9.1 白名单

图 3‑86 白名单设置界面

白名单设置界面如 图 3‑86 所示，包括主叫白名单和被叫白名单两部分。可以通过点击列表右下角的添加 添加主/被叫白名单，见 图 3‑87 、 图 3‑88 。

图 3‑87 主叫白名单号码添加界面

图 3‑88 被叫白名单号码添加界面

以上界面中各配置项的说明如下：

配置项

说明

组号

主/被叫白名单所对应的小组编号。编号范围：0～7。

组内编号

相同组号内不同的主/被叫白名单所对应的编号。

主叫号码

主叫的白名单号码，不能为空。填写规则说明：

字符 | 含义
“*” | 代表任意字符串。
“0”~”9” | 数字0～9。
“x” | 代表一个任意数字；多个x表示多个任意数字，如：xxx表示3个任意数字。
“[ ]” | 表示一个数字，该数字是前后用一对”[”、”]”括起来的范围内的任意值，“[ ]”内的值只支持数字“0”~”9”、“-”和“,”。 举例：[1-3,6,8]表示集合1、2、3、6、8内的任意一个数字。
“-” | 两个数字之间用“-”相隔，表示该区间之内的任何数字。“-”只能出现在“[ ]”中。
“,” | 两个数字或数字区间之间用“,”相隔，表示两者之间为选择关系。“,”只能出现在“[ ]”中。

被叫号码

被叫的白名单号码，不能为空。填写规则见上面主叫号码填写规则。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑86 中的修改 可以对已经配置的主/被叫白名单进行修改，修改界面如 图 3‑89 、 图 3‑90 所示。修改界面各配置项的意义与主/被叫白名单添加 界面的对应配置项相同。修改界面不允许修改组号。

图 3‑89 主叫白名单号码修改界面

图 3‑90被叫白名单号码修改界面

使用主/被叫白名单列表最上方的主/被叫白名单查询搜索框来查询特定的主被叫号码。

主/被叫白名单列表下方的删除所选 用于删除选中的主/被叫白名单；清空 用于一键清除所有主/被叫白名单。

注：当白名单设置的主、被叫号码和黑名单设置的号码重复时，则该条白名单设置无效，即黑名单具有较高优先级。黑、白名单总数不能超过5000条。


3.9.2 黑名单

图 3‑91 黑名单设置界面

黑名单的设置方式和白名单的一样，只是主被叫号码由白名单变成了黑名单。黑名单设置界面如 图 3‑91 所示，界面中各配置项的意义及配置方法与主/被叫白名单 界面的对应配置项功能一样，只是设置的主/被叫号码由白名单变成黑名单。


3.9.3 号码池

图 3‑92号码池设置界面

号码池设置界面如 图 3‑92 所示，可以通过点击列表右下角的添加 添加号码池，见 图 3‑93 。

图 3‑93号码池添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
组号 | 号码池所对应的组编号。编号范围：0～15。
组内编号 | 相同组号内的不同的号码池所对应的编号。一组最多设置100个号码池号码。
号码范围 | 一个号码池中开始和结束的号码范围，不能为空。只能填入数字。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑92 中的修改 可以对已经配置的号码池进行修改，修改界面如 图 3‑94 所示。修改界面各配置项的意义与号码池添加 界面的对应配置项相同。修改界面不允许修改组号。

图 3‑94 主叫号码池修改界面

号码池列表下方的删除所选 用于删除选中的号码；清空 用于一键清除所有号码池。


3.9.4 过滤规则

图 3‑95 过滤规则设置界面

过滤规则设置界面如 图 3‑95 所示，可以通过点击列表右下角的添加 添加过滤规则，见 图 3‑96 。

图 3‑96 过滤规则添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
编号 | 过滤规则所对应的编号。编号范围：0～99。
主叫白名单 | 在主叫白名单界面设置保存的主叫白名单组号。
被叫白名单 | 在被叫白名单界面设置保存的主叫白名单组号。
主叫黑名单 | 在主叫黑名单界面设置保存的主叫黑名单组号。
被叫黑名单 | 在被叫黑名单界面设置保存的被叫黑名单组号。
白名单主叫号码池 | 选择号码池中作为白名单主叫号码池的组号。
黑名单主叫号码池 | 选择号码池中作为黑名单主叫号码池的组号。
白名单被叫号码池 | 选择号码池中作为白名单被叫号码池的组号。
黑名单被叫号码池 | 选择号码池中作为黑名单被叫号码池的组号。
白名单原被叫号码池 | 选择号码池中作为白名单原被叫号码池的组号。
黑名单原被叫号码池 | 选择号码池中作为黑名单原被叫号码池的组号。
描述 | 过滤规则的备注，可以填写任意信息，但不能为空。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑95 中的修改 可以对已经配置的过滤规则进行修改，修改界面如 图 3‑97 所示。修改界面各配置项的意义与过滤规则添加 界面的对应配置项相同。修改界面不允许修改编号。

图 3‑97 过滤规则修改界面

过滤规则列表下方的删除所选 用于删除选中的过滤规则；清空 用于一键清除所有过滤规则。


3.10 号码变换

号码变换包括 IPàPSTN主叫变换、IPàPSTN被叫变换、IPàPSTN原被叫变换、PSTN à IP主叫变换、PSTNàIP被叫变换、PSTNàIP原被叫变换、主叫变换号码池七个部分，如 图 3‑98 所示。

图 3‑98 号码变换功能列表


3.10.1 IP to PSTN主叫变换

图 3‑99 IPàPSTN主叫号码变换界面

IPàPSTN主叫号码变换界面如 图 3‑99 所示。号码变换规则可以通过点击列表右下角的添加号码变换规则 添加，见 图 3‑100 。

图 3‑100 IPàPSTN主叫号码变换规则添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
索引 | 号码变换规则的索引，具有唯一性，并且规定了号码变换规则之间的优先级，该配置项的值越小优先级越高。当一通呼叫同时匹配多条号码变换规则时，选用优先级最高的号码变换规则来处理。
呼叫来源 | 此配置项只能选择SIP中继组[ANY]来表示任意的SIP中继组。
主叫前缀、被叫前缀 | 主被叫号码开头的字符串，可以用“*”来代表任意字符串，此配置项与呼叫来源 、存在原被叫 一起规定了适用这条规则的呼叫。 注：同时可以添加多个主被叫前缀，不同前缀间用“:”分开。
存在原被叫 | 此配置项设置为是 时，只有当呼叫中存在原被叫号码/改发号码时，才会进行相应的号码变换。默认值为否。
左起删除位数 | 将当前号码从左至右删除的号码位数，如果此配置项的值大于当前号码的位数，则删除所有号码。
右起删除位数 | 将当前号码从右至左删除的号码位数，如果此配置项的值大于当前号码的位数，则删除所有号码。
右起保留位数 | 当前号码从右至左最多保留的位数。当号码长度超过该配置项的值时，左边多余的号码都会被删除；当号码长度小于该配置项的值时，则对当前号码不予处理。
前缀添加 | 在当前号码的左边（即号码开头）添加指定的信息。
后缀添加 | 在当前号码的右边（即号码末尾）添加指定的信息。
描述 | 用于标识号码变换规则，方便查看。

注意：左起删除位数 、右起删除位数 、右起保留位数 、前缀添加 、后缀添加 五个配置项的对应操作是按此顺序依次执行的。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑99 中的修改 可以对已经配置的号码变换规则进行修改，修改界面如 图 3‑101 所示。修改界面各配置项的意义与IPàPSTN主叫号码变换规则添加 界面的对应配置项相同。修改界面不允许修改索引。

图 3‑101 IPàPSTN主叫号码变换规则修改界面

如果需要删除号码变换规则，可以在 图 3‑99 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空规则 可以一键清除所有号码变换规则。


3.10.2 IP to PSTN被叫变换

IPàPSTN被叫变换的处理方式与IPàPSTN主叫变换相同，只是处理的对象由主叫号码变成了被叫号码。IPàPSTN被叫号码变换界面如 图 3‑102 所示，界面中各配置项的意义及配置方法与 IPàPSTN主叫号码变换 界面的对应配置项相同。

图 3‑102 IPàPSTN被叫号码变换界面


3.10.3 IP to PSTN原被叫变换

IPàPSTN原被叫变换的处理方式与IPàPSTN主叫变换相同，只是处理的对象由主叫号码变成了原被叫号码。IPàPSTN原被叫号码变换界面如 图 3‑103 所示，界面中各配置项的意义及配置方法与IPàPSTN主叫号码变换 界面的对应配置项相同。

图 3‑103 IPàPSTN原被叫号码变换界面


3.10.4 PSTN to IP主叫变换

图 3‑104 PSTNàIP主叫号码变换界面

PSTNàIP主叫号码变换界面如 图 3‑104 所示。号码变换规则可以通过点击列表右下角的添加号码变换规则 添加，见 图 3‑105 。

图 3‑105 PSTNàIP主叫号码变换规则添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
索引 | 号码变换规则的索引，具有唯一性，并且规定了号码变换规则之间的优先级，该配置项的值越小优先级越高。当一通呼叫同时匹配多条号码变换规则时，选用优先级最高的号码变换规则来处理。
呼叫来源 | 此配置项只能选择PCM中继组[ANY]来表示任意的PCM中继组。
主叫前缀、被叫前缀 | 主被叫号码开头的字符串，可以用“*”来代表任意字符串，此配置项与呼叫来源 、存在原被叫 一起规定了适用这条规则的呼叫。 注：同时可以添加多个主被叫，不同前缀间用“:”分开。
存在原被叫 | 此配置项设置为是 时，只有当呼叫中存在原被叫号码/改发号码时，才会进行相应的号码变换。默认值为否。
左起删除位数 | 将当前号码从左至右删除的号码位数，如果此配置项的值大于当前号码的位数，则删除所有号码。
右起删除位数 | 将当前号码从右至左删除的号码位数，如果此配置项的值大于当前号码的位数，则删除所有号码。
右起保留位数 | 当前号码从右至左最多保留的位数。当号码长度超过该配置项的值时，左边多余的号码都会被删除；当号码长度小于该配置项的值时，则对当前号码不予处理。
前缀添加 | 在当前号码的左边（即号码开头）添加指定的信息。
后缀添加 | 在当前号码的右边（即号码末尾）添加指定的信息。
描述 | 用于标识号码变换规则，方便查看。

注意：左起删除位数 、右起删除位数 、右起保留位数 、前缀添加 、后缀添加 五个配置项的对应操作是按此顺序依次执行的。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑104 中的修改 可以对已经配置的号码变换规则进行修改，修改界面如 图 3‑106 所示。修改界面各配置项的意义与PSTNàIP主叫号码变换规则添加 界面的对应配置项相同。修改界面不允许修改索引。

图 3‑106 PSTNàIP主叫号码变换规则修改界面

如果需要删除号码变换规则，可以在 图 3‑104 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空规则 可以一键清除所有号码变换规则。


3.10.5 PSTN to IP被叫变换

PSTNàIP被叫变换的处理方式与PSTNàIP主叫变换相同，只是处理的对象由主叫号码变成了被叫号码。PSTNàIP被叫号码变换界面如 图 3‑107 所示，界面中各配置项的意义及配置方法与PSTNàIP主叫号码变换 界面的对应配置项相同。

图 3‑107 PSTNàIP被叫号码变换界面


3.10.6 PSTN to IP原被叫变换

图 3‑108 PSTNàIP原被叫号码变换界面

PSTNàIP原被叫变换的处理方式与PSTNàIP主叫变换相同，只是处理的对象由主叫号码变成了原被叫号码。PSTNàIP原被叫号码变换界面如 图 3‑108 所示，界面中各配置项的意义及配置方法与 PSTNàIP主叫号码变换 界面的对应配置项相同。


3.10.7 主叫变换号码池

图 3‑109 主叫变换号码池界面

主叫变换号码池界面如 图 3‑109 所示，包括IPàPSTN主叫变换号码池和PSTNàIP主叫变换号码池两部分。可以设置在外呼时，以该主叫变换号码池中的指定主叫号码进行外呼，并限制每个主叫号码同时呼出的数量。其中，若设置了IPàPSTN指定主叫前缀进行变换，只有当IPàPSTN主叫变换号码池中设置的主叫号码前缀符合要求才能呼出。IPàPSTN指定主叫前缀进行变换设置不能为空，默认为*，即任意主叫号码前缀都可呼出。点击列表右下角的添加 添加主叫号码和呼出资源，见 图 3‑110 。

图 3‑110 主叫变换号码池添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
编号 | 主叫变换号码池中主叫号码的编号，具有唯一性，并且规定了主叫号码之间的优先级，该配置项的值越小优先级越高。
呼出资源 | 设置每条主叫号码可以同时用于外呼的最大数量。
目的PCM | 指定PCM，只有通过该PCM呼出的呼叫才可以进行主叫变换。
主叫号码范围 | 外呼时，设置用于该呼叫的主叫号码范围。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑109 中的修改 可以对已经配置的主叫变换号码池进行修改，修改界面如 图 3‑111 所示。修改界面各配置项的意义与主叫变换号码池添加 界面的对应配置项相同。修改界面不允许修改编号。

图 3‑111 主叫变换号码池修改界面

如果需要删除主叫变换号码池中的号码，可以在 图 3‑109 界面中选择对应项目前的复选框，然后点击删除所选。清空 可以一键清除主叫变换号码池里的所有号码。

注：当开启单E1模式时，主叫变换号码池操作仅针对单个slaver配置，即选择 图 3‑109 右上角当前slaver编号，对当前的slaver的主叫变换进行配置。


3.10.8 主叫号码变换保留池

图 3‑112 主叫号码变换保留池界面

在保留号码池中的主叫号码不会进行号码变换。

图 3‑113 主叫号码变换保留池修改界面


3.11 系统工具

系统工具主要用于整个网关程序的维护，包括IP修改、时间同步、信息恢复、日志查询、连通性查询等功能，具体功能列表如 图 3‑114 所示。

图 3‑114 系统工具功能列表


3.11.1 网络设置

图 3‑115 网络设置界面

网络设置界面如 图 3‑115 所示。网关上有两个业务网口，每个网口都可以配置独立的IP地址（IPv4、IPv6）、子网掩码与默认网关。支持配置DNS服务器。也可以开启Bond功能，对网口1或网口2进行复制备份，实现网口1和网口2的热备份功能，默认为不启用。

注意：1，这两个业务网口不能使用相同网段的IP地址和默认网关。

2，连接速度和双工模式，网关默认配置为自动侦测，不建议客户随意修改，因为非自动侦测模式有可能引起网口异常情况。网关默认隐藏该配置项，可按“F”按键令其显示。

配置完成后，点击保存 将以上设置存入网关。点击重置 可恢复当前配置。IP地址修改后，需要使用新设置的IP地址重新登录。


3.11.2 授权管理

图 3‑116 授权管理界面

授权管理界面如 图 3‑116 所示，通过上传授权文件导入试用或正式授权，授权文件由我们公司提供，客户不可修改。


3.11.3 管理参数

图 3‑117 管理参数配置界面

管理参数配置界面如 图 3‑117 所示。界面中各配置项的具体说明如下：

配置项 | 说明
WEB端口 | WEB进行访问时所携带的端口号。默认为80。
访问设置 | 设置可以进行WEB访问的IP地址。默认为允许所有IP。可以设置IP白名单允许该名单内的IP自由进行WEB访问。也可以设置IP黑名单，禁止该名单内的IP进行WEB访问。
注销时长 | 设置在该配置时长内无人操作，则网关自动注销。默认时长为1800，单位为秒。
启用SSH | 设置是否开启SSH远程访问功能，默认为否。
SSH端口 | 通过SSH远程访问时所携带的端口号。
启用远程抓包功能 | 启用远程抓包功能后，用户可远程使用抓包工具获取网关的数据包，默认为否。
是否抓取RTP | 设置是否抓取RTP，功能启用后可在所选网口上同时抓取RTP包。
启用FTP | 设置是否启用FTP服务器，默认值为是。
启用Telnet | 设置是否启用Telnet功能，默认为是。 注：该配置默认在界面中不显示，点击界面，再按”F”按钮可显示或隐藏该配置项。
启用看门狗 | 设置是否启用看门狗功能，默认值为是。
启用SYSLOG | 设置是否启用SYSLOG。SYSLOG启用后，需要填写SYSLOG服务器地址和SYSLOG级别。SYSLOG默认为不启用。
服务器地址 | 设置接收日志的SYSLOG服务器地址。
SYSLOG级别 | 设置SYSLOG等级。SYSLOG等级包括：ERROR（错误）、WARNING（警告）和INFO（一般信息）三种。
发送CDR | 设置是否启用CDR。CDR启用后，需要填写服务器地址和服务器端口。发送CDR默认为不启用。
服务器地址 | 设置接收CDR的服务器地址。
服务器端口 | 设置接收CDR的服务器端口。
发送失败通话记录 | 该功能勾选后，失败的通话CDR数据也会被发送，否则只发送成功通话的CDR数据。
添加挂机方 | CDR信息中添加哪个方向挂机的字段。
监听自适应 | 开启网关和监听工具的NAT穿透。默认为不启用。
发送筛号数据 | 设置是否发送筛号数据。默认为不启用。
服务器地址 | 设置接收筛号数据的服务器地址。
服务器端口 | 设置接收筛号数据的服务器端口。
启用NTP | 设置是否启用NTP服务器自动同步时间。NTP自动同步启用后，需要填写NTP服务器的地址、同步周期和时区。NTP默认为不启用。
NTP服务器地址 | 设置自动同步时间的NTP服务器地址。
同步周期 | 设置NTP自动同步时间的同步周期。
定时重启 | 设置是否定时重启网关，启用后需要填写重启时间。启用后网关每天会在设定的时间自动重启。默认为不启用此功能。
重启时间 | 设置网关定时重启的时间。
系统时间 | 系统时间，可勾选前面的复选框进行手动修改。
时区 | 网关所在时区。


3.11.4 IP路由表

用户可以设置IP路由表，网关根据路由表设置信息，将IP包按指定路由发送到目的网段。网关默认没有IP路由信息，可以通过点击列表右下角的添加 进行添加，见 图 3‑118 。

图 3‑118 IP路由表添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
编号 | 该路由在路由表中的编号。
目的网段 | IP包可以到达的网段地址。
子网掩码 | 目的网段对应的子网掩码。
网口 | 该路由表对应的网口。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。保存配置后的界面如 图 3‑119 所示。

图 3‑119 IP路由表列表

点击中的修改 可以对已经配置的IP路由表进行修改，修改界面如 图 3‑120 所示。修改界面各配置项的意义与IP路由表添加 界面的对应配置项相同。修改界面不允许修改编号。

图 3‑120 IP路由表修改界面

IP路由表列表下方的删除所选 用于删除选中的路由表；清空 用于一键清除所有路由表。


3.11.5 访问控制

图 3‑121 访问控制列表

访问控制列表（ACL）界面如 图 3‑121 所示，配置ACL后，可以限制网络流量，允许特定设备访问，指定转发特定端口数据包等。点击添加命令，可以添加访问控制命令， 如 图 3‑122 所示。

图 3‑122 访问控制命令添加界面

在命令栏输入ACL命令，配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。命令添加后需点击应用 使其生效。

点击 图 3‑121 中的修改 可以对已经配置的命令进行修改，修改界面如 图 3‑123 所示。修改界面各配置项的意义与访问控制命令添加 界面的对应配置项相同。修改界面不允许修改索引。

图 3‑123 访问控制命令修改界面

如果需要删除访问控制列表，可以在 图 3‑121 界面中选择对应项目前的复选框，然后点击删除所选。命令删除后，点击应用 使删除的命令失效。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空列表 可以一键清除所有访问控制列表。

注：1、目前网关只支持iptables命令。

2、如果是手动添加、修改命令后，不会立即生效，需点击应用 使命令生效，手动删除命令也需点击应用，使删除的命令失效。如果是重启以及导入配置的时候，则命令自动生效，无需点击应用。


3.11.6 证书管理

证书管理即信令加密管理（TLS认证管理），为网络通信提供保密性和数据完整性的一种安全协议，用于保护网关SIP信令连接、Web界面和Telnet服务器。证书管理设置界面如 图 3‑124 所示。

图 3‑124 证书管理界面

以上界面中各配置项的说明如下：

配置项 | 说明
国家 | 国家代码，2个大写字母，例如：CN。其他国家详见:ISO 3166-1 A2。
省份 | 省份，如：Zhejiang。
城市 | 城市，如：Hangzhou。
公司 | 公司名称。
部门 | 部门，如：IT Dept。
主机名 | SBC的IP地址。
Email | 邮箱地址。

配置完成后，点击生成证书 将生成TLS证书；点击重置 可恢复当前设置，点击下载证书 可下载证书查看。


3.11.7 集中管理

图 3‑125 集中管理设置界面

集中管理配置界面如 图 3‑125 所示，启用该功能后，网关可以注册到一个集中管理平台，实现集中管理平台对网关的远程管理。界面中各配置项的具体说明如下：

配置项 | 说明
Notification设置 | 网关主动去发送snmp trap告警信息。
Trap服务器端口 | 接受告警信息的服务器端口，默认162。
CPU温度阈值 | CPU温度过高告警。
CPU使用率阈值 | CPU占用率过高告警。
内存使用率阈值 | 内存占用率过高告警。
并发率过高阈值 | 呼叫并发过高告警。
接通率过低阈值 | 接通率过低告警。
自动切换默认网关 | 该功能启用后，当连接设备云管理平台的网线松动或被拔出时，网关会自动通过另一个网口连接设备云管理平台，默认为关闭。
管理平台 | 选择网关需要注册到的管理平台。
公司名 | 网关在设备云管理平台中注册的公司名，仅在管理平台选择为设备云管理平台有效。
网关描述 | 网关挂载到三汇设备云管理平台中显示的描述，便于在设备分组时进行识别，仅在管理平台选择为三汇设备云管理平台有效。
集中管理协议 | 设置集中管理协议，目前仅支持SNMP。
SNMP版本 | SNMP协议的版本号，包括V1、V2和V3三个版本，默认为V2。
SNMP服务器地址 | 允许访问SNMP功能的IP地址。
监听端口号 | 网关上SNMP的监听端口号。
共同体 | 用于获取信息的共同体。
帐号 | SNMP的帐号名。仅在SNMP版本设置为V3时有效。
等级 | SNMP的等级信息，包括不认证不加密，认证不加密和既认证又加密三种，默认为不认证不加密。仅在SNMP版本设置为V3时有效。
认证密码 | 在等级选择为认证不加密或者既认证又加密时，需要同时输入认证密码。
加密密码 | 在等级选择为既认证又加密时，需要同时输入加密密码。
工作状态 | 显示网关与集中管理服务端的连接状态，仅在管理平台选择为设备云管理平台有效。


3.11.8 筛号管理

图 3‑126 筛号设置界面

筛号管理用于设置网关筛号的一些配置，当IPàPSTN方向的呼叫接通后，网关开始录制声音并保存为文件，筛号模块分析声音文件得到被叫号码的状态，并以SIP状态码的方式将结果发送给IP侧。网关默认是为不启用筛号功能，开启后的界面如 图 3‑126 所示。录音时长用于设置网关录音的时间。经过筛选的号码状态共有18种，用户可自行设置他们分别对应的SIP状态码。

注：普通网关不具备筛号功能，如果需要筛号功能，请购买具有筛号模块的网关。


3.11.9 SIP账号生成工具

图 3‑127 SIP账号生成工具界面

SIP账号生成工具界面如 图 3‑127 所示，网关可将普通的SIP账号和密码转换成网关支持的SIP账户格式，通过数据载入上传需要转换的SIP账号和密码，根据需要，修改SIP中继编号、注册有效期、注册地址和描述等信息后，点击保存，再重新上传SIP账号源文件后，可生成网关支持的SIP账号格式。点击下载，可查看已经生成的SIP账号信息。

注：上传的文件目前只支持txt格式，上传文件中SIP用户名和密码之间必须是“,”隔开。


3.11.10 录音管理

图 3‑128 录音管理设置界面

录音管理设置界面如 图 3‑128 所示，网关可以连接到指定录音服务器上，通过指定网口转发RTP至录音服务器，实现对网关RTP数据抓包。界面中各配置项的具体说明如下：

配置项 | 说明
认证名称 | 网关连接到录音服务器上需要通过的认证名。
认证密码 | 网关连接到录音服务器上需要通过的认证密码。
录音服务器IP | 和网关连接的录音服务器的IP地址。
录音开始时机 | 设置开始录音的时机，包括振铃和通话两种。
录音通话时长最小保存数值 | 通话时长小于设置的值时不保存，默认5秒。
RTP转发网口 | 设置网关转发RTP的网口。

设置后点击保存 即可。点击重置 可恢复当前配置。


3.11.11 配置文件

图 3‑129 配置文件界面

配置文件界面如 图 3‑129 所示，通过该界面可以查看和修改网关相关配置文件，包含SMGConfig.ini、ShConfig.ini和hosts。其中，SMGConfig.ini是网关服务的配置文件，路由规则、号码变换、号码过滤等的配置都包含在这个文件中；ShConfig.ini是板卡相关的配置文件；hosts是将域名与其对应的IP地址建立关联的系统文件。用户可直接在界面上修改配置，点击保存 将以上设置存入网关，点击重置 可恢复当前配置。


3.11.12 信令抓包

图 3‑130 信令抓包界面

信令抓包界面如 图 3‑130 所示，网口抓包用于设置需要抓包的网口。点击开始，将对相应的网口进行抓包（最大能抓800M），目前支持SIP、ISDN、SS7和SysLog抓包，用户可输入Syslog目的地址，将Syslog文件发送至需要的地址。点击停止，停止抓包并下载已抓到的信令包。启用抓取RTP后，需要输入需要抓取的RTP的呼叫号码。

时隙录音（单向）和E1双向录音（双向）用于设置需要录音的端口和时隙。点击开始，将对相应端口的相应时隙进行录音（最长能连续录制时间：单向录音为100分钟，双向录音为1分钟）；点击停止，停止录音并下载已有的录音数据。

点击清理录音和抓包，可清空所有录音和抓包文件，点击下载日志，下载core文件、配置文件、错误信息等文件在内的所有日志。


3.11.13 呼叫测试

图 3‑131 呼叫测试界面

呼叫测试界面如 图 3‑131 所示。主要用来检测网关上配置的路由和号码变换等是否正确，测试呼叫是否能成功。。

以上界面中各配置项的具体说明如下：

配置项 | 说明
测试类型 | 进行呼叫测试的测试类型，包括PSTNàIP和PSTN外呼。
PCM范围 | 当测试类型为PSTNàIP时，需要进一步选择需要进行呼叫测试的PCM中继的范围。
主叫号码 | 呼叫测试时的主叫号码。
被叫号码 | 呼叫测试时的被叫号码。
原被叫号码/改发号码 | 呼叫测试时的原被叫号码/改发号码。
PCM端口 | 当测试类型为PSTN外呼时，需要进一步选择需要进行呼叫测试的PCM端口号。 注：在测试类型为PSTN外呼时，才会显示该配置。
PCM通道 | 当测试类型为PSTN外呼时，需要进一步选择需要进行呼叫测试的PCM通道号。 注：在测试类型为PSTN外呼时，才会显示该配置。
发送通用号码 | 设置IAM消息是否发送通用号码。 注：在测试类型为PSTN外呼时，才会显示该配置。
通用号码 | 设置IAM消息中通用号码。
通用号码属性 | 设置IAM消息中通用号码属性，仅当启用发送通用号码功能时，该配置有效。
DTMF | 当测试类型为PSTN外呼时，用户可以选择通过该配置在通道建立通话后发送DTMF进行通话测试。 注：在测试类型为PSTN外呼时，才会显示该配置。
信令跟踪 | 执行呼叫测试时返回的信令信息，用户可以通过这些信息了解该呼叫测试的具体情况。

配置完成后，点击开始 执行呼叫测试。点击清除 可以清除信令跟踪信息。

注：进行呼叫测试时，当在测试类型选择为PSTN外呼时，网关可以主动结束通话，其他情况，网关端无法主动停止测试，只有被叫端结束呼叫，测试才会结束。


3.11.14 呼叫跟踪

图 3‑132 呼叫跟踪界面

呼叫跟踪界面如 图 3‑132 所示。主要用来输出和保存呼叫相关信息，方便出问题时跟踪信息及调试。包含三种模式：过滤主叫、过滤被叫和全部跟踪。点击开始 执行呼叫跟踪，具体信息将显示在下面的跟踪信息栏中。点击停止，可暂停呼叫跟踪。点击过滤 可根据相关设置，对相关呼叫信息进行过滤。点击清空，清空所有跟踪到的呼叫信息。点击下载，下载跟踪到的呼叫信息。


3.11.15 网络测速

图 3‑133 网络测速界面

网络测速界面如 图 3‑133 所示，用于测试网关所在外网的网络速度，选择连接外网的网口，点击开始，选择最优的外网进行测速，测试信息将显示在下面的信息栏。


3.11.16 PING测试

图 3‑134 Ping测试界面

Ping测试界面如 图 3‑134 所示，用户可以通过网关对指定的IP地址进行Ping测试，检测网关与指定地址的连接情况。以上界面中各配置项的说明如下：

配置项 | 说明
源IP地址选择 | 发起Ping操作的源IP地址。
目的地址 | 需要进行Ping测试的IP地址。
Ping的次数 | 进行Ping操作的次数，取值范围为1~100。
包长 | 进行Ping操作的每个数据包的数据长度，取值范围为56~1024字节。
信息 | 执行Ping操作时的返回信息，用户可以通过这些信息了解网关与目的地址之间的网络连接情况。

配置完成后，点击开始 执行Ping操作。点击结束 可以立即结束Ping操作。


3.11.17 TRACERT测试

图 3‑135 Tracert测试界面

Tracert测试界面如 图 3‑135 所示，该测试用于查看网关与指定的IP地址之间的路由情况。以上界面中各配置项的说明如下：

配置项 | 说明
源IP地址选择 | 发起Tracert操作的源IP地址。
目的地址 | 需要进行Tracert测试的IP地址。
最大跳转数 | 能够显示的网关与目的IP之间的最大跳转次数，取值范围为1~255。
信息 | 执行Tracert操作时的返回信息，用户可以通过这些信息了解网关与目的地址之间的详细跳转情况。

配置完成后，点击开始 执行Tracert操作，点击结束 可以立即结束Tracert操作。


3.11.18 修改记录

图 3‑136 修改记录界面

修改记录界面用于查看网关上配置修改的相关记录。点击查看，页面上将显示这些修改记录，如 图 3‑136 所示。点击下载，可下载修改记录。


3.11.19 备份载入

图 3‑137 数据备份、载入界面

数据备份及数据载入界面如 图 3‑137 所示。用户进行数据备份操作时，需要首先通过数据备份栏的下拉菜单选择需要备份的文件类型，然后点击右侧的备份 按钮将对应的文件备份到本地。用户也可以进行数据载入操作，首先通过数据载入栏的下拉菜单选择需要载入的文件类型，其次点击右侧的栏的浏览… 按钮加载本地备份的文件，最后点击上传 将加载的文件上传至网关。网关会自动使用载入的配置信息覆盖当前的配置。


3.11.20 恢复出厂

图 3‑138 恢复出厂界面

恢复出厂设置界面如 图 3‑138 所示，用户可以点击恢复 将网关上的配置恢复到出厂时的默认配置。


3.11.21 软件升级

图 3‑139 软件升级界面

软件升级界面如 图 3‑139 所示，用于升级网关的WEB界面、网关服务以及内核与固件的版本。升级时，通过浏览 加载对应的*.tar.gz升级包，然后点击更新 等待升级，这时网关会先进行MD5校验，校验通过，方可继续升级。点击重置 可取消上传的更新文件，但不能用于取消更新。


3.11.22 更改口令

图 3‑140 更改口令界面

更改口令界面如 图 3‑140 所示，用户可以在此界面更改网关WEB界面的登录用户名和密码。更改口令需要输入原密码，然后输入新用户名及新密码并确认新密码，修改后点击保存 即可。点击重置 可恢复当前配置。用户名及密码修改后，需要重新登录。


3.11.23 设备锁定

图 3‑141 设备锁定配置界面

设备锁定配置界面如 图 3‑141 所示，选择界面中任意一项或多项条件进行锁定，则网关所有和这些条件相关的配置都被锁定，即修改任意一个和选定的条件相关的配置时，都需要输入锁定密码。设置完成后，点击锁定，设备锁定界面将被锁定，如 图 3‑142 所示。修改和锁定条件相关配置时，都需要输入锁定密码。输入解锁密码（同锁定密码），点击解锁，可进行解锁。

图 3‑142 设备解锁界面


3.11.24 重启网关

图 3‑143 重启网关界面

重启服务及重启系统界面如 图 3‑143 所示，用户可以点击重启服务 对网关服务进行重启，或点击重启系统 对光口网关系统进行重启。


第4章 典型应用配置案例


4.1 典型应用一

图 4‑1 典型应用一

在该应用环境下，总部、分支机构A、分支机构B之间员工的通话完全通过SIP呼叫实现，不经过PSTN网络，所有对公司外部的呼叫均通过总部PBX实现，帮助企业实现了外呼统一通信的需求，也有利于电话录音的管理。

本章节以SMG3064光口网关为例，介绍实现以下拨号规则的网关应用的具体配置。

拨号规则：

总部拨打分支机构A人员：8+分机号

总部拨打分支机构B人员：7+分机号

总部拨打外部号码：0+号码

分支机构A拨打总部人员：9+分机号

分支机构A拨打分支机构B人员：7+分机号

分支机构A拨打外部号码：0+号码

分支机构B拨打总部人员：9+分机号

分支机构B拨打分支机构A人员：8+分机号

分支机构B拨打外部号码：0+号码


4.1.1.1 总部网关配置

1. 总部网关SIP设置。

图 4‑2

2. 添加分支机构A、分支机构B网关的IP地址。

图 4‑3

3. 将对应分支机构A和分支机构B的SIP中继加入到对应的SIP中继组。

图 4‑4

4. 设置PCM中继。

图 4‑5

5. 将PCM中继加入到对应的PCM中继组。

图 4‑6

6. 设置IP->PSTN路由信息。将来自不同SIP中继组的呼叫路由到相应的PCM中继组上，此处不进行号码区分，所有的IP呼入都会路由到PCM中继组0。

图 4‑7

7. 设置PSTN->IP路由信息。将来自对应PCM中继组的呼叫路由到不同的SIP中继组上。此处通过被叫前缀进行路由区分：

当被叫号码以8开头，该呼叫会被路由到SIP中继组0；

当被叫号码以7开头，该呼叫会被路由到SIP中继组1。

图 4‑8

8. 设置号码变换规则。当设备收到来自PSTN的呼叫时，先检查被叫前缀，发现以7/8开头的呼叫，设备会在路由本次呼叫前删除对应的号码7/8。

图 4‑9


4.1.2 分支机构A网关配置

1. 分支机构A网关SIP设置。

图 4‑10

2. 添加总部和分支机构B网关的IP地址。

图 4‑11

3. 将对应总部和分支机构B的SIP中继加入到对应的SIP中继组。

图 4‑12

4. 设置PCM中继。

图 4‑13

5. 将PCM中继加入到对应的PCM中继组。

图 4‑14

6. 设置IP->PSTN路由信息。将来自不同SIP中继组的呼叫路由到相应的PCM中继组上，此处不进行号码区分，所有的IP呼入都会路由到PCM中继组0。

图 4‑15

7. 设置PSTN->IP路由信息。将来自对应PCM中继组的呼叫路由到不同的SIP中继组上。此处用被叫前缀进行路由区分：

当被叫号码以9开头，该呼叫会被路由到SIP中继组0；

当被叫号码以7开头，该呼叫会被路由到SIP中继组1；

当被叫号码以0开头，该呼叫会被路由到SIP中继组0。

图 4‑16

8. 设置号码变换规则。当设备收到来自PSTN的呼叫时，先检查被叫前缀，发现以9/7开头的呼叫，设备会在路由本次呼叫前删除对应的号码9/7。

图 4‑17


4.1.3 分支机构B网关配置

1. 分支机构B网关SIP设置。

图 4‑18

2. 添加总部和分支机构A网关的IP地址。

图 4‑19

3. 将对应总部和分支机构A的SIP中继加入到对应的SIP中继组。

图 4‑20

4. 设置PCM中继。

图 4‑21

5. 将PCM中继加入到对应的PCM中继组。

图 4‑22

6. 设置IP->PSTN路由信息。将来自不同SIP中继组的呼叫路由到相应的PCM中继组上，此处不进行号码区分，所有的IP呼入都会路由到PCM中继组0。

图 4‑23

7. 设置PSTN->IP路由信息。将来自对应PCM中继组的呼叫路由到不同的SIP中继组上。此处用被叫前缀进行路由区分：

当被叫号码以9开头，该呼叫会被路由到SIP中继组0；

当被叫号码以8开头，该呼叫会被路由到SIP中继组1；

当被叫号码以0开头，该呼叫会被路由到SIP中继组0。

图 4‑24

8. 设置号码变换规则。当设备收到来自PSTN的呼叫时，先检查被叫前缀，发现以9/8开头的呼叫，设备会在路由本次呼叫前删除对应的号码9/8。

图 4‑25


4.2 典型应用二

图 4‑26 典型应用二

在该应用环境下，总部、分支机构A、分支机构B均有独立的光口网关与PSTN连接，员工之间的呼叫完全通过SIP实现，对公司外部号码的呼叫可以由软交换服务器均衡分配到不同的网关上，最大程度的利用每条E1/T1中继资源，并大大降低了因设备或网络等因素引起的单点故障，提高电话网络稳定性。

本章节以SMG2120网关为例，介绍实现以下涉及网关的拨号规则的配置说明：

总部拨打外部号码：0+号码

分支机构A、分支机构B拨打外部号码：0+号码


4.2.1 总部网关配置

1. 总部网关SIP设置。

图 4‑27

2. 添加软交换服务器的IP地址。

图 4‑28

3. 将SIP中继加入到对应的SIP中继组。

图 4‑29

4. 设置PCM中继。

图 4‑30

5. 将PCM中继加入到对应的PCM中继组。

图 4‑31

6. 设置IP->PSTN路由信息。将来自SIP中继组的呼叫路由到相应的PCM中继组上，此处不进行号码区分，所有的IP呼入都会路由到PCM中继组0。

图 4‑32

7. 设置PSTN->IP路由信息。将来自PCM中继组的呼叫路由到SIP中继组上。此处不进行号码区分，所有的PSTN呼入都会路由到SIP中继组0。

图 4‑33

说明：

在此应用场景中，号码变换处理由软交换服务器执行，即：总部通过“0+号码”拨打外部号码，软交换服务器执行号码变换，去掉“0”后，再将该号码路由给网关。因此，在此应用场景中，总部网关不需要配置号码变换规则，但用户需要在软交换服务器中添加删除前缀0的号码变换规则。


4.2.2 分支机构网关配置

在上述步骤1中，分支机构A、分支机构B需要将“WAN口选择”配置为各自网关的IP地址。其余内容配置均可与总部完全一致。


附录A 主要技术/性能参数

外形尺寸：

长×高×深＝440×44×690 mm3

重 量：

约12kg

环境要求：

工作温度：0℃—40℃

储存温度：-20℃—85℃

湿 度：8%— 90% 无结露

储存湿度：8%— 90% 无结露

网络接口：

接口数量：2（10/100/1000 BASE-TX（RJ-45））

自适应带宽：支持

自动翻转：支持

光口：

接口数量：1

接口类型：LC

串口：

接口数量：8（USB x2）

波特率：115200bps

接口类型：RJ45（信号定义见硬件描述）

数据位：8 bits

停止位：1 bit

校验：无

流控：无

注意：串口连接时，需要安装USB串口驱动，请向我司技术支持获取，按照以上配置进行设置，否则可能造成异常。

电源要求：

接入电压：100～240V AC

最大消耗功率：167W

信令和协议：

7号信令：TUP协议、ISUP协议

ISDN协议：ISDN用户侧、ISDN网络侧

SIP信令：SIP V1.0/2.0、RFC3261

音频编解码速率：

G.711A | 64 kbps
G.711U | 64 kbps
G.729A/B | 8 kbps
G723 | 5.3/6.3 kbps
G722 | 64 kbps
AMR-NB | 4.75/5.15/5.90/6.70/7.40/7.95/10.20/12.20 kbps
iLBC | 13.3/15.2 kbps
SILK(16K) | 20 kbps
OPUS(16K) | 20 kbps
SILK(8K) | 20 kbps
OPUS(8K) | 20 kbps

采样率：

8kHz

安全防护：

防雷击能力：4级


附录B 常见问题

1、 忘记SMG光口网关的IP地址，如何重新获得？

长按恢复出厂设置键恢复网关的出厂设置，使网关回到缺省的IP地址，两个网口缺省的地址分别为：

LAN1：192.168.1.101

LAN2：192.168.0.101

2、 哪些情况下可以确定SMG光口网关设备出现故障，需要联系我公司的技术支持协助解决？

a) 网关设备运行时，运行灯不闪烁或告警灯点亮或闪烁，且重启设备或长按恢复出厂设置键并重启设备后，该状态都不消失。

b) 通话过程中出现无声、单通、声音质量不好等问题。

c) 网关设备上的光纤正常接线，但LOS指示灯亮。

其它问题比如通道状态显示故障、呼叫不通、注册失败、呼叫号码不正确等情况，一般是由配置错误引起的。用户可以参照第3章 WEB配置仔细检查网关的配置状况。检查配置后，如果仍旧无法排除问题，也可以联系我公司的技术支持。

3、 通过某些浏览器进入光口网关的WEB界面时无法正常登陆，应该如何处理？

请按如下方法在浏览器上进行设置：进入工具àInternet选项à安全，在“受信任的站点”设置中，添加光口网关当前的IP地址即可。在使用光口网关的过程中，如果修改了IP地址，需要将新的IP地址添加到以上设置中。


附录C ISUP (ISDN)挂起原因到SIP状态码对应表

ISUP (ISDN) 返回值 | 取值含义 | SIP状态码 | 取值含义
1 | 未分配的号码 | 404 | 未发现
2 | 无路由到达规定的转接网络 | 404 | 未发现
3 | 无路由到达终点 | 404 | 未发现
26 | 清除未选择的用户 | 404 | 未发现
16 | 正常的呼叫清除（并且失败原因是等待被叫摘机超时） | 603 | 丢弃
16 | 正常的呼叫清除 | 500 | 丢弃
17 | 用户忙 | 486 | 这里忙
132 | 网络忙（内部定义，只适用于ISDN） | 486 | 这里忙
21 | 呼叫拒绝 | 486 | 这里忙
18 | 用户无响应 | 408 | 请求超时
19 | 用户无应答（用户已提醒） | 480 | 临时失效
20 | 用户缺席 | 480 | 临时失效
31 | 正常未规定 | 480 | 临时失效
136 | 摘机后连接失败（内部定义，只适用于ISDN） | 480 | 临时失效
137 | 摘机超时（内部定义，只适用于ISDN） | 480 | 临时失效
55 | CUG内呼入呼叫阻塞 | 403 | 禁止
57 | 承载能力未认可 | 403 | 禁止
87 | 用户不是CUG成员 | 403 | 禁止
22 | 号码变更 | 410 | 离开
27 | 终点故障 | 502 | 坏网关
28 | 无效的号码格式 | 484 | 地址不完整
29 | 性能被拒绝 | 501 | 不可执行
79 | 业务或任选未实施，未规定 | 501 | 不可执行
34 | 无可用的电路/通路 | 503 | 服务无效
38 | 网络失序 | 503 | 服务无效
41 | 临时故障 | 503 | 服务无效
42 | 交换设备拥塞 | 503 | 服务无效
47 | 资源不可用，未规定 | 503 | 服务无效
58 | 目前尚无可用的承载能力 | 503 | 服务无效
88 | 不兼容的终点 | 503 | 服务无效
133 | 电路重启（内部定义，只适用于ISDN） | 503 | 服务无效
134 | 临时故障（内部定义，只适用于ISDN） | 503 | 服务无效
135 | 数据链路故障（内部定义，只适用于ISDN） | 503 | 服务无效
65 | 承载能力未实施 | 488 | 这里请求不可接受
70 | 只有受限的数字信息承载能力可用 | 488 | 这里请求不可接受
102 | 定时器超时的恢复 | 504 | 服务器超时
128 | T303超时（内部定义，只适用于ISDN） | 504 | 服务器超时
129 | T304超时（内部定义，只适用于ISDN） | 504 | 服务器超时
130 | T310超时（内部定义，只适用于ISDN） | 504 | 服务器超时
111 | 协议差错，未规定 | 500 | 服务器内部错误
127 | 互通,未规定 | 500 | 服务器内部错误
其他 | 其他 | 408 | 请求超时


附录D TUP挂起原因到SIP状态码对应表

TUP返回值 | 取值含义 | SIP状态码 | 取值含义
11 | SS7 signaling: receives SSB message from remote PBX | 486 | 这里忙
12 | SS7 signaling: receives SLB message from remote PBX | 486 | 这里忙
13 | SS7 signaling: receives STB message from remote PBX | 486 | 这里忙
67 | TUP: receives CBK message from remote PBX | 403 | 禁止
21 | SS7 signaling: receives ACB message from remote PBX | 403 | 禁止
18 | SS7 signaling: receives CFL message from remote PBX | 504 | 禁止
14 | SS7 signaling: receives UNN message from remote PBX | 488 | 这里请求不可接受
16 | SS7 signaling: receives CGC message from remote PBX | 406 | 不可接受
17 | SS7 signaling: receives NNC message from remote PBX | 406 | 不可接受
19 | SS7 signaling: receives LOS message from remote PBX | 406 | 不可接受
20 | SS7 signaling: receives SST message from remote PBX | 406 | 不可接受
22 | SS7 signaling: receives DPN message from remote PBX | 406 | 不可接受
23 | SS7 signaling: receives EUM message from remote PBX | 406 | 不可接受
24 | SS7 signaling: receives ADI message from remote PBX | 484 | 地址不完整


附录E CDR使用说明

CDR（A call detail record）即一通完整电话的呼叫记录。光口网关记录一定数量的CDR到内存中，实时将这些信息发给指定的服务器。实现方法：

1、 使用TCP协议，网关作为客户端，配置CDR服务端，网关定时将CDR发送给CDR服务器。

2、 每隔3秒发送记录到CDR服务器。

3、 若与服务器断开连接则每隔30秒重连CDR服务器。

4、 服务中最大存储了2000条CDR记录，超出2000条时删除前100条记录。

5、 CDR的格式示例：

Outgoing example:(ip->pstn)

“2014-12-20 14:55:33.345”, ”2014-12-20 14:57:43.627”, ”1000”, ”5551234”, ”SIP/1000”, “Zap/444”, “”, “”

Incoming example:(pstn->ip)

“2014-12-20 14:55:33.345”, ”2014-12-20 14:57:43.627”, ”5551234”, ”1000”, ”Zap/444”, “SIP/1000”, “1234”, “”

# | Field Name | Format | Description
1 | Start Time | YYYY-MM-DD HH:MM:SS.mmm | Call start timestamp
2 | End Time | YYYY-MM-DD HH:MM:SS.mmm | Call end timestamp
3 | Calling Number (A) |  | Calling Number
4 | Dialed Number (B) |  | Dialed Number
5 | Incoming Call Leg |  | Incoming Call Leg
6 | Outgoing Call Leg |  | Outgoing Call Leg
7 | DNIS |  | DNIS (incoming only)
8 | Queue |  | Queue (incoming only)


附录F 技术/销售支持

您在使用我们产品的过程中，有任何疑问都可以与我们联系，我们将尽心尽力提供服务。

公司联系方法：

杭州三汇信息工程有限公司

http：//www.synway.cn

地址：杭州滨江区南环路3756号三汇研发大楼9F

邮编：310053

电话：0571-88861158（总机）

传真：0571-88850923

微信二维码：请扫描下图二维码添加公司微信订阅号了解更多详情。

技术支持：

电话：0571-88921532（工作日8:30 - 17:00）

手机：（0）13306501675（24小时热线）

Email：support@sanhuid.com

销售部：

电话：0571-86695356

Email：13989830066@139.com