封面

三汇SBO系列网关

SBO2000网关

用户手册

Version 1.7.0

杭 州 三 汇 信 息 工 程 有 限 公 司

www.synway.cn


目 录

目 录... i

版权申明 iii

版本修订记录... iv

第1章 产品介绍... 1

1.1 应用场景图.. 1

1.2 功能列表.. 1

1.3 硬件描述.. 2

1.4 告警信息说明.. 3

第2章 基本使用... 5

第3章 WEB配置... 7

3.1 登录系统.. 7

3.2 运行信息.. 8

3.2.1 系统信息.. 9

3.2.2 IP线路状态.. 11

3.2.3 呼叫监控.. 13

3.2.4 呼叫统计.. 14

3.2.5 告警信息.. 15

3.3 SIP设置.. 15

3.3.1 SIP设置.. 16

3.3.2 SIP中继.. 18

3.3.3 SIP注册.. 21

3.3.4 SIP账户.. 22

3.3.5 SIP中继组.. 24

3.3.6 媒体设置.. 27

3.4 路由设置.. 29

3.4.1 IP to IP路由.. 29

3.5 号码过滤.. 31

3.5.1 白名单.. 32

3.5.2 黑名单.. 34

3.5.3 号码池.. 35

3.5.4 过滤规则.. 37

3.6 号码变换.. 39

3.6.1 IP to IP主叫变换.. 39

3.6.2 IP to IP被叫变换.. 41

3.7 系统工具.. 42

3.7.1 网络设置.. 43

3.7.2 授权管理.. 44

3.7.3 管理参数.. 44

3.7.4 IP路由表.. 45

3.7.5 访问控制.. 47

3.7.6 证书管理.. 48

3.7.7 集中管理.. 49

3.7.8 SIP账号生成工具.. 50

3.7.9 录音管理.. 51

3.7.10 配置文件.. 52

3.7.11 信令抓包.. 53

3.7.12 呼叫测试.. 54

3.7.13 呼叫跟踪.. 55

3.7.14 网络测速.. 56

3.7.15 PING测试.. 57

3.7.16 TRACERT测试.. 58

3.7.17 修改记录.. 59

3.7.18 备份载入.. 59

3.7.19 恢复出厂.. 60

3.7.20 软件升级.. 60

3.7.21 更改口令.. 61

3.7.22 设备锁定.. 61

3.7.23 重启网关.. 62

第4章 典型应用配置案例... 63

附录A 主要技术/性能参数... 66

附录B 常见问题... 67

附录C 技术/销售支持... 68


版权申明

本文档版权属杭州三汇信息工程有限公司所有。

杭州三汇信息工程有限公司保留对此文件进行修改而不另行通知之权利。

杭州三汇信息工程有限公司承诺所提供的信息为正确且可靠，但并不保证本文件绝无错误。

请在使用本产品前，自行确定所使用的相关技术文件及规格为最新有效之版本。若因贵公司使用本公司之文件或产品，而需要第三方之产品、专利或者著作等与其配合时，则应由贵公司负责取得第三方同意及授权。关于上述同意及授权，非属本公司应为保证之责任。


版本修订记录

版本号 | 发布日期 | 修订内容
Version 1.7.0 | 2018.06 | 新创建此文档。

请访问我们的网站（www.synway.cn）以获取该文档的最新版本。


第1章 产品介绍

欢迎使用三汇SBO系列网关产品（以下简称SBO网关）。SBO2000网关用于连接基于IP的电话网络或IP PBX，提供转码、路由、号码过滤、号码变换等功能。


1.1 应用场景图

图 1‑1 SBO网关应用场景图


1.2 功能列表

基本功能

说明

IP呼叫

IP线路呼入，经过路由和号码变换，连接指定的SIP中继进行语音通信

号码变换

删减号码头部或尾部的数字，或者对号码添加前缀或后缀

VoIP路由

用户可以设置路由路径，从IP到IP

信令和协议

说明

SIP信令

兼容的协议：SIP V1.0/2.0、RFC3261

语音

音频编解码格式 | G.711A、G.711U、G.729、G723、G722、AMR-NB、iLBC
DTMF模式 | RFC2833、SIP INFO、INBAND、RFC2833+信令、带内+信令

网络特性

说明

网络协议

TCP/UDP、HTTP、ARP/RARP、DNS、NTP、TFTP、TELNET、STUN

静态IP

IP地址修改

DNS

域名解析

安全性

说明

管理认证

支持管理员认证确保资源和数据的安全性

维护升级

说明

WEB配置

通过WEB界面修改配置

支持语言

中文，英文

软件升级

基于WEB的用户界面、网关服务、内核及固件升级

跟踪测试

基于WEB的Ping测试和Tracert测试

SysLog类型

ERROR、WARNING、INFO


1.3 硬件描述

SBO2000网关采用1U高度标准机架式设计，并在POWERPC+DSP的硬件架构中提供LINUX嵌入式系统。网关机箱支持2个千兆以太网口。产品外观示意图如下：

图 1‑2 SBO2000前面板示意图

图 1‑3 SBO2000后面板示意图

图 1‑4 SBO2000左侧示意图

上图中各接口、按键及指示灯的详细介绍如下：

接口 | 说明
网络接口 | 数量：2个
 | 类型：RJ-45
 | 带宽：10/100/1000 Mbps
 | 自适应带宽：支持
 | 自动翻转：支持
串口 | 数量：1
 | 类型：RS-232
 | 波特率：115200 bps
 | 接口类型：RJ45（信号定义见 错误!未找到引用源。 ）、USB
 | 数据位：8 bits
 | 停止位：1 bit
 | 校验：无
 | 流控：无
按键 | 说明
电源开关 | 开启/关闭SBO网关，两个电源开关同时打开，实现电源主从热备份功能
恢复出厂设置按键 | 将SBO网关恢复到出厂设置状态
指示灯 | 说明
电源指示灯 | 指示电源状态，开机通电后点亮
运行状态灯 | 指示设备运行状态，具体说明见1.4告警信息说明
告警指示灯 | 指示设备异常，告警，具体说明见1.4告警信息说明
Link指示灯 | 网络指示灯中的绿色LED指示灯，用于指示网络连接状态
ACT指示灯 | 网络指示灯中的黄色LED指示灯，该指示灯闪烁表示数据正在传输

对于SBO2000网关，串口通过双公头USB线连接，每个USB口转4个串口，共8个串口。

其它硬件参数请参考附录A 主要技术/性能参数。


1.4 告警信息说明

SBO2000网关提供两个指示设备运行状态的LED指示灯：运行灯与告警灯。运行灯为绿色，告警灯为红色。指示灯的状态及含义说明如下：

指示灯 | 状态 | 含义
运行灯 | 熄灭 | 系统未启动
 | 点亮 | 系统正在启动
 | 闪烁 | 设备正常运行
告警灯 | 熄灭 | 设备无异常
 | 点亮 | 启动时：设备正常 运行中：设备异常
 | 闪烁 | 设备异常

说明：

l 开机过程包括系统启动和网关服务启动两个阶段。系统启动过程大约持续1分钟，系统启动成功后，运行灯与告警灯均点亮。网关服务启动成功，设备正常运行后，运行灯闪烁，告警灯熄灭。

l 运行过程中，告警灯点亮或者闪烁表示设备异常，用户如果无法自行排除故障，请联系我公司的技术人员处理故障，技术支持联系方式见附录C技术/销售支持。


第2章 基本使用

本章节旨在帮助用户于最短的时间内掌握SBO网关产品的基本使用方法。

第一步：确认产品包装盒内包含以下物品。

l SBO2000网关机箱1台

l 脚垫6个、挂耳螺丝8颗、前角板2个、后角板2个、接地线1根、直通屏蔽网线2根

l 220V电源线2根

l 保修卡1份

l 安装手册1份

第二步：固定SBO网关机箱。

如果不需要安放到机架上，先安装脚垫；如果需要安放到机架上，先将前角板安装到机箱上，再配合后角板将机箱安装到机架上。

第三步：连接机箱电源。

在连接机箱电源之前，务必确认可靠接地。先查看电源插座是否有接地线；如果没有，可以通过机箱后侧的接地螺柱（如 错误!未找到引用源。 所示）接地。

注：每个SBO网关有两个电源接口，满足电源主从热备份功能需求。正确连接并开启两个电源后，当一个电源出现故障时，另外一个电源也能保证网关的正常工作。

第四步：接入网线。

第五步：登录网关。

通过浏览器输入SBO网关的初始IP地址（LAN1初始IP地址：192.168.1.101；LAN2初始IP地址：192.168.0.101），进入SBO网关。具体登录方法见3.1登录系统，SBO网关的初始用户名为admin，初始密码为admin。用户在初次登录后，应尽快通过“系统工具 à 更改口令”界面修改初始用户名及密码。用户名、密码修改方法见3.7.21更改口令。用户名及密码修改后，需要重新登录。

第六步：修改网关的IP地址。

通过“系统工具 à 网络设置”界面修改IP，使之融入公司的局域网中。IP地址的修改方法见 3.7.1网络设置 。IP地址修改后，需要使用新设置的IP地址重新登录。

第七步：检查通道状态。

完成信令配置后，用户可以通过“运行信息 à IP线路状态”界面检查通道状态，通道各状态的具体说明见3.2.2 IP线路状态。

第八步：设置呼叫路由。

说明：为方便用户理解及操作，此步骤的所有示例均不涉及注册操作。

1. 在配置中添加与网关进行通信的SIP终端IP地址，此IP范围以外的终端呼入网关，网关不会响应。操作方法见“SIP设置 à SIP中继”。点击添加 SIP中继，进行添加，设置界面中的“远端地址”和“远端端口”分别填写呼入的SIP终端的IP地址和端口，其余选项均可采用默认值。
举例：假设呼入的SIP中继地址为192.168.0.111，端口为5060。新增 SIP中继0，填写远端地址为 192.168.0.111，远端端口为 5060；呼出的SIP中继地址为192.168.0.222，端口为5060。新增 SIP中继1，填写远端地址为 192.168.0.222，远端端口为 5060。

2. 将第1步中添加的SIP中继加入到对应的SIP中继组。操作方法见“SIP设置 à SIP中继组”，点击添加 SIP中继组，进行添加。设置界面中的“选择SIP中继”需要选择第1步中设置的SIP中继，其余选项可以采用默认值。
举例：新增 SIP中继组0，选择 SIP中继勾选 0，其余配置项不修改，采用默认值；新增 SIP中继组1，选择 SIP中继勾选 1，其余配置不修改，采用默认值。

3. 添加呼叫路由。使用第2步中设置的SIP中继组[0]作为呼叫来源，SIP中继组[1]作为呼叫目的。操作方法见“路由设置 à IPàIP路由”，点击添加路由规则，进行添加。设置界面中的“呼叫来源”和“呼叫目的”需要进行相应选择，其余选项可以采用默认值。
举例：呼叫来源选择 SIP中继组[0]，呼叫目的选择 SIP中继组[1]，其余配置项不修改，采用默认值。

4. 使用第1步中配置的SIP中继0呼叫SBO网关的IP地址和端口，就可以通过路由规则转呼到SIP中继1，与IP终端进行语音通信了。（注意：SIP中继呼叫IP地址的方式为：username@IP地址）
举例：假设SBO网关的IP地址为192.168.0.101，端口为5060；123是一个符合对端设备收号规则的号码。SIP中继0呼叫SBO网关的IP地址192.168.0.101（呼叫方式为123@192.168.0.101），就可以通过SBO网关的路由规则外呼到SIP中继1，和对方进行语音通信了。

特别注意：

l 按照电信设备使用的常规要求，SBO网关必须可靠接地（通过电源的第三只脚连接地线，或者使用机箱上的接地螺柱接地），否则可能出现工作不稳定且抗雷击能力降低等情况。

l SBO网关工作时会产生热量，切勿阻挡机箱两侧的散热孔（如 错误!未找到引用源。 、 图 1‑4 所示），以免发生意外。

l 发现SBO网关运行时告警灯亮或者闪烁，用户如果无法自行排除故障，应及时联系我公司的技术人员分析告警类型，并进行相应处理，否则可能会出现性能下降或发生意外错误的情况。


第3章 WEB配置


3.1 登录系统

在浏览器地址栏输入网关的IP地址，进入登录界面，如 图 3‑1 所示：

图 3‑1登录界面

网关只有一个用户，初始用户名为admin，初始密码为admin。登录后，用户名和密码都可以修改，具体修改方法见 3.7.21 更改口令 。

用户登录后，界面显示如下：

图 3‑2登陆后的主界面


3.2 运行信息

运行信息显示了网关当前的工作状态，包括系统信息、IP线路状态、呼叫统计和告警信息四个部分，如 图 3‑3 所示，详细介绍如下：

图 3‑3 运行信息功能列表


3.2.1 系统信息

图 3‑4系统信息界面

系统信息界面如 图 3‑4 所示，点击刷新 可以获取最新的系统信息。以上各信息项的说明如下：

信息项 | 说明
MAC地址 | 业务网口1或业务网口2的MAC地址。
IP地址 | 从左到右依次为业务网口1或业务网口2的IP地址、子网掩码、默认网关。
IPV6地址 | IPV6地址。
DNS服务器 | 业务网口1或业务网口2的DNS服务器地址。
接收数据包、发送数据包 | 网关启用后的接收/发送数据包数量，包括总包数、错包数和丢包数。
当前速率 | 显示网络当前发送和接收的速率。
工作模式 | 显示网络的工作模式，包括10 Mbps半双工、10 Mbps全双工、100 Mbps半双工、100 Mbps全双工、1000 Mbps全双工和断线六种。
网络类型 | 网络类型，包括静态、DHCP和PPPoE。
运行时间 | 网关服务启动后，设备正常工作的时长。运行时间每2s更新一次。
CPU温度 | 显示当前CPU的实时温度，第一个为Master的温度，后面4个为Slaver的温度。
CPU占用率 | 显示当前CPU的占用率。
当前RTP报文数据 | 显示当前RTP报文数据的发送和接收信息。
设备云工作状态 | 显示网关与集中管理服务端的连接状态。
录音工作状态 | 显示网关对接的录音服务器的工作状态。
序列号 | 每台SBO网关唯一的序列号。
WEB | 当前使用的WEB界面版本。
网关服务 | 当前使用的网关服务版本。
Uboot | 当前使用的Uboot版本。
内核 | 网关上运行的系统内核版本号。
固件 | 网关上运行的固件版本信息。


3.2.2 IP线路状态

图 3‑5 IP线路状态界面

IP线路状态界面如 图 3‑5 、该界面显示了网关上每个IP通道的状态，以上各信息项的说明如下：

信息项

说明

通道编号

IP通道在物理设备上的对应序号。

通道状态

显示通道的实时状态。将鼠标移至通道状态图标上方可以查看具体的通道状态说明和呼叫相关信息，如：呼叫方向，主、被叫号码信息。通道状态包括：

通道状态 | 图标 | 说明
空闲 |  | 通道可用。
回铃 |  | 等待对方应答，收到来自对端的回铃音。
振铃 |  | 通道处于振铃状态。
通话 |  | 通道处于通话状态。
挂起 |  | 通道处于挂起状态。
拨号中 |  | 通道正在拨号。
等待消息 |  | 等待对端消息。

注：该界面提供了模糊查找通话的功能，用户只需鼠标点击 图 3‑5 ，界面上的任意文字部分，然后按“F”键，即可出现查找框，输入关键字后，网关可定位到正在通话的符合模糊查询条件的电话发生在哪个通道上。

举例说明：如下 图 3‑6 所示，查找栏输入100，网关根据此关键字，模糊查找并定位到被叫号码包含100的通话发生在通道组1的通道6上。

图 3‑6 查找通话


3.2.3 呼叫监控

图 3‑7 呼叫监控界面

呼叫监控界面如 图 3‑7 所示，在监控条件栏设置监控条件，可对满足条件的呼叫进行监控。

信息项 | 说明
监控主叫号码、监控被 叫号码、监控远端地址 | 设置通话监控条件，可以根据主叫号码、被叫号码和远端地址对通话进行监控。
监听网口选择 | 设置对通话进行监听的网口。
通道组号 | 通道组的编号，编号从0开始。
通道编号 | IP通道在物理设备上的对应序号。
呼叫方向 | 显示被监控呼叫的呼叫方向，包含IPà PSTN和PSTNàIP两种。
通道状态 | 显示被监控呼叫所在通道的状态。
主叫号码 | 显示被监控呼叫的主叫号码。
被叫号码 | 显示被监控呼叫的被叫号码。
开始时间 | 显示被监控呼叫的开始时间。
持续时间 | 显示被监控呼叫的持续时间。


3.2.4 呼叫统计

图 3‑8 呼叫统计界面

呼叫统计界面如 图 3‑8 所示，该界面记录了从网关开机到最近一次打开或刷新此界面这个时间段内所有呼叫的具体信息。点击重置统计 可以重新统计呼叫信息，点击下载 可以下载呼叫统计日志。以上各信息项的说明如下：

信息项 | 说明
SIP中继 | SIP中继的地址，即与网关通信的对方SIP设备的IP地址或域名。
描述 | 标识每个SIP中继组的信息，方便查看。
当前IP呼入数 | 当前IP呼入的呼叫数量。
接通IP呼入数 | 从IP呼入的呼叫接通的数量。
总IP呼入数 | 从IP呼入的总呼叫数量。
IP呼入接通率 | 从IP呼入的且双方成功进入通话的呼叫数量占各自发起的总呼叫数量的百分比。
当前IP呼出数 | 当前从IP呼出的呼叫数量。
接通IP呼出数 | 从IP呼出的呼叫接通的数量。
总IP呼出数 | 从IP呼出的总呼叫数量。
IP呼出接通率 | 从IP呼出发起的且双方成功进入通话的呼叫数量占各自发起的总呼叫数量的百分比。
平均通话时长 | 所有接通呼叫的平均通话时间。
CPS | 每秒新呼叫的数量。
释放原因 | 呼叫的释放原因。
正常拆线 | 正常结束通话的呼叫。
主叫取消 | 呼叫的主叫方取消呼叫。
用户忙 | 被叫端被占用、直接回复忙消息的呼叫。
无应答 | 由于被叫长时间不摘机或主叫在被叫没有摘机的情况下挂机导致失败的呼叫。
路由失败 | 由于呼叫找不到匹配的路由规则导致失败的呼叫。
无空闲资源 | 由于找不到空闲的语音资源导致失败的呼叫。
呼叫失败 | 由于被叫号码不符合收号规则等原因导致网关外呼失败的数量。
其他 | 由于其他原因导致呼叫失败的呼叫数量。
个数 | 统计处于各个通道状态的数量。
百分比 | 不同释放原因的呼叫数量占总呼叫数量的百分比。


3.2.5 告警信息

图 3‑9 告警日志界面

告警信息界面如 图 3‑9 所示，网关上出现的所有告警信息都会输出并在该界面显示。


3.3 SIP设置

SIP设置包括 SIP设置、SIP中继、SIP注册、SIP账户、SIP中继组和媒体设置六个部分，如 图 3‑10 所示。SIP设置用于设置SIP通用信息；SIP中继用于设置SIP中继的基本信息和注册信息；SIP注册用于设置SIP的注册情况；SIP账户用于将SIP账户注册到对应的SIP服务器；SIP中继组用于分组管理SIP中继；媒体设置用于设置RTP端口和负载类型。

图 3‑10 SIP设置功能列表


3.3.1 SIP设置

图 3‑11 SIP通用设置界面

SIP设置界面如 图 3‑11 所示，用户可以通过该界面设置SIP通用信息。配置完成后，点击保存 将以上设置存入网关，如果保存后弹出页面提示“重启服务后生效”，需要重启网关服务，操作方法见3.7.23重启网关。点击重置 可恢复当前配置。界面中的各配置项说明如下：

配置项 | 说明
WAN口选择 | SIP信令的IP地址，默认使用网口1。
SIP信令端口 | SIP信令用于监听的端口，取值范围为5001~65535，默认值为5060。 注：不能与媒体设置里RTP端口范围有重叠。
SIP TLS信令端口 | TLS信令端口，端口范围2000~65535，默认5061。
发送100rel | 设置是否发送100rel字段，默认为不发送。
主叫隐藏 | 设置是否隐藏主叫号码，默认值为不隐藏。
获取主叫ID方式 | 获取主叫号码的方式，包括 From字段的username 和 From字段的displayname 两个选项，默认值为 From字段的username。
获取/发送被叫ID方式 | 获取和发送被叫号码的方式，包括从 To字段 和从 Request字段 两个选项，默认值为从 Request字段 获取。
Asserted Identity模式 | 设置是否在invite消息里将带上某些头信息，目前包含P-Asserted-Identity和P-Preferred-Identity两个字段，默认值为关闭。
From字段号码不变换 | 该功能启用后，From字段里的主叫将不进行变换，默认值为关闭。 注：仅当配置项Asserted Identity模式启用时，该配置有效。
Prack发送模式 | 收到的180/183带了100rel字段后是否回复prack消息，可以选择Supported和Require方式，默认不发送。
NAT穿透、穿透类型 | 设置是否开启NAT穿透，默认值为不开启。穿透类型仅包括端口映射。默认为不启用。
网口1映射地址、网口2映射地址 | NAT穿透启用后，网口1和网口2分别对应的映射地址。实现端口映射同时还需要路由器的配合。此处填写路由器设置的映射地址和端口。
网口1 映射地址(RTP)、网口2映射地址(RTP) | NAT穿透启用后，网口1和网口2分别对应的RTP映射地址。
始终使用映射地址 | 该功能启用后，将强制使用上面的映射地址进行呼叫，默认为不启用。
SIP加密 | 启用SIP加密功能可以对SIP信令进行加密，默认为关闭。加密时需要选择加密规范和密钥。
加密规范 | 对SIP信令进行加密的加密规范，目前只支持VOS1.1。
密钥 | 对SIP信令进行加密的密钥。
RTP加密 | 该功能启用后，可以对RTP进行加密，默认为关闭。
RTP自适应 | 该功能启用后，当远端发送的信令消息中携带的RTP接收地址或端口与实际情况不符时，自动更新其为实际的RTP接收地址或端口，提高网关RTP发送的自适应能力。默认为不启用。
开启UDP头校验 | 该功能启用后，网关在发送RTP时会自动计算UDP头校验码。
开启Rport | 该功能开启后，将在SIP信令的Via字段中增加对应的Rport字段。默认为不启用。
开启来源地址回复 | 该功能启用后，网关将使用invite消息里面的源地址回复，默认为不启用。
主叫并发限制 | 限制相同主叫号码的呼叫次数，超过次数后回复503。
并发数 | 设置相同主叫号码的呼叫次数。
SIP账号注册间隔 | 多个SIP账号注册的间隔，范围0~10000，默认0。
启用DSCP | 启用DSCP差异化服务编码点功能。默认值为不启用。
语音媒体 | 设置DSCP中语音媒体的优先级。取值范围为0～63，默认值为 46。取值越大，优先级越高。
信令控制 | 设置DSCP中信令控制的优先级。取值范围为0～63，默认值为 26。取值越大，优先级越高。
仅允许SIP中继地址呼入 | 此功能开启后，网关仅接收SIP设置àSIP中继里配置的IP地址过来的呼叫。默认为不启用。
通话超时挂机设置 | 设置是否开启通话超时时挂机的功能。默认为不启用。
最大超时时间 | 设置通话的最大超时时间，单位为分钟。
工作时间段、时间段 | 设置整个网关的工作时间段，可以设置在指定时间段内才能进行呼叫。默认为 24小时 都可以呼叫。
会话定时器 | 设置是否开启会话刷新功能，默认值为不启用。该功能启用后，需输入定时器最小时间和定时器超时时间。
定时器最小时间 | 设置会话刷新的最小时间。取值范围为90～65535，默认值为 150.
定时器超时时间 | 设置会话刷新的超时时间。取值不能小于定时器最小时间，默认值为 600.
启用中继心跳 | 设置是否定期向SIP中继发送option消息，未收到MGCF中继的回复超过一定次数则路由至该中继的呼叫直接拒绝。
中继心跳周期 | 设置向SIP中继发送option消息的周期。
允许未响应次数 | 设置允许SIP中继未回复option消息的次数。
SIP回复值 | 未收到MGCF中继的回复超过一定次数则路由至该中继的呼叫直接拒绝，可设置SIP回复值，默认502。
启用早期媒体 | 该功能启用后，Inivite消息会加上P-Early-Media字段，默认值为不启用。
启用早期会话 | 该功能启用后，Inivite消息会加上early-session字段，默认值为不启用。
发送200OK后不等待 ACK | 该功能启用后，网关发送200OK消息以后不需要等待ACK消息，默认值为不启用。
注册消息发送周期占 有效期百分比 | 设置实际发送SIP注册消息的周期时间占SIP注册消息有效期的百分比，取值范围为1~200，默认值为70。
等待对方应答时间 | SIP通道外呼时等待被叫应答的时间。如果对方在指定时间内没有应答，则通道自动取消此次呼叫。默认值为60，单位为秒。
RTP超时挂机时长 | 通道等待RTP包的时间。如果在指定的时间内没有收到RTP包，则通道会自动进入挂起状态，终止本次呼叫。默认值为0，单位为秒。
INVITE消息To字段添 加内容 | 该功能启用后，INVITE消息的TO字段中将添加user=phone。默认为不启用。
添加内容 | 自定义设置TO字段添加的内容。
自定义UserAgent字段 | 自定义设置UserAgent字段内容，目前只支持英文的大小写字母。


3.3.2 SIP中继

网关默认没有SIP中继信息，点击添加 SIP中继 进行添加，如 图 3‑12 所示。用户可以通过该界面添加SIP中继相关信息。

图 3‑12 SIP中继添加界面

以上界面中各配置项的说明如下：

配置项

说明

索引

SIP中继的索引，具有唯一性。

描述

标识每个SIP中继组的信息，方便查看。

远端地址

SIP中继的地址，即与网关通信的对方SIP设备的IP地址或域名。

远端端口

SIP中继的信令端口。

本端网口

SIP中继所在的网口。

编解码优先级

SIP中继建立语音通话时适用的编解码格式及优先级。各子配置项具体说明如下：

子配置项 | 说明
优先级 | 在SIP通信中选用编解码格式的先后顺序，数值越小优先级越高。
编解码 | 编解码格式类型，取值范围包括 G711A、G711U、G729、G723、G722、AMR-NB、iLBC。

每种编解码格式的详细参数参见3.3.6媒体设置中的编解码设置说明。

新增SIP中继默认编解码格式为3.3.6媒体设置中的编解码设置。

呼出语音资源

网关分配给SIP中继的最大资源数。

呼入语音资源

SIP中继分配给网关的最大呼入资源数。

工作时间段、时间段

设置该SIP中继的工作时间段，可以设置在指定时间段内才能进行呼叫。默认为 24小时 都可以呼叫。

启用外部代理

是否启用代理，启用后SIP消息往代理地址发送。

外部代理地址

代理地址。

外部代理端口

代理端口。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。

图 3‑13 SIP中继列表

点击 图 3‑13 中的修改 可以对已经配置的SIP中继进行修改，修改界面如 图 3‑14 所示。修改界面各配置项的意义与 SIP中继添加 界面的对应配置项相同。

图 3‑14 SIP中继修改界面

如果需要删除SIP中继，可以在 图 3‑13 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空 SIP中继 用于一键清除所有SIP中继。

注：若没有配置SIP中继，则后面的SIP注册和SIP中继组等都不可用。


3.3.3 SIP注册

网关默认没有SIP注册信息，点击添加SIP注册 进行添加，如 图 3‑15 所示。用户可以通过该界面添加SIP注册相关信息。

图 3‑15 SIP注册添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
索引 | SIP注册的索引，具有唯一性。
SIP中继编号 | 设置哪个SIP中继注册到SIP服务器。
用户名 | 通过网关向SIP线路发起呼叫时，该号码对应于SIP的username；通过网关向PSTN外呼时，该号码对应于显示的主叫号码。
密码 | 网关注册到SIP服务器上时所使用的密码，发起注册时必须同时填写用户名 与密码 。
注册地址 | SIP中继对外注册的SIP服务器地址。
注册端口 | SIP中继对外注册的SIP服务器的信令端口。
注册域名 | 网关用于对外注册的注册服务器域名。
注册有效期 | SIP注册的注册周期，每间隔该时间段重新发起注册。取值范围为10~3600，单位为秒，默认值为3600。
认证用户名 | 注册时的认证用户名。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。

图 3‑16 SIP注册信息列表

点击 图 3‑16 中的修改 可以对已经配置的SIP注册信息进行修改，修改界面如 图 3‑17 所示。修改界面各配置项的意义与SIP注册添加 界面的对应配置项相同。

图 3‑17 SIP注册修改界面

如果需要删除SIP注册，可以在 图 3‑16 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空SIP注册信息 用于一键清除所有SIP注册信息。

注：若没有配置SIP注册，则后面的SIP账户不可用。


3.3.4 SIP账户

网关默认没有SIP账户信息，点击添加 SIP账户 进行添加，如 图 3‑18 所示。用户可以通过该界面添加SIP账户相关信息。

图 3‑18 SIP账户添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
索引 | SIP账户的索引，具有唯一性。
SIP中继编号 | 设置SIP账户注册到哪个SIP中继。
用户名 | SIP账户注册到SIP中继的用户名。SIP账户注册成功后，服务器可以通过用户名 呼叫网关。
密码 | SIP账户注册到SIP中继上时所使用的密码，发起注册时必须同时填写用户名 与密码 。
注册有效期 | SIP账户注册的周期，每间隔该时间段重新发起注册。取值范围为10~3600，单位为秒，默认值为3600。
注册状态 | 显示SIP账户注册的情况，包括已注册 或注册失败。
认证用户名 | 启用IMS网络时，该端口注册到SIP服务器上时所使用的认证用户名。 注：此配置只有在该SIP账户所对应的SIP中继启用了IMS网络的情况下才会出现。
描述 | 标识每个SIP账户的信息，方便查看。

配置完成后，点击保存 将以上设置存入网关；点击关闭 可直接取消设置。

图 3‑19 SIP账户列表

点击 图 3‑19 中的修改 可以对已经配置的SIP账户进行修改，修改界面如 图 3‑20 所示。修改界面各配置项的意义与 SIP账户添加 界面的对应配置项相同。

图 3‑20 SIP账户修改界面

如果需要删除SIP账户，可以在 图 3‑19 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空 SIP账户 用于一键清除所有SIP账户。


3.3.5 SIP中继组

网关默认没有SIP中继组信息，点击添加 SIP中继组 进行添加，如 图 3‑21 所示。用户可以通过该界面添加SIP中继组相关信息。

图 3‑21 SIP中继组添加界面

以上界面中各配置项的说明如下：

配置项

说明

索引

每个SIP中继组的唯一标识，用于在配置路由规则和号码变换规则时对应需要配置的SIP中继组。

描述

标识每个SIP中继组的信息，方便查看。

中继选择方式

当SIP中继组收到呼叫时，会以指定的中继选择方式，选择合适的SIP中继进入振铃。包括递增 、递减 、循环递增 、循环递减 四个可选项，具体说明如下：

可选项 | 说明
递 | 每次从序号最小的SIP中继开始，按升序查找有空闲资源的SIP中继。
递减 | 每次从序号最大的SIP中继开始，按降序查找 空闲资源的SIP中继。
循环递增 | 记录之前查找到的SIP中继，从序号为记录SIP中继+1的SIP中继开始，按升序查找有空闲资源的SIP中继。
循环递减 | 记录之前查找到的SIP中继，从序号为记录SIP中继-1的SIP中继开始，按降序查找有空闲资源的SIP中继。

IPàIP禁止呼出

设置是否禁止从IP到IP的呼叫，默认值为否，若选择是，需要输入被叫禁呼规则或主叫禁呼规则。具体禁呼规则请查看页面下方的批注。

选择SIP中继

SIP中继组中包含的SIP中继，SIP中继前的复选框呈灰色表示该SIP中继已被占用，不能选择。选中的SIP中继在 图 3‑22 的列表中显示为包含中继。

配置完成后，点击保存 将以上设置存入网关；点击取消 可直接取消设置。

图 3‑22 SIP中继组列表

点击 图 3‑22 中的修改 可以对已经配置的SIP中继组进行修改，修改界面如 图 3‑23 所示。修改界面各配置项的意义与 SIP中继组添加 界面的对应配置项相同。

图 3‑23 SIP中继组修改界面

如果需要删除SIP中继组，可以在 图 3‑22 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空 SIP中继组 用于一键清除所有SIP中继组。


3.3.6 媒体设置

图 3‑24 媒体设置界面

媒体设置界面如 图 3‑24 所示，用户可以根据实际需求对RTP端口和负载类型进行配置。配置完成后，点击保存 将以上设置存入网关，如果保存后弹出页面提示“重启服务后生效”，需要重启网关服务，操作方法见 3.7.23重启网关 。点击重置 可恢复当前配置。界面中各配置项的说明如下：

配置项

说明

发送DTMF方式

IP端发送DTMF的方式，取值范围包括 RFC2833、信令、带内、RFC2833+信令、带内+信令五种方式，默认采用 RFC2833。

RFC2833负载值

RFC2833形式的DTMF在IP线路上采用的负载值，取值范围为90~127，默认值为101。

RTP端口范围

IP端建立语音通话时网关端RTP适用的端口范围，默认值为6000-30000，取值范围的下限为5000，上限为60000，且端口范围差值不能小于16384。

注：不能与SIP信令端口有重叠。

静音抑制

设置当IP通话过程中没有语音时，是否用柔和静音包代替RTP包或者不发送RTP包，以减少带宽的占用。默认值为禁用。

注：当编解码选择G723时，该配置会自动修改为启用。

自动降噪

启用噪音抑制功能，可以自动降低线路上的噪音音量。默认值为开启。

JitterMode

设置JitterMode的工作模式，包括静态模式 和自适应模式 两种模式，默认采用静态模式。

JitterBuffer

对IP线路上语音包的缓冲处理能力。缓冲越大，对网络上语音包抖动的适应能力越强，但同时语音延迟也会适当变大；反之则对语音包的抖动处理能力变弱，但语音延迟变小。取值范围为0~280，单位为毫秒，表示能够接受网络上多少时间范围内的数据包抖动，默认值为 100。

JitterUnderrunLead

设置当接收的语音包晚于JitterBuffer设定值时，已接收语音包的初始延迟。取值范围为0~280，单位为毫秒，默认值为 100。

注：只有当JitterMode配置为静态模式 时，用户才可以看到该配置项。

JitterOverrunLead

设置当接收的语音包早于300-JitterBuffer设定值时，插入的提前时间。取值范围为0~280，单位为毫秒，默认值为 50。

注：只有当JitterMode配置为静态模式 时，用户才可以看到该配置项。

JitterMin

设置自适应jitter功能可以设定的最小延时，必须小于JitterBuffer设定值。取值范围为0~280，单位为毫秒，默认值为 80。

注：只有当JitterMode配置为自适应模式 时，用户才可以看到该配置项。

JitterDecreaseRatio

设置自适应模式下，减小延时的速率，定义了减少延时可以删除的静音的最大百分比。取值范围为0~100，默认值为 50。

注：只有当JitterMode配置为自适应模式 时，用户才可以看到该配置项。

JitterIncreaseMax

设置一个静音周期内增大的最大延时。取值范围为0~280，单位为毫秒，默认值为 30。

注：只有当JitterMode配置为自适应模式 时，用户才可以看到该配置项。

IP侧输出增益

网关向IP侧发送的语音增益大小，取值大小必须为3的倍数，取值范围为-24～24，单位为分贝，默认值为 0。

编解码设置

IP端建立语音通话时适用的编解码设置。各子配置项具体说明如下：

子配置项 | 说明
网关协商编码顺序 | 设置编解码优先级顺序，包括默认优先级 和自定义优先级 两种，缺省值是默认优先级。
优先级 | 在SIP通信中选用编解码格式的先后顺序，数值越小优先级越高。
编解码 | 编解码格式类型，取值范围包括G711A、G711U、G729、G723、G722、AMR-NB、iLBC。
打包时长 | RTP包的打包间隔，单位为毫秒。
比特率 | 该编解码格式在净荷情况下每秒钟需要传输多少个千比特。

默认七种编解码格式同时适用，且优先级从高到低分别为G711A、G711U、G729、G723、G722、AMR-NB、iLBC，此处设置编解码为新增SIP中继的默认编解码格式。

不同编解码格式支持的打包时长和比特率如下表所示，图中字体加粗的取值为该编解码的默认值。

编解码 | 打包时长（ms） | 比特率（kbps）
G711A | 5 / 10 / 20 / 30 / 40 / 50 / 60 | 64
G711U | 5 / 10 / 20 / 30 / 40 / 50 / 60 | 64
G729 | 10 / 20 / 30 / 40 / 50 / 60 | 8
G723 | 30 / 60 | 5.3 / 6.3
G722 | 5 / 10 / 20 / 30 / 40 | 64
AMR | 20 / 40 / 60 | 4.75 / 5.15 / 5.90 / 6.70 / 7.40 / 7.95 / 10.20 / 12.20
iLBC | 20 / 30/ 40/ 60 | 15.2


3.4 路由设置

路由设置用于规定IP à IP呼叫的路由选择方式，如 图 3‑25 所示。

图 3‑25 路由设置功能列表


3.4.1 IP to IP路由

网关默认没有IPàIP路由规则，点击添加路由规则 添加，见 图 3‑26 。用户可以通过该界面添加路由规则相关信息。

图 3‑26 IPàIP路由规则添加界面

以上界面中各配置项的说明如下：

配置项

说明

索引

路由规则的索引，具有唯一性，并且规定了路由规则的优先级，该配置项的值越小优先级越高。用于当一通呼叫同时匹配多条路由规则时，选用优先级最高的路由规则来处理。

呼叫来源

表示呼叫来自于哪个SIP中继组。此配置项可以选择具体的SIP中继组，也可以选择SIP中继组[ANY]来表示任意SIP中继组。

主叫前缀、被叫前缀

主被叫号码开头的字符串，可以用“*”来代表任意字符串。此配置项与呼叫来源 一起规定了适用这条规则的呼叫。

规则说明：

字符 | 含义
“0”~”9” | 数字0～9。
“[ ]” | 表示一个数字，该数字是前后用一对”[”、”]”括起来的范围内的任意值，“[ ]”内的值只支持数字“0”~”9”、“-”和“,”。 举例：[1-3,6,8]表示集合1、2、3、6、8内的任意一个数字。
“-” | 两个数字之间用“-”相隔，表示该区间之内的任何数字。“-”只能出现在“[ ]”中。
“,” | 两个数字或数字区间之间用“,”相隔，表示两者之间为选择关系。“,”只能出现在“[ ]”中。

举例：规则“0[0-3,7][6-9]”表示前缀为006、016、026、036、007、017、027、037、008、018、028、038、009、019、029、039、076、077、078、079。

注：主、被叫号码前缀支持多个规则，不同规则间用“:”分开。

呼叫目的

指定这条路由规则最终路由的目的SIP中继组。

号码过滤

指定这条路由适用的号码过滤规则。具体过滤规则在号码过滤 里设置，见3.5.4过滤规则。

描述

用于标识路由规则，方便查看。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

图 3‑27 IPàIP路由规则列表

点击 图 3‑27 中的修改 可以对已经配置的路由规则进行修改，修改界面如 图 3‑28 所示。修改界面各配置项的意义与路由规则添加 界面的对应配置项相同。修改界面不允许修改索引。

图 3‑28 IPàIP路由规则修改界面

如果需要删除路由规则，可以在 图 3‑27 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空路由 可以一键清除所有路由规则。


3.5 号码过滤

号码过滤界面如 图 3‑29 所示，包括白名单、黑名单、号码池和过滤规则四个部分。

图 3‑29 号码过滤界面


3.5.1 白名单

图 3‑30 白名单设置界面

白名单设置界面如 图 3‑30 所示，包括主叫白名单和被叫白名单两部分。可以通过点击列表右下角的添加 添加主/被叫白名单，见 图 3‑31 、 图 3‑32 。

图 3‑31 主叫白名单号码添加界面

图 3‑32 被叫白名单号码添加界面

以上界面中各配置项的说明如下：

配置项

说明

组号

主/被叫白名单所对应的小组编号。编号范围：0～7。

组内编号

相同组号内不同的主/被叫白名单所对应的编号。

主叫号码

主叫的白名单号码，不能为空。填写规则说明：

字符 | 含义
“*” | 代表任意字符串。
“0”~”9” | 数字0～9。
“x” | 代表一个任意数字；多个x表示多个任意数字，如：xxx表示3个任意数字。
“[ ]” | 表示一个数字，该数字是前后用一对”[”、”]”括起来的范围内的任意值，“[ ]”内的值只支持数字“0”~”9”、“-”和“,”。 举例：[1-3,6,8]表示集合1、2、3、6、8内的任意一个数字。
“-” | 两个数字之间用“-”相隔，表示该区间之内的任何数字。“-”只能出现在“[ ]”中。
“,” | 两个数字或数字区间之间用“,”相隔，表示两者之间为选择关系。“,”只能出现在“[ ]”中。

被叫号码

被叫的白名单号码，不能为空。填写规则见上面主叫号码。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑30 中的修改 可以对已经配置的主/被叫白名单进行修改，修改界面如 图 3‑33 、 图 3‑34 所示。修改界面各配置项的意义与主/被叫白名单添加 界面的对应配置项相同。修改界面不允许修改组号。

图 3‑33 主叫白名单号码修改界面

图 3‑34被叫白名单号码修改界面

使用主/被叫白名单列表最上方的主/被叫白名单查询搜索框来查询特定的主被叫号码。

主/被叫白名单列表下方的删除所选 用于删除选中的主/被叫白名单；清空 用于一键清除所有主/被叫白名单。

注：当白名单设置的主、被叫号码和黑名单设置的号码重复时，则该条白名单设置无效，即黑名单具有较高优先级。黑、白名单总数不能超过5000条。


3.5.2 黑名单

图 3‑35 黑名单设置界面

黑名单的设置方式和白名单的一样，只是主被叫号码由白名单变成了黑名单。黑名单设置界面如 图 3‑35 所示，界面中各配置项的意义及配置方法与主/被叫白名单 界面的对应配置项功能一样，只是设置的主/被叫号码由白名单变成黑名单。

注：黑名单比白名单的优先级要高。如果黑名单和白名单有相同的号码时，优先执行黑名单里的号码。


3.5.3 号码池

图 3‑36号码池设置界面

号码池设置界面如 图 3‑36 所示，可以通过点击列表右下角的添加 添加号码池，见 图 3‑37 。

图 3‑37号码池添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
组号 | 号码池所对应的组编号。编号范围：0～15。
组内编号 | 相同组号内的不同的号码池所对应的编号。一组最多设置100个号码池号码。
号码范围 | 一个号码池中开始和结束的号码范围，不能为空。只能填入数字。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑36 中的修改 可以对已经配置的号码池进行修改，修改界面如 图 3‑38 所示。修改界面各配置项的意义与号码池添加 界面的对应配置项相同。修改界面不允许修改组号。

图 3‑38 主叫号码池修改界面

号码池列表下方的删除所选 用于删除选中的号码；清空 用于一键清除所有号码池。


3.5.4 过滤规则

图 3‑39 过滤规则设置界面

过滤规则设置界面如 图 3‑39 所示，可以通过点击列表右下角的添加 添加过滤规则，见 图 3‑40 。

图 3‑40 过滤规则添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
编号 | 过滤规则所对应的编号。编号范围：0～99。
主叫白名单 | 在主叫白名单界面设置保存的主叫白名单组号。
被叫白名单 | 在被叫白名单界面设置保存的主叫白名单组号。
主叫黑名单 | 在主叫黑名单界面设置保存的主叫黑名单组号。
被叫黑名单 | 在被叫黑名单界面设置保存的被叫黑名单组号。
白名单主叫号码池 | 选择号码池中作为白名单主叫号码池的组号。
黑名单主叫号码池 | 选择号码池中作为黑名单主叫号码池的组号。
白名单被叫号码池 | 选择号码池中作为白名单被叫号码池的组号。
黑名单被叫号码池 | 选择号码池中作为黑名单被叫号码池的组号。
白名单原被叫号码池 | 选择号码池中作为白名单原被叫号码池的组号。
黑名单原被叫号码池 | 选择号码池中作为黑名单原被叫号码池的组号。
描述 | 过滤规则的备注，可以填写任意信息，但不能为空。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

点击 图 3‑39 中的修改 可以对已经配置的过滤规则进行修改，修改界面如 图 3‑41 所示。修改界面各配置项的意义与过滤规则添加 界面的对应配置项相同。修改界面不允许修改编号。

图 3‑41 过滤规则修改界面

过滤规则列表下方的删除所选 用于删除选中的过滤规则；清空 用于一键清除所有过滤规则。


3.6 号码变换

号码变换包括 IPàIP主叫变换、IPàIP被叫变换两个部分，如 图 3‑42 所示。

图 3‑42 号码变换功能列表


3.6.1 IP to IP主叫变换

网关默认没有IPàIP主叫变换，点击添加变换规则 进行添加。如 图 3‑43 所示。用户可以通过该界面添加IPàIP主叫号码变换相关信息。

图 3‑43 IPàIP主叫号码变换规则添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
索引 | 号码变换规则的索引，具有唯一性，并且规定了号码变换规则之间的优先级，该配置项的值越小优先级越高。当一通呼叫同时匹配多条号码变换规则时，选用优先级最高的号码变换规则来处理。
呼叫来源 | 表示呼叫来自于哪个SIP中继组。SIP中继组[ANY]来表示任意的SIP中继组。
主叫前缀、被叫前缀 | 主被叫号码开头的字符串，可以用“*”来代表任意字符串，此配置项与呼叫来源 、第二主叫 一起规定了适用这条规则的呼叫。 注：同时可以添加多个主被叫，不同前缀间用“:”分开。
存在原被叫 | 此配置项设置为是 时，只有当呼叫中存在原被叫号码/改发号码时，才会进行相应的号码变换。默认值为否。
左起删除位数 | 将当前号码从左至右删除的号码位数，如果此配置项的值大于当前号码的位数，则删除所有号码。
右起删除位数 | 将当前号码从右至左删除的号码位数，如果此配置项的值大于当前号码的位数，则删除所有号码。
右起保留位数 | 当前号码从右至左最多保留的位数。当号码长度超过该配置项的值时，左边多余的号码都会被删除；当号码长度小于该配置项的值时，则对当前号码不予处理。
前缀添加 | 在当前号码的左边（即号码开头）添加指定的信息。
后缀添加 | 在当前号码的右边（即号码末尾）添加指定的信息。
描述 | 用于标识号码变换规则，方便查看。

注意：左起删除位数 、右起删除位数 、右起保留位数 、前缀添加 、后缀添加 五个配置项的对应操作是按此顺序依次执行的。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。

图 3‑44 IPàIP主叫号码变换界面

点击 图 3‑44 中的修改 可以对已经配置的号码变换规则进行修改，修改界面如 图 3‑45 所示。修改界面各配置项的意义与IPàIP主叫号码变换规则添加 界面的对应配置项相同。修改界面不允许修改索引。

图 3‑45 IPàIP主叫号码变换规则修改界面

如果需要删除号码变换规则，可以在 图 3‑44 界面中选择对应项目前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空规则 可以一键清除所有号码变换规则。


3.6.2 IP to IP被叫变换

IPàIP被叫变换的处理方式与IPàIP主叫变换相同，只是处理的对象由主叫号码变成了被叫号码。IPàIP被叫号码变换界面如 图 3‑46 所示，界面中各配置项的意义及配置方法与 IPàIP主叫号码变换 界面的对应配置项相同。

图 3‑46 IPàIP被叫号码变换界面


3.7 系统工具

系统工具主要用于整个网关程序的维护，包括IP修改、时间同步、信息恢复、日志查询、连通性查询等功能，具体功能列表如 图 3‑47 所示。

图 3‑47 系统工具功能列表


3.7.1 网络设置

图 3‑48 网络设置界面

网络设置界面如 图 3‑48 所示。网关上有两个业务网口，每个网口都可以配置独立的IP地址（IPv4、IPv6）、子网掩码与默认网关。支持配置DNS服务器。

注意：1，这两个业务网口不能使用相同网段的IP地址和默认网关。

2，连接速度和双工模式，网关默认配置为自动侦测，不建议客户随意修改，因为非自动侦测模式有可能引起网口异常情况。网关默认隐藏该配置项，可按“F”按键令其显示。

配置完成后，点击保存 将以上设置存入网关。点击重置 可恢复当前配置。IP地址修改后，需要使用新设置的IP地址重新登录。


3.7.2 授权管理

图 3‑49 授权管理界面

授权管理界面如 图 3‑49 所示，通过上传授权文件导入试用或正式授权，授权文件由我们公司提供，客户不可修改。


3.7.3 管理参数

图 3‑50 管理参数配置界面

管理参数配置界面如 图 3‑50 所示。界面中各配置项的具体说明如下：

配置项 | 说明
WEB端口 | WEB进行访问时所携带的端口号。默认为80。
访问位置 | 设置可以进行WEB访问的IP地址。默认为允许所有IP。可以设置IP白名单允许该名单内的IP自由进行WEB访问。也可以设置IP黑名单，禁止该名单内的IP进行WEB访问。
注销时长 | 设置在该配置时长内无人操作，则网关自动注销。默认时长为1800，单位为秒。
启用SSH | 设置是否开启SSH远程访问功能，默认为否。
SSH端口 | 通过SSH远程访问时所携带的端口号。
启用远程抓包功能 | 启用远程抓包功能后，用户可远程使用抓包工具获取网关的数据包，默认为否。
是否抓取RTP | 设置是否抓取RTP，功能启用后可在所选网口上同时抓取RTP包。
启用FTP | 设置是否启用FTP服务器，默认值为是。
启用看门狗 | 设置是否启用看门狗功能，默认值为是。
启用SYSLOG | 设置是否启用SYSLOG。SYSLOG启用后，需要填写 SYSLOG服务器地址 和 SYSLOG级别。SYSLOG默认为不启用。
服务器地址 | 设置接收日志的SYSLOG服务器地址。
SYSLOG级别 | 设置SYSLOG等级。SYSLOG等级包括：ERROR（错误）、WARNING（警告）和 INFO（一般信息）三种。
监听自适应 | 开启网关和监听工具的NAT穿透。默认为不启用。
启用NTP | 设置是否启用NTP服务器自动同步时间。NTP自动同步启用后，需要填写 NTP服务器的地址 、同步周期 和时区。NTP默认为不启用。
NTP服务器地址 | 设置自动同步时间的NTP服务器地址。
同步周期 | 设置NTP自动同步时间的同步周期。
定时重启 | 设置是否定时重启网关，启用后需要填写重启时间。启用后网关每天会在设定的时间自动重启。默认为不启用此功能。
重启时间 | 设置网关定时重启的时间。
系统时间 | 系统时间，可勾选前面的复选框手动修改。
时区 | 网关所在时区。


3.7.4 IP路由表

用户可以设置IP路由表，网关根据路由表设置信息，将IP包按指定路由发送到目的网段。网关默认没有IP路由信息，可以通过点击列表右下角的添加 进行添加，见 图 3‑51 。

图 3‑51 IP路由表添加界面

以上界面中各配置项的说明如下：

配置项 | 说明
编号 | 该路由在路由表中的编号。
目的网段 | IP包可以到达的网段地址。
子网掩码 | 目的网段对应的子网掩码。
网口 | 该路由表对应的网口。

配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。保存配置后的界面如 图 3‑52 所示。

图 3‑52 IP路由表列表

点击中的修改 可以对已经配置的IP路由表进行修改，修改界面如 图 3‑53 所示。修改界面各配置项的意义与IP路由表添加 界面的对应配置项相同。修改界面不允许修改编号。

图 3‑53 IP路由表修改界面

IP路由表列表下方的删除所选 用于删除选中的路由表；清空 用于一键清除所有路由表。


3.7.5 访问控制

图 3‑54 访问控制列表

访问控制列表（ACL）界面如 图 3‑54 所示，配置ACL后，可以限制网络流量，允许特定设备访问，指定转发特定端口数据包等。点击添加命令，可以添加访问控制命令， 如 图 3‑55 所示。

图 3‑55 访问控制命令添加界面

在命令栏输入ACL命令，配置完成后，点击保存 将以上设置存入网关。点击关闭 可直接取消设置。命令添加后需点击应用 使其生效。

点击 图 3‑54 中的修改 可以对已经配置的命令进行修改，修改界面如 图 3‑56 所示。修改界面各配置项的意义与访问控制命令添加 界面的对应配置项相同。修改界面不允许修改索引。

图 3‑56 访问控制命令修改界面

如果需要删除访问控制列表，可以在 图 3‑54 界面中选择对应项目前的复选框，然后点击删除所选。命令删除后，点击应用 使删除的命令失效。全选 指选中当前页面可以选定的全部项目；全不选 指取消选中当前页面已经选定的全部项目；反选 指取消选中当前页面已选中的项目，并选中原先未选中的项目。清空列表 可以一键清除所有访问控制列表。

注：

1、目前网关只支持iptables命令。

2、如果是手动添加、修改命令后，不会立即生效，需点击应用 使命令生效，手动删除命令也需点击应用，使删除的命令失效。如果是重启以及导入配置的时候，则命令自动生效，无需点击应用。


3.7.6 证书管理

证书管理即信令加密管理（TLS认证管理），为网络通信提供保密性和数据完整性的一种安全协议，用于保护网关SIP信令连接、Web界面和Telnet服务器。证书管理设置界面如 图 3‑57 所示。

图 3‑57 证书管理界面

以上界面中各配置项的说明如下：

配置项 | 说明
国家 | 国家代码，2个大写字母，例如：CN。其他国家详见:ISO 3166-1 A2。
省份 | 省份，如：Zhejiang。
城市 | 城市，如：Hangzhou。
公司 | 公司名称。
部门 | 部门，如：IT Dept。
主机名 | SBC的IP地址。
Email | 邮箱地址。

配置完成后，点击生成证书 将生成TLS证书；点击重置 可恢复当前设置，点击下载证书 可下载证书查看。


3.7.7 集中管理

图 3‑58 集中管理设置界面

集中管理配置界面如 图 3‑58 所示，启用该功能后，网关可以注册到一个集中管理平台，实现集中管理平台对网关的远程管理。界面中各配置项的具体说明如下：

配置项 | 说明
Notification设置 | 网关主动去发送snmp trap告警信息。
自动切换默认网关 | 该功能启用后，当连接设备云管理平台的网线松动或被拔出时，网关会自动通过另一个网口连接设备云管理平台，默认为关闭。
管理平台 | 选择网关需要注册到的管理平台。
公司名 | 网关在三汇设备云管理平台中注册的公司名，仅在管理平台选择为三汇设备云管理平台有效。
网关描述 | 网关挂载到三汇设备云管理平台中显示的描述，便于在设备分组时进行识别，仅在管理平台选择为三汇设备云管理平台有效。
集中管理协议 | 设置集中管理协议，目前仅支持SNMP。
SNMP版本 | SNMP协议的版本号，包括V1、V2和V3三个版本，默认为V2。
SNMP服务器地址 | 允许访问SNMP功能的IP地址。
监听端口号 | 网关上SNMP的监听端口号。
共同体 | 用于获取信息的共同体。
帐号 | SNMP的帐号名。仅在SNMP版本设置为V3时有效。
等级 | SNMP的等级信息，包括不认证，不加密认证不加密和既认证又加密三种，默认为不认证不加密。仅在SNMP版本设置为V3时有效。
认证密码 | 在等级选择为认证不加密或者既认证又加密时，需要同时输入认证密码。
加密密码 | 在等级选择为既认证又加密时，需要同时输入加密密码。
工作状态 | 显示网关与集中管理服务端的连接状态，仅在管理平台选择为三汇设备云管理平台有效。

注：如果用户需要获取网关链路状态和PCM同步状态，需要在SNMP客户端查询OID（对象识别树）=.1.3.6.1.4.1.2021.51。


3.7.8 SIP账号生成工具

图 3‑59 SIP账号生成工具界面

SIP账号生成工具界面如 图 3‑59 所示，网关可将普通的SIP账号和密码转换成网关支持的SIP账户格式，通过数据载入上传需要转换的SIP账号和密码，根据需要，修改SIP中继编号、注册有效期、注册地址和描述等信息后，点击保存，再重新上传SIP账号源文件后，可生成网关支持的SIP账号格式。点击下载，可查看已经生成的SIP账号信息。

注：上传的文件目前只支持txt格式，上传文件中SIP用户名和密码之间必须是“,”隔开。


3.7.9 录音管理

图 3‑60 录音管理设置界面

录音管理设置界面如 图 3‑60 所示，SBO网关可以连接到指定录音服务器上，通过指定网口转发RTP至录音服务器，实现对SBO网关RTP数据抓包。界面中各配置项的具体说明如下：

配置项 | 说明
认证名称 | SBO网关连接到录音服务器上需要通过的认证名。
认证密码 | SBO网关连接到录音服务器上需要通过的认证密码。
录音服务器IP | 和SBO网关连接的录音服务器的IP地址。
录音资源 | 设置进行录音的资源通道数量。
录音开始时机 | 设置开始录音的时机，包括振铃和通话两种。
RTP转发网口 | 设置SBO网关转发RTP的网口。

点击启用开始录音后，需要点击保存 后，才可以设置相关参数。


3.7.10 配置文件

图 3‑61 配置文件界面

配置文件界面如 图 3‑61 所示，通过该界面可以查看和修改网关相关配置文件，包含SMGConfig.ini和ShConfig.ini。其中，SMGConfig.ini是网关服务的配置文件，路由规则、号码变换、号码过滤等的配置都包含在这个文件中；ShConfig.ini是板卡相关的配置文件。用户可直接在界面上修改配置，点击保存 将以上设置存入网关，点击重置 可恢复当前配置。


3.7.11 信令抓包

图 3‑62 信令抓包界面

信令抓包界面如 图 3‑62 所示，网口抓包用于设置需要抓包的网口。点击开始，将对相应的网口进行抓包（最大能抓1024000个包），目前支持SIP和SysLog抓包，用户可选择是否抓取Syslog，启用后需输入Syslog目的地址，将Syslog文件发送至需要的地址。点击停止，停止抓包并下载已抓到的信令包。

双向录音用于设置需要录音的通道组和通道号。点击开始，将对相应通道组的相应通道进行录音（最长能连续录制1分钟）；点击停止，停止录音并下载已有的录音数据。

点击清理录音和抓包，可清空所有录音和抓包文件，点击下载故障日志，下载core文件、配置文件、错误信息等文件在内的所有日志。


3.7.12 呼叫测试

图 3‑63 呼叫测试界面

呼叫测试界面如 图 3‑63 所示。主要用来检测网关上配置的路由和号码变换等是否正确，测试呼叫是否能成功。。

以上界面中各配置项的具体说明如下：

配置项 | 说明
测试类型 | 进行呼叫测试的测试类型。
SIP中继编号 | 选择需要进行呼叫测试的SIP中继编号。
主叫号码 | 呼叫测试时的主叫号码。
被叫号码 | 呼叫测试时的被叫号码。
原被叫号码 | 呼叫测试时的原被叫号码。
DTMF | 通过该配置在通道建立通话后发送DTMF进行通话测试。
添加或修改Invite头字段、字段名称、字段内容 | 配置启用并添加Invite头字段及相应内容。
信令跟踪 | 执行呼叫测试时返回的信令信息，用户可以通过这些信息了解该呼叫测试的具体情况。

配置完成后，点击开始 执行呼叫测试。点击清除 可以清除信令跟踪信息。

注：进行呼叫测试时，网关端无法主动停止测试，只有被叫端结束呼叫，测试才会结束。


3.7.13 呼叫跟踪

图 3‑64 呼叫跟踪界面

呼叫跟踪界面如 图 3‑64 所示。主要用来输出和保存呼叫相关信息，方便出问题时跟踪信息及调试。包含三种模式：过滤主叫、过滤被叫和全部跟踪。点击开始 执行呼叫跟踪，具体信息将显示在下面的跟踪信息栏中。点击停止，可暂停呼叫跟踪。点击过滤 可根据相关设置，对相关呼叫信息进行过滤。点击清空，清空所有跟踪到的呼叫信息。点击下载，下载跟踪到的呼叫信息。


3.7.14 网络测速

图 3‑65 网络测速界面

网络测速界面如 图 3‑65 所示，用于测试网关所在外网的网络速度，选择连接外网的网口，点击开始，选择最优的外网进行测速，测试信息将显示在下面的信息栏。


3.7.15 PING测试

图 3‑66 Ping测试界面

Ping测试界面如 图 3‑66 所示，用户可以通过网关对指定的IP地址进行Ping测试，检测网关与指定地址的连接情况。以上界面中各配置项的说明如下：

配置项 | 说明
源IP地址选择 | 发起Ping操作的源IP地址。
目的地址 | 需要进行Ping测试的IP地址。
Ping的次数 | 进行Ping操作的次数，取值范围为1~100。
包长 | 进行Ping操作的每个数据包的数据长度，取值范围为56~1024字节。
信息 | 执行Ping操作时的返回信息，用户可以通过这些信息了解网关与目的地址之间的网络连接情况。

配置完成后，点击开始 执行Ping操作。点击结束 可以立即结束Ping操作。


3.7.16 TRACERT测试

图 3‑67 Tracert测试界面

Tracert测试界面如 图 3‑67 所示，该测试用于查看网关与指定的IP地址之间的路由情况。以上界面中各配置项的说明如下：

配置项 | 说明
源IP地址选择 | 发起Tracert操作的源IP地址。
目的地址 | 需要进行Tracert测试的IP地址。
最大跳转数 | 能够显示的网关与目的IP之间的最大跳转次数，取值范围为1~255。
信息 | 执行Tracert操作时的返回信息，用户可以通过这些信息了解网关与目的地址之间的详细跳转情况。

配置完成后，点击开始 执行Tracert操作，点击结束 可以立即结束Tracert操作。


3.7.17 修改记录

图 3‑68 修改记录界面

修改记录界面用于查看网关上配置修改的相关记录。点击查看，页面上将显示这些修改记录，如 图 3‑68 所示。点击下载，可下载修改记录。


3.7.18 备份载入

图 3‑69 数据备份、载入界面

数据备份及数据载入界面如 图 3‑69 所示。用户进行数据备份操作时，需要首先通过数据备份栏的下拉菜单选择需要备份的文件类型，然后点击右侧的备份 按钮将对应的文件备份到本地。用户也可以进行数据载入操作，首先通过数据载入栏的下拉菜单选择需要载入的文件类型，其次点击右侧的栏的浏览… 按钮加载本地备份的文件，最后点击上传 将加载的文件上传至网关。网关会自动使用载入的配置信息覆盖当前的配置。


3.7.19 恢复出厂

图 3‑70 恢复出厂界面

恢复出厂设置界面如 图 3‑70 所示，用户可以点击恢复 将网关上的配置恢复到出厂时的默认配置。


3.7.20 软件升级

图 3‑71 软件升级界面

软件升级界面如 图 3‑71 所示，用于升级网关的WEB界面、网关服务以及内核与固件的版本。升级时，通过选择文件 加载对应的*.tar.gz升级包，然后点击更新 等待升级，这时网关会先进行MD5校验，校验通过，方可继续升级。点击重置 可取消上传的更新文件，但不能用于取消更新。


3.7.21 更改口令

图 3‑72 更改口令界面

更改口令界面如 图 3‑72 所示，用户可以在此界面更改网关WEB界面的登录用户名和密码。更改口令需要输入原密码，然后输入新用户名及新密码并确认新密码，修改后点击保存 即可。点击重置 可恢复当前配置。用户名及密码修改后，需要重新登录。


3.7.22 设备锁定

图 3‑73 设备锁定配置界面

设备锁定配置界面如 图 3‑73 所示，用户可以选择至少一项作为判断网关设备是否锁定的条件，即被选中的条件中任意一条内容发生改变，网关设备就会被锁定。设置锁定时需要输入锁定密码，为设备锁定后解锁所用。设置完成后，点击锁定，设备锁定界面将被锁定，如 图 3‑74 所示，输入解锁密码，点击解锁，可对锁定界面进行解锁。

图 3‑74 设备解锁界面

若 图 3‑73 中选定的锁定条件中有任意一条内容发生变化，网关设备就会被锁定，见 图 3‑75 此时，web只开放系统信息、网络设置、更改口令、设备锁定和重启网关这五个页面，呼叫将全部拒绝。进入设备锁定界面（ 图 3‑74 ），输入解锁密码，即可对设备解锁。

图 3‑75 设备锁定界面


3.7.23 重启网关

图 3‑76 重启网关界面

重启服务及重启系统界面如 图 3‑76 所示，用户可以点击重启服务 对网关服务进行重启，或点击重启系统 对网关系统进行重启。


第4章 典型应用配置案例

图 4‑1 典型应用

1. SBO网关SIP设置。

图 4‑2

2. 添加SIP终端的IP地址。

图 4‑3

3. 将SIP中继加入到对应的SIP中继组。

图 4‑4

4. 设置路由参数，此处可使用默认值“号码变换前路由”。

图 4‑5

5. 设置IP->IP路由信息。将来自不同SIP中继组的呼叫路由到相应的SIP中继组上。

图 4‑6

6. 设置号码变换规则。当设备收到来自网络的呼叫时，先检查被叫前缀，发现以7/8开头的呼叫，设备会在路由本次呼叫前删除对应的号码7/8。

图 4‑7


附录A 主要技术/性能参数

外形尺寸：

长×高×深＝440×44×690 mm3

重 量：

约12kg

环境要求：

工作温度：0℃—40℃

储存温度：-20℃—85℃

湿 度：8%— 90% 无结露

储存湿度：8%— 90% 无结露

网络接口：

接口数量：2（10/100/1000 BASE-TX（RJ-45））

自适应带宽：支持

自动翻转：支持

串口：

接口数量：1（RS-232）、8（USB x2）

波特率：115200bps

接口类型：RJ45（信号定义见硬件描述）

数据位：8 bits

停止位：1 bit

校验：无

流控：无

注意：串口连接时，请按照以上配置进行设置，否则可能造成异常。

电源要求：

接入电压：100～240V AC

最大消耗功率：≤167W

信令和协议：

SIP信令：SIP V1.0/2.0、RFC3261

音频编解码速率：

G.711A | 64 kbps
G.711U | 64 kbps
G.729 | 8 kbps
G723 | 5.3/6.3 kbps
G722 | 64 kbps
AMR-NB | 4.75/5.15/5.90/6.70/7.40/7.95/10.20/12.20 kbps
iLBC | 15.2 kbps

采样率：

8kHz

安全防护：

防雷击能力：4级


附录B 常见问题

1、 忘记SBO网关的IP地址，如何重新获得？

长按恢复出厂设置键恢复网关的出厂设置，使网关回到缺省的IP地址，两个网口缺省的地址分别为：

LAN1：192.168.1.101

LAN2：192.168.0.101

2、 哪些情况下可以确定SBO网关设备出现故障，需要联系我公司的技术支持协助解决？

a) 网关设备运行时，运行灯不闪烁或告警灯点亮或闪烁，且重启设备或长按恢复出厂设置键并重启设备后，该状态都不消失。

b) 通话过程中出现无声、单通、声音质量不好等问题。

其它问题比如通道状态显示故障、呼叫不通、注册失败、呼叫号码不正确等情况，一般是由配置错误引起的。用户可以参照第3章 WEB配置仔细检查网关的配置状况。检查配置后，如果仍旧无法排除问题，也可以联系我公司的技术支持。

3、 通过某些浏览器进入网关的WEB界面时无法正常登陆，应该如何处理？

请按如下方法在浏览器上进行设置：进入工具àInternet选项à安全，在“受信任的站点”设置中，添加网关当前的IP地址即可。在使用网关的过程中，如果修改了IP地址，需要将新的IP地址添加到以上设置中。


附录C 技术/销售支持

您在使用我们产品的过程中，有任何疑问都可以与我们联系，我们将尽心尽力提供服务。

公司联系方法：

杭州三汇信息工程有限公司

http：//www.synway.cn

地址：杭州滨江区南环路3756号三汇研发大楼9F

邮编：310053

电话：0571-88861158（总机）

传真：0571-88850923

微信二维码：请扫描下图二维码添加公司微信订阅号了解更多详情。

技术支持：

电话：0571-88921532（工作日8:30 - 17:00）

手机：（0）13306501675（24小时热线）

Email：support@sanhuid.com

销售部：

电话：0571-86695356

Email：13989830066@139.com